作者 主題: [分享]Logitech 滾輪滑鼠的安裝與Ess Solo-1音效卡  (閱讀 4494 次)

0 會員 與 1 訪客 正在閱讀本文。

damon

  • 管理員
  • 俺是博士!
  • *****
  • 文章數: 4227
    • 檢視個人資料
    • http://blog.damon.tw/
各位好,小弟這幾天把家中的破電腦打造成FreeBSD4.6 Release了
一切都很順利,其實是各位先進的文章整理的很好,剛剛搜尋了
一下,對於滾輪滑鼠的部份,在文章中並沒有說得很詳細,對於
的其他部份小弟還在學習中,這邊跟大家分享一下小弟怎麼讓
這隻老古董的Logitech 滾輪滑鼠動起來(歷經了狂完AOE,D2,等等
連線遊戲之後依然工作正常,相容性又高,沒話說),小弟用的是
Logitech First Mouse

01.首先必須先確定XFree86的版本,現在FreeBSD安裝光碟內附的
     版本都有支援了(3.3.2之後的版本)

02.讓滑鼠在console下正常運作/stand/sysinstall設定一下就好

03.設定/etc/X11/XF86Config,找到
     Section "InputDevice"

# Identifier and driver

    Identifier  "Mouse1"
    Driver      "mouse"
    Option "Protocol"     "auto"
    Option "Device"       "/dev/sysmouse"
    Option "ZAxisMapping" "4 5"
     ^^^^^^^^^^^^^^^^^^^^^^^
     在這邊需要注意的是按鑑的算法部份,將滾輪部份視為第四與第
     五鍵,或是可以加上Option "Buttons" 5設定為五鍵滑鼠,還有
      Option "Protocol"  "auto"部份,/stand/sysinstall之後用xf86config設定
      時必須選 2.  Mouse Systems (3-button protocol) & FreeBSD moused protocol
      並將模擬三鍵滑鼠的功能取消,小弟是先設定成在x中能夠先正常
      工作,在修改這部份,不建議加上Option "Buttons" 5,測試時發現
      加上此參數之後頁面捲動的幅度太大,不加的話一樣可以正常運作
      ,但頁面捲動的幅度就很正常,原因不明
      還有Option "Protocol"  "auto"部份,很奇怪,必須設定成"auto"否則
      在x  中會不聽指揮,一直往右上方跑
       http://koala.ilog.fr/colas/mouse-wheel-scroll/中有詳細的說明

05.音效卡的部份,發現有一些小問題,不知道是sound server的問題
     或是aRts sound server的問題,以device pcm加入kernel或是修改
     loader.conf中的snd_solo_load="YES"打開都以以找到音效卡,但有時
     候進入kde時會變成吱吱吱的破音,有時不會,且會佔用sound server
     pcm約30秒到一分鐘,必須等一下子才能用xmms,且有時進入kde時
     聲音正常,登出時卻變成破音....原因待查

梁楓

  • 俺是博士!
  • *****
  • 文章數: 6220
    • 檢視個人資料
[分享]Logitech 滾輪滑鼠的安裝與Ess Solo-1音效卡
« 回覆 #1 於: 2002-07-22 08:06 »
感謝您的分享 ^^