顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


主題 - qrtt1

頁: [1]
1
代碼: [選擇]
void handle (int signal_number){
    printf("recv signal: %d\n", signal_number);
}

foo(){
    struct sockaddr_in sa;
    memset(sa, 0, sizeof(struct sigaction));
    sa->sa_handler = &handle;
    sigaction (SIGPIPE, sa, NULL);
}

各位版友好, 弟使用這段程式註冊signal handler
但不知道要如何在捕抓到適當的signal後停止他的運作,
想請有經驗的版友分享一下

2
各位版友好,
弟正試著在 trace Open Source 專案的程式
它是個 cpp 為主的程式,不過在下列 function 用了 :: 語法
ret = ::select(_sockfd+1, &fdset, NULL, NULL, &tval);
想要詢問一下它有代表什麼特殊意義嗎?
因為有些地方呼叫 select 函式時並沒有加上 ::

3
Linux 討論版 / 開機時卡在 Attached scsi ..
« 於: 2007-12-17 20:18 »
Hi, 各位版友好

我試著在 dell 1950 上安裝 debian amd64

(debian-40r1-amd64-netinst.iso)

並有二個硬碟在 bios 設成 raid 1

雖然安裝好了

但是開機時總會卡在

sd 2:0:0:0 Attached scsi removable disks sdb

這一行, 需要有人按 enter

才會繼續開機的流程



目前心中有幾個疑問:

1. 要做些什麼調整才有辦法讓它順利開機?

2. 如果 sdb 是用來做 raid mirror 的, 那它是否還需要被 attach?


感謝 :)

4
Linux 討論版 / apt-get 遇到相依問題
« 於: 2007-01-30 18:26 »
Hi, 某次用 upgrade 時不慎而終斷了
從此次後就無法再用 apt-get 來安裝東西了 @"@
以下是錯誤訊息,請問有人知道要如何解決呢

代碼: [選擇]
qrtt1@ubuntu:~/test$ sudo apt-get install python2.4-minimal
讀取套件清單中... 完成
了解套件依存關係中... 完成
下列的【新】套件都將被安裝:
  python2.4-minimal
更新 0 個套件,新安裝 1 個套件,刪除 0 個套件,另不更新 176 個套件。
5 個套件沒有完全安裝或刪除完畢。
需要下載 701kB 中 0B 的檔案。
解壓縮後將消耗 2142kB 的空間。

正在預先設定套件 ...
選中了曾被取消選擇的套件 python2.4-minimal。
(正在讀取資料庫 ... 系統目前總共安裝有 136080 個檔案和目錄。)
正在解壓縮 python2.4-minimal (從 .../python2.4-minimal_2.4.2-1ubuntu0.2_i386.deb) ...
正在設定 python2.4-minimal (2.4.2-1ubuntu0.2) ...
Compiling python modules in /usr/lib/python2.4 ...
Compiling /usr/lib/python2.4/site-packages/pythondoc/formatters/format_init.py ...
SyntaxError: ("unqualified exec is not allowed in function 'init' it contains a nested function with free variables",)

Compiling /usr/lib/python2.4/site-packages/pythondoc/xref/xref.py ...
SyntaxError: ("unqualified exec is not allowed in function 'main' it contains a nested function with free variables",)

dpkg:處理 python2.4-minimal (--configure)時出錯:
 子程序·post-installation script·返回了錯誤號·1
dpkg:相依關系問題使得 python-minimal 的設定工作不能繼續:
 python-minimal 相依於 python2.4-minimal (>= 2.4.2)﹔然而:
  套件 python2.4-minimal還沒有被設定。
dpkg:處理 python-minimal (--configure)時出錯:
 相依關系問題 - 仍未被設定
dpkg:相依關系問題使得 python2.4 的設定工作不能繼續:
 python2.4 相依於 python2.4-minimal (= 2.4.2-1ubuntu0.2)﹔然而:
  套件 python2.4-minimal還沒有被設定。
dpkg:處理 python2.4 (--configure)時出錯:
 相依關系問題 - 仍未被設定
dpkg:相依關系問題使得 python2.4-dbus 的設定工作不能繼續:
 python2.4-dbus 相依於 python2.4﹔然而:
  套件 python2.4還沒有被設定。
dpkg:處理 python2.4-dbus (--configure)時出錯:
 相依關系問題 - 仍未被設定
dpkg:相依關系問題使得 python2.4-dev 的設定工作不能繼續:
 python2.4-dev 相依於 python2.4 (= 2.4.2-1ubuntu0.2)﹔然而:
  套件 python2.4還沒有被設定。
dpkg:處理 python2.4-dev (--configure)時出錯:
 相依關系問題 - 仍未被設定
dpkg:相依關系問題使得 python2.4-gdbm 的設定工作不能繼續:
 python2.4-gdbm 相依於 python2.4 (= 2.4.2-1ubuntu0.2)﹔然而:
  套件 python2.4還沒有被設定。
dpkg:處理 python2.4-gdbm (--configure)時出錯:
 相依關系問題 - 仍未被設定
在處理時有錯誤發生:
 python2.4-minimal
 python-minimal
 python2.4
 python2.4-dbus
 python2.4-dev
 python2.4-gdbm
E: Sub-process /usr/bin/dpkg returned an error code (1)

5
肉腳版 / 中文字形相關的問題
« 於: 2003-08-22 22:28 »
http://stumail.ntntc.edu.tw/~s889001/fonterr.jpge
上面這圖是應用程式上的字形,
我也不知改了什麼,他變那麼好了...
看了好難過...><"
有沒有人知道我要改什麼地方才能把他改回來呢?

6
活動/聚會區 / [閒聊]第一次參加聚會
« 於: 2003-07-27 01:25 »
今天是我第一次參加聚會,
看到了netman的講課,心中不覺崇拜起來,一直在內心:「哇~~~~~~`」
其實,上來分享一下心情而已。

netman勾起了我高中的回憶,
我高中的老師是廣香人,
說話的音,很相似呢!

頁: [1]