顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


文章 - p6703

頁: [1]
1
學了Linux一個多月,但是這問題一直困擾著我,雖然我總是有Post問題,問網上的先進,但得到的答案,卻仍無法解開我的疑惑,實在是小弟太笨了,所以只好再上網來問問各位了..........

是否當我們架好Nat Server時,Linux就己算有防火牆的弁鄐F嗎,如果有的話,那它是怎麼去阻擋不法人士的入侵呢,還有如果有的話,那是否也意味著,WWW伺服器無法從別台電腦登入呢,因為我的Linux主機,有架設nat,dhcp,WWW Server,Ftp Server,Mail Server,從別台電腦可以登入我的Ftp server,而e-mail也可順利的發送,但是WWW Server我也有設定好,從連接主機的區網電腦可以看到我的首頁,但從別台電腦要連上時,卻都只會顯示”無法顯示網頁”,我都是照書上及網路上的設定,一步步去設定的,應也沒有錯,但一直就都卡在這裡,所以今天我再大膽的向各位網路的先進請教一下,我要怎樣才能在已架有Nat server的Linux主機下,再架設WWW伺服器呢.....@_@

2
你這種應是稱為死當吧,是每次要重開都這樣嗎,如果是的話,先看看你的常駐程式是不是太多了,否則就是你系統有問題,還是之前不會,最近才開始這樣呢???如果是的話,也請你想想是否有安裝了什麼程式還是去動到硬體配備...

還有新的電腦還是有Reset鈕啊,為什麼你的電腦會沒有嗎,會不會是Reset的按鈕比較小你沒注意到呢....

但如果你真的沒Reset鈕的話又想要重開,當然只有按Power鈕了,至於硬碟是否會因此容易壞呢,我想機會會增加,但卻未必然,最好還是按照正常開關機^_^

3
Netman大大,我依舊不懂也~~~@_@
ipt_config 這程式是做檢測還是設定網路組態呢,還有我一直搞不懂的一件事就是,為什麼我從別台電腦可以Telnet到我的主機,但是卻無法連線到我的網頁呢,我的WWW伺服器也是有開啟的啊,難道是因為我有使用iptaables架NAT的關係嗎,雖然netmane大大你的文章我已看過好幾次了,但請恕小弟愚味,我實在是找不出原因,所以教netman大大能不吝指教........>_<

4
播接???不是啊,我是使用雙向Cable的........

5
還有當我下達了:
smbmount //p6703/linux /mnt/win98時卻出現了

timeout connecting to 63.149.6.91:139
1509: connection to p6703 failed
SMB connection failed

但我的對外IP為210.72.52.XXX,怎會去連接63.149.91.139呢.......

6
netman大大,我已將之前備份的回存了,在執行testparm時也顯示OK,但是為什麼我Win系統中,還是無法從網芳中看到我linux的主機呢

7
還原為Default???怎麼還原成Default呢,因為Samba伺服器設定不是都只要修改smb.conf這個檔案嗎,如果要重新設定的話,那要怎麼做呢........

謝謝netman大大的回應....^_^

8
"撥號配接卡"主要是使用數據機撥接時才會用到嗎,如真是如此,那用寬頻的就是可以刪除這一項,是這樣嗎.....???

9
不知從何時開始,我內部的電腦就沒辦法連接Linux主機了,雖然我早已有架設了Samba伺服器,於是我只好先輸入testparm時測試看看是否我的Smb.conf語法有誤,結果竟出現了
params.c:Parameter() - Ignoring badly formed line in configuration file: two loaded services file Ok
但小弟不知是那出了問題,請好來請教各位了......@_@

10
我有用Linux架起一些服務,如Nat,mail server及DHCP主機,以提供我區網內其餘電腦可以上網,原本使用Win98時,不用再做任何的設定,就可以因Dhcp主機而自動發配到IP,藉此上網,但因我電腦做多重開機,當我用WinXP系統時,卻無法分配到IP,而也因這樣所以無法上網,但怎會如此呢,我也是設定Ip自動取得,但WinXP系統就是無法接受到Linux主機分配的IP........@_@

11
對了~~~還是因為我這塊網卡是D-LINK 530TX的關係呢~~~~~不過怎樣~~~真的很怪~~~也很感謝你熱心的回應我~~~謝謝啦^_^

12
KevinLing兄,說真的,我也不相信啊,不過事實礎b眼前,我實在不得不相信啊,我只要一把網線拔掉後,我用Winipcfg去觀看時,IP位址及子網路遮罩都會顯示0.0.0.0,我原本還以為網卡壞了呢,如果不是因為這是我剛組的零件,我一定會判定網卡壞了,真的很怪.....@_@

13
一般人的電腦中,如果家裡有上寬頻的話,在網路組態下大部份最少都會有該網卡,撥號配接卡及TCP/IP及NETBEUI二項通訊協定,但是小弟想請問的是,到底撥號配接卡的用處是什麼呢,因為就算我把”撥號配接卡”刪除的話,我還是一樣可以上網,也可以用網芳來看到其他台的電腦,而最重要的是,我的開機速度也因此變快了點哦,但為何在網路組態下還要有”撥號配接卡”呢....

14
我錯的離譜啦,原來只要網卡沒接網線,還是網線損壞的話,Win系統就不會自動分配IP給網卡,就算在網路組態下設定IP也是一樣,前提是必須先接上網線.......

感謝KevinLing兄熱心回的回答~~~

15
一般來說,如果我沒設IP位址,子網路遮罩及通訊閘的話,Win系統還是會自動的分配一IP,是嗎~~~~

這跟有沒有接網路線是應沒有關係的吧~~~~

我確定我的網卡沒有壞掉,在裝置管理員也無出現不正常,換了新卡及交換插槽後,情況還是一樣.......但是~~~但是.........

當我將電腦搬到朋友家測試時,卻一切都正常了,用Winipcfg觀看時,已有顯示我設定的IP位址,子網路遮罩及通訊閘,但我不解的是,難道會是因網路線的關係嗎,因為我接網線時,後面的網路燈號不會亮......@_@

16
我有將所有的通訊協定移除後再重新安裝,連網卡的驅動程式都上網去下載新版的更新,但是問題卻還是依舊如此......@_@

17
小弟我的系統為Winme,一開機時也可以看到顯示網卡佔IRQ9,而且用IP分享器完全不用設定就可以上網了,但最近將電腦重移到工作場所,因是固接式寬頻,所以必須設定IP位址,子網路遮罩及通訊閘,沒想到一設完重開用winipcfg時,IP位址及子網路遮罩都顯示為0.0.0.0,我也有把網卡的驅動程式更新,但情況卻依舊如此,不知是那裡出問題了~~~~~@_@

18
請問netman大大,這支script 是在做什麼的呢...???

19
謝謝網中人大大你那麼快就回應,小弟因又有將主機設定nat弁遄A所以在我內部的電腦打入我申請的網址時,是可以連上的,但是只要從外部電腦時,就都沒辦法連接,不過我用telnet也可以順利的登入我的主機哦,因之前我也有上網post過相同的問題,但卻沒有辦法解決,也有人說是防火牆的關係,但如果我使用nat的話,iptables不就一定要開啟嗎.....???

20
小弟是去申請免費動態IP服務,目前己將Mail Server架好了,也可以順利的收發信,但我一直沒辦法將自己的WWW server架起來,但我確定我有啟動WWW服務,而且我用別台電腦ping我的網址時,也能正確的顯示有連接好,但就是用ie要瀏覽時,卻總會顯示無法顯示網頁,不知是小弟那裡設定的問題,請各位高手能不吝指教......@_@

頁: [1]