顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


文章 - 廉價勞工

頁: 1 [2] 3 4 ... 8
31
pci插槽故障 ? 換個插槽試試
南橋晶片故障 ? 換個版子吧

32
那apache 的 error log有看到什麼?

33
出現 404 嗎? 還是其他錯誤?

apache log看一下 , 無法連線通常會有訊息在裡面

從中找出問題點

34
你是設定成  $config['url_path'] = “ /”;    這樣嗎?

試試改成  $config['url_path'] = '/' ;   單引號不是雙引號

35
你notebook抓到的ip是無法連線那台pc原本的ip嗎?
另外notebook手動設定無法連線那台pc的IP也是通的嗎?

36
能正常運作時的網址為何?

http://xxx.xxx.xxx.xxx/cacti 嗎?

37
quotacheck是root才能用的指令

如果是因為沒安裝 , 直接使用yum安裝就好了

38
酷!學園 精華區 / 回覆: CPU負載不平衡
« 於: 2008-11-28 13:52 »
感謝各位的回覆 , 目前已測試成功 , 跟大家分享完整修改過程

的確是因為MSI的影響關係
加上pci=nomsi開機後
eth0跟eth1由PCI-MSI改變為IO-APIC-level
此時smp_affinity參數還是只有指向其中一顆CPU
#cat smp_affinity  結果為 00000002  <=由CPU1工作
這時改smp_affinity參數已可有作用 (PCI-MSI時怎麼改都沒反應)
#echo ff > smp_affinity       
此處CPU分配為HEX , 1=cpu0 , 2=cpu1 , 4=cpu2 , 8=cpu3 後四顆則再進一位
例如我要cpu0跟cpu2兩顆作業,就是#echo 5 > smp_affinity
因我要8顆同時作業故改為 ff
以下為改完後測試結果

代碼: [選擇]
           CPU0       CPU1       CPU2       CPU3       CPU4       CPU5       CPU6       CPU7       
  0:     102261      91525     111568     107161     101577     101559     101558     101568    IO-APIC-edge  timer
  8:          0          0          0          0          0          0          0          1    IO-APIC-edge  rtc
  9:          1          0          0          0          0          0          0          0   IO-APIC-level  acpi
 14:          0          0          0          0          0          0          0          0    IO-APIC-edge  libata
 15:          0          0          0          0          0          0          0          0    IO-APIC-edge  libata
169:       2308        382        535        344        499        368        370        423   IO-APIC-level  ioc0
177:          7          5          6          8          3         10          3          0   IO-APIC-level  uhci_hcd:usb1
185:          0          0          0          0          0          0          0          0   IO-APIC-level  uhci_hcd:usb2
193:        473          7          3          6          4          6          3          6   IO-APIC-level  uhci_hcd:usb3, eth1
201:        560        145      13251        137       6652        175        178       7125   IO-APIC-level  ehci_hcd:usb4
209:     209132     215021     203399     205638     223642     227333     232260     232366   IO-APIC-level  eth0
NMI:          0          0          0          0          0          0          0          0
LOC:     810637     810656     808624     808629     810475     810474     808474     808473
ERR:          0
MIS:          0



39
酷!學園 精華區 / 回覆: CPU負載不平衡
« 於: 2008-11-28 11:32 »
之前已改過smp_affinity作測試
只是不管改成f0或者0f , 還是都只有CPU0在動作

平時還好,連線數一多,cpu0 loading甚至跑上100%
網路流量是正常,就是機器處理不過來,嚴重一點甚至crash必須重開

用其他幾台也做了測試,好像只有HS21的會有這種情形
用另一台HS20的看就還蠻正常

193:  167393904         103814896   IO-APIC-level  eth0
201:  132481412         100143242   IO-APIC-level  eth1

是否跟 PCI-MSI 與 IO-APIC-level 不同有關呢?

40
酷!學園 精華區 / 回覆: CPU負載不平衡
« 於: 2008-11-28 10:27 »
沒有,不只跑程式的時候
只要是跟網路傳輸有關的動作(例如傳送檔案)
都是只有cpu0在做處理動作
所以在eth0跟eth1的欄位,cpu1~7都是掛0


41
酷!學園 精華區 / 回覆: CPU負載不平衡
« 於: 2008-11-28 09:11 »
主機板為  IBM 8853C2U
處理器為  Intel(R) Xeon(R) CPU  X5355  @ 2.66GHz

此機器為 BladeCenter HS21

42
酷!學園 精華區 / CPU負載不平衡
« 於: 2008-11-27 17:40 »
發生好幾次 , 跑個程式讓外面電腦進來做資料交換 , 跑的時候整個速度變很慢
用top看一下發現loading都在 cpu 0 上 (環境是4核心*2 , cpu有0~7)
然後查了一下原因 cat /proc/interrupts 後如下
代碼: [選擇]
           CPU0       CPU1       CPU2       CPU3       CPU4       CPU5       CPU6       CPU7       
  0:   11545582   36998535   37138639   37138472   37138613   37137324   37128604   37128505    IO-APIC-edge  timer
  8:         16        267        273        182        125        301        205        363    IO-APIC-edge  rtc
  9:          0          0          0          0          0          0          0          0   IO-APIC-level  acpi
 14:         19       3414    1089547       1101     659416       3520         24     660679    IO-APIC-edge  ide0
 74:          0          0          0          0          0          0          0          0   IO-APIC-level  uhci_hcd:usb1, uhci_hcd:usb3, ehci_hcd:usb4
 82:          0          0          0          0          0          0          0          0   IO-APIC-level  uhci_hcd:usb2
106:    4518023          0          0          0          0          0          0          0         PCI-MSI  eth0
114:  184896191          0          0          0          0          0          0          0         PCI-MSI  eth1
169:       2883      83712     583107     960988     598394    1377973       8029     137693   IO-APIC-level  aacraid
NMI:          0          0          0          0          0          0          0          0
LOC:  271323598  271323598  271349232  271349231  271349469  271349468  271353042  271353040
ERR:          0
MIS:          0


發現是因為eth0跟eth1都是cpu0在處理,而不像其他是共同負載
請問此種問題有何種解決方式?   

kernel為2.6.18-8.el5
irqbalance 有啟動

43
代碼: [選擇]
Interesting ports on ms.shinning-tech.com (124.10.81.217):
Not shown: 1675 filtered ports
PORT    STATE  SERVICE
22/tcp  open   ssh
25/tcp  closed smtp
53/tcp  open   domain
110/tcp open   pop3
443/tcp open   https

似乎80沒開放成功 , 檢查iptable吧

44
兩台就可以了 , 一台master , 一台slave
兩台本身皆可當client

46
最簡單的方法,直接打 setup,選第一個就是了

如果跑一堆亂碼 , 就打 LANG=C setup

試試看

47
clamd.conf  這個檔

log記錄位置也是在這個檔裡面設定

安裝步驟如果沒錯 , 是會有這個設定檔的

如果找不到 , 建議多裝幾次先熟系安裝的方法

48
設定檔沒設好,看log有什麼錯誤訊息

設定好正常啟動成功,自動會產生sock在設定的path中

49
MIS 討論區 / 回覆: 大家會忌諱 4 或9 嗎?
« 於: 2008-11-18 11:40 »
9應該是日本那邊吧,發音像 苦

50
不是都幫你分析好了   :o

代碼: [選擇]
Sorry, I cannot run apxs.  Possible reasons follow:
1. Perl is not installed
2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is displayed)

51
基本上如果是ext3的,又沒有做其他備份的話...
可以跟它說掰掰了...

不然試試看 debugfs + e2fsck 有沒有用囉

52
有中科的缺嗎?  ;D

53
檢查看看資料夾及其內檔案是否有開read權限
預設來說資料夾權限為755 , 內部檔案權限為644 , owner、group為root

54
環境是固定IP還是DHCP還是PPPOE?
是獨立網路環境還是bridge?
lspci有抓到網卡嗎?
設定完後service有restart嗎?
設定檔中的gateway有打成getway嗎?

55
CDE用NFS掛到B上用Samba分享
您試試看此作法是否可行

56
Outlook 2003 :
Outlook中選工具→選項→偏好→電子郵件選項→進階電子郵件選項→在完成[收件者]、[副本]、[密件副本]欄位時建議名稱,打勾

Outlook Express :
工具列→工具→選項→將 [輸入電子郵件地址時自動補齊] 選項打勾

57
看來是外部DNS被擋掉
ping得到168.95.1.1嗎...
規則看來好像只出不進,有點怪怪的


58
LDAP 討論區 / 回覆: 移除Openldap的問題
« 於: 2008-10-30 17:50 »
#rpm -e xxxx.rpm

59
心  ;D ;D

60
Linux 討論版 / 回覆: cpu loading的問題
« 於: 2008-10-27 14:39 »
你的kernel是?
忘了好像2.4.20之前有bug
跑kswapd會造成cpu loading很高



頁: 1 [2] 3 4 ... 8