顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


文章 - aerocat

頁: [1]
1
LDAP 討論區 / 回覆: Centos v4.6 ldap啟動問題
« 於: 2008-01-12 18:46 »
debug 2天,找不到原因,
上centos網站,好像也沒人反映有類似問題,
只知道v4.6 的 openldap跟samba 搭配有問題,
但我沒有使用samba,也檢查過所有設定,看不出哪裡有問題。



補上 boot.log
Jan 12 17:56:44 linux syslog: syslogd startup succeeded
Jan 12 17:56:44 linux syslog: klogd startup succeeded
Jan 12 17:56:44 linux irqbalance: Can't balance irqs on a uniprocessor system:  failed
Jan 12 17:56:44 linux portmap: portmap startup succeeded
Jan 13 01:56:00 linux rc.sysinit: -e
Jan 12 17:55:58 linux date: Sat Jan 12 17:55:58 CST 2008
Jan 12 17:55:58 linux rc.sysinit: Setting clock  (localtime): Sat Jan 12 17:55:58 CST 2008 succeeded
Jan 12 17:56:01 linux start_udev: Starting udev:  succeeded
Jan 12 17:56:13 linux rc.sysinit: -e
Jan 12 17:56:25 linux sysctl: net.ipv4.ip_forward = 0
Jan 12 17:56:25 linux sysctl: net.ipv4.conf.default.rp_filter = 1
Jan 12 17:56:25 linux sysctl: net.ipv4.conf.default.accept_source_route = 0
Jan 12 17:56:25 linux sysctl: kernel.sysrq = 0
Jan 12 17:56:25 linux sysctl: kernel.core_uses_pid = 1
Jan 12 17:56:25 linux rc.sysinit: Configuring kernel parameters:  succeeded
Jan 12 17:56:25 linux rc.sysinit: Loading default keymap succeeded
Jan 12 17:56:25 linux rc.sysinit: Setting hostname linux:  succeeded
Jan 12 17:56:25 linux rc.sysinit: Checking root filesystem succeeded
Jan 12 17:56:25 linux rc.sysinit: Remounting root filesystem in read-write mode:  succeeded
Jan 12 17:56:26 linux lvm.static:   2 logical volume(s) in volume group VolGroup00 now active
Jan 12 17:56:26 linux rc.sysinit: Setting up Logical Volume Management: succeeded
Jan 12 17:56:26 linux rc.sysinit: Checking filesystems succeeded
Jan 12 17:56:26 linux rc.sysinit: Mounting local filesystems:  succeeded
Jan 12 17:56:26 linux rc.sysinit: Enabling local filesystem quotas:  succeeded
Jan 12 17:56:27 linux rc.sysinit: Enabling swap space:  succeeded
Jan 12 17:56:27 linux microcode_ctl: microcode_ctl startup succeeded
Jan 12 17:56:28 linux vgchange:   2 logical volume(s) in volume group "VolGroup00" monitored
Jan 12 17:56:28 linux lvm2-monitor: Starting monitoring for VG VolGroup00: succeeded
Jan 12 17:56:28 linux readahead_early: Starting background readahead:
Jan 12 17:56:28 linux rc: Starting readahead_early:  succeeded
Jan 12 17:56:38 linux kudzu:  succeeded
Jan 12 17:56:38 linux rc: Starting openibd:  succeeded
Jan 12 17:56:39 linux rc: Starting pcmcia:  succeeded
Jan 12 17:56:39 linux sysctl: net.ipv4.ip_forward = 0
Jan 12 17:56:39 linux sysctl: net.ipv4.conf.default.rp_filter = 1
Jan 12 17:56:39 linux sysctl: net.ipv4.conf.default.accept_source_route = 0
Jan 12 17:56:39 linux sysctl: kernel.sysrq = 0
Jan 12 17:56:39 linux sysctl: kernel.core_uses_pid = 1
Jan 12 17:56:39 linux network: Setting network parameters:  succeeded
Jan 12 17:56:39 linux network: Bringing up loopback interface:  succeeded
Jan 12 17:56:44 linux network: Bringing up interface eth0:  succeeded
Jan 12 17:58:44 linux nfslock: rpc.statd startup succeeded

Jan 12 17:58:45 linux rpcidmapd: rpc.idmapd startup succeeded
Jan 12 17:58:45 linux netfs: Mounting other filesystems:  succeeded
Jan 12 17:58:45 linux autofs5: Load autofs4 succeeded
Jan 12 17:58:45 linux autofs5: automount5 startup failed
Jan 12 18:00:46 linux runuser: config file testing succeeded
Jan 12 18:00:46 linux ldap: Checking configuration files for slapd:  succeeded
Jan 12 18:02:46 linux ldap: slapd startup succeeded

Jan 12 18:02:47 linux smartd: smartd startup succeeded
Jan 12 18:02:47 linux acpid: acpid startup succeeded
Jan 12 18:02:49 linux cups: cupsd startup succeeded
Jan 12 18:02:49 linux sshd:  succeeded
Jan 12 18:02:49 linux xinetd: xinetd startup succeeded
Jan 12 18:02:49 linux vsftpd: vsftpd vsftpd succeeded
Jan 12 18:02:51 linux mysqld: Starting MySQL:  succeeded
Jan 12 18:02:52 linux cyrus-imapd: cyrus-master startup succeeded
Jan 12 18:02:52 linux dovecot: dovecot startup succeeded
Jan 12 18:02:53 linux gpm: gpm startup succeeded
Jan 12 18:02:54 linux httpd: httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
Jan 12 18:02:55 linux httpd: httpd startup succeeded
Jan 12 18:02:55 linux crond: crond startup succeeded
Jan 12 18:02:57 linux xfs: xfs startup succeeded
Jan 12 18:02:57 linux anacron: anacron startup succeeded
Jan 12 18:02:57 linux atd: atd startup succeeded
Jan 12 18:02:57 linux saslauthd: saslauthd startup succeeded
Jan 12 18:02:57 linux readahead: Starting background readahead:
Jan 12 18:02:57 linux rc: Starting readahead:  succeeded
Jan 12 18:02:58 linux messagebus: messagebus startup succeeded
Jan 12 18:02:58 linux cups-config-daemon: cups-config-daemon startup succeeded
Jan 12 18:02:58 linux haldaemon: haldaemon startup succeeded

2
LDAP 討論區 / Centos v4.6 ldap啟動問題
« 於: 2008-01-10 21:44 »
最近準備升到Centos v4.6 所以先裝了一台起來測試,

發現如果啟動openldap後,再加上Authentication Configuration 中 "User Information" enable "Use LDAP,
 
代碼: [選擇]
 
│                     
 |  [ ] Cache Information   [*] Use MD5 Passwords          │                     
│  [ ] Use Hesiod             [*] Use Shadow Passwords      │                     
│  [*] Use LDAP              [*] Use LDAP Authentication    │                     
│  [ ] Use NIS                 [ ] Use Kerberos                     │                     
│  [ ] Use Winbind            [ ] Use SMB Authentication      │                     
│                                  [ ] Use Winbind Authentication   │                     
│                                  [*] Local authorization is sufficient  │                     
│                                                                 │ 


boot過程中在兩個程序會花很多時間,
一個是NFS statd ----3min以上
一個是slapd ----- 3min以上, 主要是checking the configuration file for slapd 花很久時間。

(註)若僅右邊Authentication enable 不會這樣。

進入系統後,ldap運作是正常的,但是如果手動stop ldap 再啟動也是一樣在checking the configuration file for slapd 會停很久。

上線中的電腦 Centos v4.5 則沒有這種現象,
Centos v4.5
openldap-servers-sql-2.2.13-7.4E
openldap-2.2.13-7.4E
openldap-clients-2.2.13-7.4E
openldap-devel-2.2.13-7.4E
openldap-servers-2.2.13-7.4E

Centos v4.6 (已經更新到最新patch,可能非原v4.6 package)
compat-openldap-2.1.30-8.el4_6.2       
openldap-2.2.13-8.el4_6.2               
openldap-clients-2.2.13-8.el4_6.2     
openldap-devel-2.2.13-8.el4_6.2               
openldap-servers-2.2.13-8.el4_6.2         
openldap-servers-sql-2.2.13-8.el4_6.2


有人知道問題出在哪裡嗎?

3
引述: "windychan"
Error message from my system via IE.

Fatal error: call to undefined function:_() in /usr/local/apache/www/ldapadmin/lib/functions.php on line 1015

I never change the file --functions.php

Help me!!! tkx!


Please write down more detail information of your system.
like as
1. OS
2. LDAP version
3. phpldapadmin versio.
4. config.php

Then all people are able to help you to slove the problem quickly.

4
有一個solution 大家可以試一下
http://www.mythtv.org/

5
Linux 討論版 / Re: RedHat 9.0 &RHEL4.0
« 於: 2005-03-29 22:59 »
引述: "nkhg"
請問各位大大
這要去那抓...
找了好久
都沒找到...
有大大可以提示載點之類的嗎...


you can use the redhat EL rebuilder, like as centos , see http://www.centos.org

6
Linux 討論版 / FC3的cyrus-imapd問題
« 於: 2005-03-29 22:57 »
1. do you login as "root" .
2. check the dovecot.conf 權限

7
to dandy:
我對dovecot 是門外漢, 有一個問題請教
請問現在有了dovecot 可以提供pop3s 跟 imaps 服務, 還有需要使用cyrus-sasl嗎?
以你的作法是將認證服務交給sasl, 而dovecot只做pop3 ,
這樣的作法的出發點是什麼?
穩定性?
安全性?
相容性?

8
引述: "hsyah"
在/var/spool/test  也有,權限問題我也檢查過了沒問題
Cyrus-IMAP目前我是考慮先換其他pop3 來先行使用應應急
Cyrus-IMAP事後再慢慢研究,再此先謝謝各位了


你的問題應該是在dovecot.conf中的設定未開啟pop3服務,
請尋找
#protocols = imap pop3
將 "#"拿掉

9
database 討論版 / 請教一個mysql問題.
« 於: 2005-03-12 20:25 »
引述: "paulchensu"
RedHat Enterprise Linux 3 AS 的mysql好像是有問題,
很多人使用後都說有問題.所以裝目前較新的版本會是一種較好的選擇.

我現在就是用RHEL 3,
資料庫部分我覺得還好,
kernel太就有些跟不上時代,很多ap不能用,
不過換 v4, 更新網站部分很痛苦.............

10
database 討論版 / 請教一個mysql問題.
« 於: 2005-03-12 20:23 »
引述: "湯姆貓"
MySQL3.23的資料格式與MySQL4.1有些不同
直接用一定會出問題.
用MySQL3.23的mysqldump出來的資料,
如果是Big5中文資料,
也不能直接塞到MySQL4.1裡,
會有特殊字的問題.

前一陣子我有順利將MySQL3.23的資料移轉到MySQL4.1
步驟如下:
1.利用phpMyAdmin將MySQL3.23的資料dump成文字檔.
2.系統重新安裝MySQL4.1
3.再利用那個文字檔,將資料重新塞回資料庫.
4.若資料沒問題...但是phpBB2卻讀不到資料.
   可能是權限問題,就要再下
UPDATE mysql.user SET Password=OLD_PASSWORD('newpwd') WHERE Host = 'some_host' AND User = 'some_user';
   這個指令


新版對password 編碼的方式不同, 可在/etc/my.cnf中加上下面設定
# Default to using old password format for compatibility with mysql 3.x
# clients (those using the mysqlclient10 compatibility package).
old_passwords=1

11
再跟各位報告一下, 連java sql語法也要跟著改變,
所以沒必要大家先不要用mysql 4.1.xxx
實在太累了

updated....

如果資料中有"許蓋功餐"這些字, 務必 再轉成unicode 後以人工檢查一遍是否有帶"/", 將他移除 後, 再放到 server目錄中. 語系檔也要檢查一下,

另外 redhat es v4 or centos v4 的 gedit好像有問題, 開有中文的php檔會有亂碼問題, 請將檔案改成 *.txt來處理.

12
呵呵呵, 如果沒有時間壓力,我倒是蠻喜歡研究一些新的東西,
這次要更新主機, 最主要是我們的IT等 REDHAT ES的 2.6 kernel好久了,
好不容易readhat出了新版的ES LINUX, 所以要趕快將原先不能用的軟體放上去, 而uft-8 也是重點, 因為有許多國際人士在用, 以前都強迫他們用英文, 現在全部的人都在等我測完, 我是已經快沒力了, 因為'搜尋"還是不能用,已經搞了一個早上. 對的跟search有關的code, 也看不出來要改哪裡.

我只有在一開始弄phpbb2 的時候, 有認真的去看完整個code, 經過2年,現在都忘光了, 我看真的要將phpbb2 升級到最新版.
這次真的太感謝你了....

搜尋功能改好了

13
我已經按照你的新方法,並且測試成功了,
我的頁面文字和資料庫內的資料, 原先在新主機上已經都轉換成utf-8了
所以在原先的code上一定要加上, 資料庫中的中文資料才能正常顯示
======================================
$db->sql_query("SET NAMES utf8;");
$db->sql_query("SET CHARACTER_SET_CLIENT=utf8;");
$db->sql_query("SET CHARACTER_SET_RESULTS=utf8;");
======================================

我有一個疑問,
(1)按照竹貓上的utf-8化文章, 都沒有人提到要加上這一段code, 這是僅有mysql 4.1.10以上才會有的問題嗎?

(2)請問用iconv 轉檔, 跟用piconv 有不同嗎?

14
太感謝了, 本來要放棄了, 我也在竹貓找了很久, 都沒有找到這個方法,


不過還是有一點許蓋功, 不過這點問題應該是不難解決的.


15
現在狀況:
(1)資料庫的資料用phpmyadmin看已經正常,花了好多時間去修改big5-->uft-8轉碼後一些字元亂碼的問題.
(2)網頁中有中文的在browser顯示正常
(3)但是存在資料庫中的資料在browser中卻是亂碼(我有一個phpbb2的forums)



*****************************************************************************

16
Sorry 我剛剛又重新做了一次
原先我轉UTF-8的指令是
 iconv -c -f big5 -t utf-8 phpbbforums.sql -o ppp.sql
部分改成大寫(參考linux 手冊)
 iconv -c -f Big5 -t UTF-8 phpbbforums.sql -o ppp.sql

這樣就可以了,奇怪大小寫有差嗎? 那我這幾天不是............
我在整個重作看看
謝謝

17
現況報告

後來我不轉uft-8, 直接restore dump-file.sql 回去, 這樣phpbb2就可以, (Character Sets and Collations 全部用latin1)
但是從phpmyadmin中看到的都是亂碼, 這樣資料沒辦法維護.
 
   
   請問有什麼辦法可以保留big5格式資料, 但是phpmyadmin可以看到正常中文
   或是一定要轉換成utf-8
   (1)原資料轉成uft-8要怎樣作才會正常      
   (2)非ie 看可以正常顯示嗎?
   (3)另外原先資料中有日文, 可以用incov轉換嗎?
------------------------------------------------------------------------------------  
回覆Darkhero:
是rpm安裝的,
*********************************************
你的方法我會測一下, (ps資料僅有中 , 英文)
中文字部份不見了
用 uft8-unicode_ci , 也會這樣
***********************************************

18
引述: "Darkhero"
就....有個 mysql 的指令..它是個 command line 的程式...
用它可以去聯結資料庫 select 看資料庫狀態等等...


我想應該是Character Sets and Collations  的問題,
我只有mysql 3.xx經驗, 第一次用mysql 4.xx, 第一次遇到Character Sets and Collations  的問題, 而且看起來很複雜, 可能要K一下manual..
我的 server status 請見
http://home.pchome.com.tw/web/jfkwang/mysqlstatus.pdf

19
引述: "Darkhero"
麻煩....
mysql 連進去...
把 status 的狀況傳上來大家看一下..
可能跟 server , client 的 charset 有關...


請問要看哪一些狀況, 譬如要下哪些指令

20
my system is centos 3.4 ---> centos v4 (系統不支援big5)
mysql is 3.23.58 --> 4.1.7 (原資料為big5)
phpmyadmin is 2.6.0
因為要升級系統,而新的系統只支援unicode, 試了很多方法, 都無法將資料轉過去
方法一,  先將資料轉成utf-8,
a. 用mysqldump -u root -p  db_name > db_name.sql
b. 用 windows 下的covertz 轉成utf-8, 傳到新主機,
c. 在新主機, mysql -u root -p db_name < db_name.sql ---> 失敗, 語法錯誤
   (若不轉成utf-8, 就沒問題, 但從phpmyadmin看資料是亂碼,)

方法二,dump下來的資料, 先傳到新主機,
用  iconv -c -f big5 -t utf8 MysqDumpFile.sql 轉完(在textedit 下確定轉成utf-8), 但是 restore 後用phpmyadmin 看是亂碼, phpmyadmin確定語系已經設成
 MySQL 文字編碼: UTF-8 Unicode (utf8)
MySQL 連線校對 utf-8-unicode-ci

方法三, 跟方法二類似, 轉成uft-8 後, 修改dump file 加上
SET NAMES utf8;
SET CHARACTER_SET_CLIENT=utf8;
SET CHARACTER_SET_RESULTS=utf8;

還是亂碼,
請教教我吧

或是可以將資料保留為BIG 5格式

21
我現在的情況是可以登入可以下傳, 但是沒辦法上傳
(1)myos=centos 3.4
(2)目錄已經 chmod 777 -R
(3) 上傳目錄 , 目錄會產生, 但檔案無法上傳
(4)local user 登入也會 進入 虛擬帳號的目錄, 可以讓local user 進入自己的目錄嗎?

22
myos=centos3.4
ups = apc back-up es500

我近日因為安裝ups監控軟體apcupsd, 發現在我以前編譯的新核心(kernel)上不能work, 我想可以是當初在make menuconfig時usb的選項沒設好,
所以我設定好這部分後,重新編譯, 還是不能work
<M> USB Human Interface Device (full HID) support
  • HID input layer support
  • /dev/hiddev raw HID device support hid,


ps1: 所有的核心下,用 cat /proc/bus/usb/devices
都可以看到ups device
ps2: 用 apcaccess status check status
[root@home linux-2.4]# apcaccess status
FATAL ERROR in apcaccess.c at line 243
tcp_open: cannot connect to server localhost on port 3551.
ERR=Connection refused

---------------------------------------------------
我做了一些實驗
(1)在安裝後的原始核心下---是正常的work
(2)用/usr/src/linux-2.4/configs/ 中的config 不修改直接來編譯---不能work
(3)將/lib/modules/2.4.21-27.0.1 copy 到新的module 目錄--- 可以正常工作

所以應該是 make modules時 發生問題, 但是我卻找不到原因,
請大家指導一下

23
Linux 討論版 / 無法同時多pppoe連線
« 於: 2005-02-05 22:22 »
我的經驗:
current myos= centos3.4
this solution was tested on redhat ESv3.0 and centos 3.3

我用x-window介面,在network中設定新的pppoe,不能active, 原因老實講我不知道 , 因為redhat的圖形介面設定好像一直有問題,包括web的設定.

所以我都用telnet,直接去改設定檔案

我的做法:
1. 建議用adsl-setup 去設你第一個pppoe

2. 在/etc/sysconfig/network-scripts中
cp ifcfg-ppp0 ifcfg-ppp1
然後更改一些值, 如下例

USERCTL=yes
BOOTPROTO=dialup
NAME=DSLppp01 <---- here , must change
DEVICE=ppp1 <---- here, must change
TYPE=xDSL
ONBOOT=yes <----- sorry,boot時是否要啟動在這裡
PIDFILE=/var/run/pppoe-adsl01.pid <---- here , must change
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=80 <--- here, depen on you
LCP_FAILURE=3
LCP_INTERVAL=20
CLAMPMSS=1412
CONNECT_POLL=6
CONNECT_TIMEOUT=60 <----- here , depend on you
DEFROUTE=yes <---- look out here for gateway
SYNCHRONOUS=no
ETH=eth0  <-----看你要用哪一張網路卡
PROVIDER=DSLppp01
USER=xxxxxx <---- this your adsl account of you ISP
PEERDNS=no
DEMAND=yes <--- here ,使用yes or no並沒有不同, 因為boot的時候只要在network-scripts中的ifcfg都會被起動, 理論上應該不會但我的系統每次都會,
[這個我忘記要作什麼用了]
-----------------------------


3. reboot 後, 用 ifconfig check 是否正常, 不行在看一下log

4. 請注意設定兩個adsl 連線後,如果get到的IP在同一個subnet下
default gateway會相同, 所以route也會有問題,

比如:
ppp0 --- 140.114.1.1
ppp1 --- 140.114.1.2
default gateway --- 140.114.1.254

route table 中可能會出現
fefault : ppp1
如果原先你的WEB是listen 140.114.1.1 那會從140.114.1.2回去,
對方就會收不到回應.
所以除非 電腦是用來作route(並作IP forward), 你又願意發時間去重寫靜態route. 不然作這個沒什麼效益.

頁: [1]