顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


主題 - aerocat

頁: [1]
1
LDAP 討論區 / Centos v4.6 ldap啟動問題
« 於: 2008-01-10 21:44 »
最近準備升到Centos v4.6 所以先裝了一台起來測試,

發現如果啟動openldap後,再加上Authentication Configuration 中 "User Information" enable "Use LDAP,
 
代碼: [選擇]
 
│                     
 |  [ ] Cache Information   [*] Use MD5 Passwords          │                     
│  [ ] Use Hesiod             [*] Use Shadow Passwords      │                     
│  [*] Use LDAP              [*] Use LDAP Authentication    │                     
│  [ ] Use NIS                 [ ] Use Kerberos                     │                     
│  [ ] Use Winbind            [ ] Use SMB Authentication      │                     
│                                  [ ] Use Winbind Authentication   │                     
│                                  [*] Local authorization is sufficient  │                     
│                                                                 │ 


boot過程中在兩個程序會花很多時間,
一個是NFS statd ----3min以上
一個是slapd ----- 3min以上, 主要是checking the configuration file for slapd 花很久時間。

(註)若僅右邊Authentication enable 不會這樣。

進入系統後,ldap運作是正常的,但是如果手動stop ldap 再啟動也是一樣在checking the configuration file for slapd 會停很久。

上線中的電腦 Centos v4.5 則沒有這種現象,
Centos v4.5
openldap-servers-sql-2.2.13-7.4E
openldap-2.2.13-7.4E
openldap-clients-2.2.13-7.4E
openldap-devel-2.2.13-7.4E
openldap-servers-2.2.13-7.4E

Centos v4.6 (已經更新到最新patch,可能非原v4.6 package)
compat-openldap-2.1.30-8.el4_6.2       
openldap-2.2.13-8.el4_6.2               
openldap-clients-2.2.13-8.el4_6.2     
openldap-devel-2.2.13-8.el4_6.2               
openldap-servers-2.2.13-8.el4_6.2         
openldap-servers-sql-2.2.13-8.el4_6.2


有人知道問題出在哪裡嗎?

2
my system is centos 3.4 ---> centos v4 (系統不支援big5)
mysql is 3.23.58 --> 4.1.7 (原資料為big5)
phpmyadmin is 2.6.0
因為要升級系統,而新的系統只支援unicode, 試了很多方法, 都無法將資料轉過去
方法一,  先將資料轉成utf-8,
a. 用mysqldump -u root -p  db_name > db_name.sql
b. 用 windows 下的covertz 轉成utf-8, 傳到新主機,
c. 在新主機, mysql -u root -p db_name < db_name.sql ---> 失敗, 語法錯誤
   (若不轉成utf-8, 就沒問題, 但從phpmyadmin看資料是亂碼,)

方法二,dump下來的資料, 先傳到新主機,
用  iconv -c -f big5 -t utf8 MysqDumpFile.sql 轉完(在textedit 下確定轉成utf-8), 但是 restore 後用phpmyadmin 看是亂碼, phpmyadmin確定語系已經設成
 MySQL 文字編碼: UTF-8 Unicode (utf8)
MySQL 連線校對 utf-8-unicode-ci

方法三, 跟方法二類似, 轉成uft-8 後, 修改dump file 加上
SET NAMES utf8;
SET CHARACTER_SET_CLIENT=utf8;
SET CHARACTER_SET_RESULTS=utf8;

還是亂碼,
請教教我吧

或是可以將資料保留為BIG 5格式

3
myos=centos3.4
ups = apc back-up es500

我近日因為安裝ups監控軟體apcupsd, 發現在我以前編譯的新核心(kernel)上不能work, 我想可以是當初在make menuconfig時usb的選項沒設好,
所以我設定好這部分後,重新編譯, 還是不能work
<M> USB Human Interface Device (full HID) support
  • HID input layer support
  • /dev/hiddev raw HID device support hid,


ps1: 所有的核心下,用 cat /proc/bus/usb/devices
都可以看到ups device
ps2: 用 apcaccess status check status
[root@home linux-2.4]# apcaccess status
FATAL ERROR in apcaccess.c at line 243
tcp_open: cannot connect to server localhost on port 3551.
ERR=Connection refused

---------------------------------------------------
我做了一些實驗
(1)在安裝後的原始核心下---是正常的work
(2)用/usr/src/linux-2.4/configs/ 中的config 不修改直接來編譯---不能work
(3)將/lib/modules/2.4.21-27.0.1 copy 到新的module 目錄--- 可以正常工作

所以應該是 make modules時 發生問題, 但是我卻找不到原因,
請大家指導一下

頁: [1]