顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


主題 - Rachel

頁: [1]
1
Linux 討論版 / Mail常出現no route to host
« 於: 2003-02-19 09:53 »
各位學長:
請教一個問題.
我將Mail Server升級後(RH7.2升級到RH8.0),伺服器共用兩條線路(一條專線,一條雙向512K),mail用專線,網頁用DSL,有下iproute的指令,讓兩條線各走各的,我有將iproute改用舊版的,iproute的用法是按照之前我提出multihome的問題時,一位學長提供參考的做法.
但是現在Mail常會寄不出去,回覆原因都是
No route to host,message still undelivered after 4 hours
Will keep trying until message is 5 days old
但是收信者都會收到信件,這個很明顯是4小時內郵件寄不出去,4小時後的嘗試寄信就會寄出去了,為什麼呢?
我去測主機上的DNS,Traceroute都可以查到指定主機的IP,route應該沒有問題,
ping或是traceroute都是從eth0出去,eth0是接專線,給Mail使用,我現在想不出一個測試方向,可否請各位學長提示一下,看看是該檢查那一個問題?
謝謝

2
各位學長
請教一下
我的Cisco Route 2611的ethernet0/0都是administratively down
請問該怎樣讓他up起來呢?
謝謝

3
Network 討論版 / 網路卡無法用多個IP
« 於: 2002-11-21 13:57 »
各位學長:
我用RH8,安裝兩片網卡,IP如下,eth0用了6個IP(0-5)
eth0--IP:200.200.200.200
eth0:1-IP:200.200.200.201
---
eth1--IP:60.60.60.200
eth1:1-IP:60.60.60.201
有一個很奇怪的現象
我從別台電腦ping這兩張網卡的IP,eth0可以,但是eth0:1-5就ping不到,ping eth1及eth1:1可以,我就覺得很奇怪,
把兩張網卡的IP對調,ping eth0及eth0:1會有反應,但是ping eth1有反應,ping eth1:1-5就是沒反應,這是什麼怪現象呢?
因為從安裝到增加IP也沒動到其他設定.有可能是哪方面引起的呢?
謝謝

4
Network 討論版 / Routing出問題
« 於: 2002-11-06 18:07 »
各位學長:
我用一台三張網卡的NAT,eth0接ADSL,eth1接專線,eth2接內網,內部上網都用ADSL,收MAIL會經過eth1到專線收,原本都好好的,結果早上重新開機後卻掛點了,上網一樣沒問題,但是就是無法收MAIL,下指令
ping -I 192.168.1.1(eth2)  200.200.200.194(eth1) 有回應
ping -I 200.200.200.194  200.200.200.195  有回應
但是
ping -I 192.168.1.1  200.200.200.195 卻沒反應
也就是說eth2可以ping到eth1,eth1可以ping到同網段的,但是eth2卻無法經由eth1到達專線網段.
我有下route指令
route add -net 200.200.200.192 netmask 255.255.255.192 gateway 200.200.200.194
但是無效,是指令下錯了嗎?還是有其他怪因素呢?
我以前不需用加routing 也可以這樣走
謝謝

5
Linux 討論版 / openwebmail用mysql認證
« 於: 2002-10-29 12:48 »
各位學長:
小弟使用openwebmail,auth是用mysql,小弟自行弄一個資料庫,table用了六個欄位(因為他本來就只要六個),其中u_id欄位是給Linux識別用的,從600起跳,home欄位是user的home folder,例如/home/a,請問一下,
一:我怎樣設定欄位才能讓u_id自動增加呢?我用phpMyAdmin設定有看到一個"附加"是"auto_increment"?可以用嗎?
二:我怎樣設定home folder,讓他可以自動指定/home/username,而不需要指定/home/a是給a用,/home/b是給b用呢?
謝謝

PS:openwebmail可以幫user建立Home Folder,不過必須在openwebmail.conf設定create_homedir為yes,不然會無法使用mysql資料表人員,預設是NO.
另外u_id一定是有,不然會以為是用root登入

6
Linux 討論版 / mdk9.0的user設定有點怪
« 於: 2002-10-17 09:50 »
各位學長:
小弟安裝MDK9.0後,設定一位user為oracle,home設定在/usr/oracle,另外在/usr下增加一個資料夾oraInventory,我將這兩個資料夾的所有人及群組設定為oracle及oinstall,我是在安裝Oracle9iR2,所有一切設定OK後,登出再登入後,卻發現進不了oracle的KDE,原因是無權限,用root登入後一看,原來這兩個資料夾變成root所有,這是第一個問題.
然後再一次將所有權改過後,用oracle再登入一次,就可以了.但是在安裝過程中需要用root執行程式,用su - root執行後,我並沒有跳出root,安裝30%後卻出現無法安裝的訊息,一看又是資料夾變成root的(真的在裝笑為),再把資料夾改回oracle,可以繼續安裝,但是所有權及群組會變成oracle及root,後來再把oracle及oraInventory下的資料全部改為oracle及oinstall,後來有安裝完成約70%,因為資料庫安裝完成後需要一些tool設定要有jre,但是卻沒有可以用的(有i686卻沒有i386).
請問這是什麼怪問題呢?
謝謝

7
酷!學園 精華區 / 整合兩條線路
« 於: 2002-09-20 11:29 »
各位學長:
小弟接兩條線路,一條ISnet專線,一條台固雙向512K-DSL,我架設了一部NAT主機,接了三張網卡,eth0接ISnet,eth1接台固,eth2接內部,在iptables內設定eth0及eth1的IP都對應到內部網路的一部主機,不好意思,設定都是抄Netman學長的.
for PORT in $TRUSTED_TCP_PORT; do
   iptables -t nat -A PREROUTING -i $T_IF -p tcp -d $IS_IP \
      --dport $PORT -j DNAT --to-destination $WWW
done
for PORT in $TRUSTED_TCP_PORT; do
   iptables -t nat -A PREROUTING -i $T_IF -p tcp -d $T_IP \
      --dport $PORT -j DNAT --to-destination $WWW
done
從eth0的IP進去都可以看到內部主機提供的網頁,從eth1就不行,我想是不是這樣會衝突到,從eth0進來的封包知道要經過eth2跑到內部主機,回應的封包知道要從eth0出去,從eth1進來的也可以跑到內部,但是回應不知道要從哪裡走,所以無法從台固IP看到網頁.
所以我就加了下面這一段
iptables -t nat -A POSTROUTING -p tcp -d $WWW --sport 80 -j SNAT --to $T_IP
想當然爾,結果一樣看不到.
是不是應該配合iproute2的功能還是只要用iptables就可以了?
謝謝

8
請Netman學長幫忙一下
謝謝

9
Linux 討論版 / 很奇怪的問題
« 於: 2002-09-19 16:17 »
剛才提問了一個問題,發表成功後點進去後整個網頁都是空白的,以為失敗了,再提問一次也是一樣,看這一次會不會成功?

10
這一兩天發現網路有點慢,剛好把NTOP架設起來,利用他來看一下內部網路狀況,發現有一部機器的流量特別大,短短一個半小時就有100MB流量進入,30幾MB送出,想說下載檔案也不會有這麼多MB送出,看一下NAT內Squid紀錄,原來那一個同事都上Kuro的網站,利用Kuro在下載歌曲,下載就算了,最討厭的就是這種軟體還會分享給其他人,每一台電腦既是Server也是Client,而且還會隱藏PORT,變相的利用port80出去,利用NMAP掃電腦port,還看不出他是怎麼走出去的,後來利用tcpdump捉到這一部電腦跟很多不同的電腦利用6699通訊,才用iptables 擋掉,不過聽說Kuro還可以變換不同的PORT,這樣一來不就每天跟他玩捉迷藏,該怎麼做最好呢?
像ICQ之類的都有很多部Server當主機來做通聯,那Kuro有沒有呢?
謝謝

11
Linux 討論版 / NAT只要給部分電腦上網?
« 於: 2002-05-22 09:54 »
各位學長:
我做一個NAT主機,但是我只想給八部電腦上網,設定是不是如下列:
iptables -t nat -A POSTROUTING -o 192.168.0.1-8/24 -j MASQUERADE
我不想用切mask的方法,因為我可能隨時會增加可上網電腦,而且區域網路中若有人懂設定方法,它可以設定其他IP,那有沒有設限還不是一樣。
另一個問題是如何防止區網中有人再架一部NAT呢?因為這樣會多好幾部電腦上網,會拖垮網路速度。
謝謝

12
各位學長:
有一個很奇怪的問題,我發信給同仁,第一次大概50幾人,結果系統管理者會回信給我說沒有可使用的傳輸者,我把這一封信再寄一次(Outlook的重寄功能),只寄給6個人,她就成功了,再把信寄一次,選了20幾個人,結果又是說沒有可使用的傳輸者,我把第二封退信再寄一次,選了10個人,但又被退信,把第二封或是第三封退信再重寄一次,只寄給4個人,但同樣會被退信,請問一下這是什麼情況呢?信只有在內部跑,利用NAT功能將專線及ADSL連在同一部機器上。
謝謝

13
Linux 討論版 / PostgreSQL啟動時的問題
« 於: 2002-04-09 17:43 »
各位學長:
我在輸入psql後都會出現下列這一行字,請問該怎麼解決呢?

Database "root" does not exist in the system catalog.

謝謝

[ 這篇文章被編輯過:  Rachel 在 2002-04-09 17:45 ]

14
各位學長:
我的板子是微星MS6178,CPU為賽揚500,為了作測試,跟朋友借了一顆P3-600來裝,很不幸的是測試完要將C-500換回去後就無法開機了,連"嗶"一聲都不願意叫了,板子上的電池也拿起來再重新裝回去,CMOS也clean了,jump(就是調時脈的jump,open就可以手調,short就會自動偵測)也調成short了,就是不願意啟動。換成P-600就又可以啟動,怎麼辦呢?又不可能將P-600ㄠ下來。
謝謝

15
Network 討論版 / 無法ping到新架設的Server IP
« 於: 2002-03-15 10:06 »
各位學長:
小弟新架設了二部Server(就是那一部讓我抓狂的Intel IPC612),感謝各位的幫忙,讓我順利成尼髡芋C
那現在有一個小問題,那就是我將這兩部設定ok後,放在專線部分,他的網路通訊都沒問題,都可以ping到外面,那公司內部是用ADSL上網,靠一部NAT上有三張網卡,一張ADSL,一張專線,一張內部虛擬IP,在虛擬IP內ping專線IP都會走NAT的專線IP網卡到專線部分,等於在走內部網路一樣,在NAT主機上ping這兩部Server都可以ping的到,但是內部虛擬IP就ping不到,而其他專線IP就可以ping的到,這該怎麼辦呢?因為有一些檔案要上傳,重新在Server上下傳實在很費工夫,像java的檔案都有30MB左右。
謝謝。
需要在NAT上加routing嗎?
我在NAT打route指令可以看到往專線部分的gateway就是NAT上的專線IP網卡,所以也不知道該怎麼辦?

[ 這篇文章被編輯過:  rachel 在 2002-03-15 11:55 ]

16
Linux 討論版 / user登入權限
« 於: 2002-03-12 15:08 »
各位學長:
請問一下,如果我要讓一個人只可以利用SSH上傳檔案,其他什麼都不能做,應該要如何設定呢?
是改他的shell?還是其他設定呢?
謝謝

17
各位學長:
小弟這一個問題一直無法解決,我想到一個方法,但我不懂得實做,請各位指導一下。
RH7.0可以認得這一組晶片,7.2不行(日京三子學長說原本的aic7xxx模組已經換成別的了),那怎麼利用這一個模組去讓7.2認識晶片呢?(就是怎樣將此模組加入7.2的開機光碟或是磁碟片呢?)
另外像是有一位老兄說他直接將aic7xxx compile 到 kernel, not module.有辦法將安裝光碟中的檔案直接作此修改嗎?
謝謝各位

18
各位學長:
開工大吉(因為歹命的我還在上班)。
我拿一部舊的NoteBook(P166、32MB RAM)安裝RH7.2,因為抓不到PCMCIA卡(D-Link DE660),就又拿Man8.2beta版來裝,結果也抓不到,想說RH比較熟,又將他裝回RH7.2,拿pcmcia-3.x來測試。
問題來了,每一次重新開機都會出現CMOS有問題的畫面,我要將他安裝回Windows,無法fdisk /mbr,作fdisk時將磁區刪掉再重新建立,重開機後一樣找不到磁區,將開機磁片移走,就會重新跑RH,我在想應該是MBR的問題,但怎麼解決呢?
怎麼讓我的HDD恢復正常呢?
謝謝

19
如果有人在安裝Oracle9i的時候會發生類似下列的問題
"Error invoking target install of makefile oracle/product/9.0.1/plsql/lib/ins_plsql.mk
請切換視窗到$ORACLE_HOME/bin/下,並修改genclntsh,找到下列這一行
LD_SELF_CONTAINED="-z defs"
改為
LD_SELF_CONTAINED=""
然後執行此檔案,他會產生一個libclntst9.a,然後再回到安裝畫面,在error的視窗上按retry。
這樣就可以繼續安裝直至安裝完成。
大家參考一下

20
Linux 討論版 / SCSI 晶片 AIC7896的問題
« 於: 2002-01-25 11:40 »
各位學長:
我有一部Intel Server,他使用AIC7896的SCSI晶片(好像很多Server都用這一款),但是問題在於RedHat7.1(Man8.0後也一樣)以上的版本並不支援此晶片,CLE1.0或是RH7.0可以用,Intel並沒有此款晶片的驅動程式For Linux,那可不可從7.0系列的CD或是已經安裝好的Server上找到這一款的模組來使用呢?
如果可以,安裝時要怎麼作呢?
謝謝
PS:是不是在Linux的世界中,前一版可以支援,後一版不能支援是很正常的呢?

頁: [1]