顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


主題 - alumi

頁: [1]
1
Linux 討論版 / Q: sendmail 備援
« 於: 2002-10-21 10:22 »
IN   MX    50   aaa.do.com.
IN             MX  100    bbb.do.com.

當 aaa 主機掛掉 (當機, 斷線. ..... ), bbb 就負責接收 do.com 這個網域的信件,

直到 aaa 正常時, bbb 才會把所收到的信, 傳給 aaa.


Q:
aaa 主機上的 mail account , bbb 是否也要有一份?!

還是 bbb 主機只負責接受 do.com這個網域的信件, 而不會管這個網域是否有
該收件人帳號.

ps: 小弟 不能(也無法) 將 aaa 關機做實驗.

2
Network 討論版 / Proftp & 續傳問題
« 於: 2002-10-09 18:58 »
FTP: Proftp

使用 Anonymous Login 至 Upload , 能 READ / WRITE ,

但是為何不能續傳呢? (斷線後, 接著再傳)

是設定有錯嗎?

User            nobody
Group            nobody

# Normally, we want files to be overwriteable.

  AllowOverwrite      on


# A basic anonymous configuration, no upload directories.

  User            ftp
  Group            ftp
     # We want clients to be able to login with "anonymous" as well as "ftp"
     UserAlias         anonymous ftp

     # Limit the maximum number of anonymous logins
     MaxClients         6

     # We want 'welcome.msg' displayed at login, and '.message' displayed
     # in each newly chdired directory.
     DisplayLogin         welcome.msg
     DisplayFirstChdir      .message

     # Limit WRITE everywhere in the anonymous chroot
     
          DenyAll
     

   
   
      
        Allowall
      


      
        Allowall
      


      
        Allowall
      

   

   
   



3
Network 討論版 / Promiscuous mode enabled.
« 於: 2002-09-24 10:50 »
最近裝了 ntop , 但系統會自動跳出下列的訊息.

這是正常的嗎??

Promiscuous(雜亂的?!) mode enabled.






------- < /var/log/messages > --------
gw1 kernel: device eth0 entered promiscuous mode
gw1 kernel: eth1: Promiscuous mode enabled.
gw1 kernel: device eth1 entered promiscuous mode

4
Network 討論版 / sendmail 啟動問題
« 於: 2002-09-18 11:10 »
在重新啟動 sendmail 時, 出現下列訊息
Shutting down sendmail:                                    [FAILED]
Starting sendmail: 451 4.0.0 /etc/sendmail.cf: line 88: fileclass: cannot open '/etc/mail/local-host-names': Group writable directory
451 4.0.0 /etc/sendmail.cf: line 513: fileclass: cannot open '/etc/mail/trusted-users': Group writable directory
                                                           [FAILED]

再比對一下, 這兩個檔案的權限與屬性, 皆與其他能夠正常工作 的 sendmail server, 並無兩樣.

這奇怪的問題, 是否有人遇到過..

5
Network 討論版 / Multipath
« 於: 2002-09-17 10:28 »
根據 "半套武功密技 Multipath"  的內文試了一下,

發現

1. 兩片對外的網卡, 是不是不能在同一個網段之內?!
    這樣實驗的結果, 連不出去.


ex:

GW1是 Firewall & NAT 接上  ADSL 1 (對內 IP 為 10.0.0.254 )
GW2是 Firewall & NAT 接上  ADSL 2 (對內 IP 為 10.0.0.252 )


而 Multipath 主機 的兩個 對外 Gateway 分別設為 GW1 與 GW2(eth1: 10.0.0.241,GW:10.0.0.254; eth2:10.0.0.242,GW:10.0.0.252, eth0:10.1.1.253)

ps: office  為 10.1.1.0/24

6
Network 討論版 / DNS & List
« 於: 2002-09-02 15:52 »
DNS Server 如何防止 Client , 使用 ls 來 list dns records.

7
Network 討論版 / CISCO 2600 Router & IP Mapping
« 於: 2002-08-19 18:21 »
環境:
CICSO 2600 OS V12
ADSL (固八, NetworkID: 211.23.73.0, ADSL IP: 211.23.73.1,
          可用IP: 211.23.73.2~6, Broadcast: 211.23.73.7,
          Netmask:255.255.255.248)

CISCO 為公司內部虛擬網路的 Gateway 又兼 NAT ,
FastEthernet 0/0 : 211.23.73.6
FastEthernet 0/1 : 192.168.1.254

公司內部虛擬網路: 192.168.1.0 / 255.255.255.0
------------------------------------------------------------------------
欲達成之功能(IP Mapping/Forward)
211.23.73.2 <--> 192.168.1.2
211.23.73.3 <--> 192.168.1.3
211.23.73.4 <--> 192.168.1.4
211.23.73.5 <--> 192.168.1.5

問題:
  公司內部連上192.168.1.2~5 伺服器所開啟的服務都沒問題,
  從Internet 連到 211.23.73.2 ~ 5 伺服器所開啟的服務也沒問題
  (其實也只是藉由CISCO Router 直接對映至虛擬IP).

  1.從公司內部卻連不上211.23.73.2 ~5 ,不過奇怪的是 Ping 卻可以
    ping 的到實體IP ?!
            (CISCO Router 上,小弟並無增設Firewall 的Rule, 而中華電信的ADSL 也無問題)

ps: 目前CISCO Router已移置他處實驗, 而211.23.73.6 是一台臨時架設的Linux.


----------------------------------------------------
測試過程:(從公司內部機器實驗)
  ping 211.23.73.2  --> 有回應.
  telnet 211.23.73.2 80 --> 無回應.
  telnet 192.168.1.2 80 --> 有回應.
  tracert 211.23.73.2 (成功)
  Tracing route to 211-23-73-2.HINET-IP.hinet.net [211.23.73.2]
  over a maximum of 30 hops:

    1   <10 ms   <10 ms   <10 ms  211-23-73-2.HINET-IP.hinet.net [211.23.73.2]

  Trace complete.
  
-------- 以下為 CISCO 2600 設定值 (show config) ----------------
interface FastEthernet0/0
ip address 211.23.73.6 255.255.255.248
no ip directed-broadcast
ip nat outside

interface FastEthernet0/1
ip address 192.168.1.254 255.255.255.0
no ip directed-broadcast
ip nat inside


ip nat pool ta 211.23.73.6 211.23.73.6 netmask 255.255.255.248
ip nat inside source list 1 pool ta overload
ip nat inside source static 192.168.1.5 211.23.73.5
ip nat inside source static 192.168.1.4 211.23.73.4
ip nat inside source static 192.168.1.3 211.23.73.3
ip nat inside source static 192.168.1.2 211.23.73.2

ip classless
ip route 0.0.0.0 0.0.0.0 211.23.73.1
no ip http server

access-list 1 permit any

8
Network 討論版 / sendmail & IP 變更
« 於: 2002-07-31 12:27 »
公司搬家; IP 變動;dns 相關設定皆正確.

目前 mail server 可以寄信,可以收信,但是別人卻寄不進來;
(只能內部自己人寄給自己人)
做了一個簡單的實驗 
1. 使用學校的機器 telnet 至 mail server 25 或 110 Port, 皆無反應.
2. 只有公司的 Gateway 的實體 IP , telnet 至 mail server 才會有反應.

這是怎麼一回事?!原先sendmail 組態,我記得都沒有改過什麼,只是搬個家,
換個IP, mail server 就出問題.

也試著 /etc/mail/access 看看是否有問題,看了之後有沒啥問題,
不知道各位先進,是否有其他的想法.

( mail server 很單純,沒任何防火牆,在 /etc/host*.* 也沒有任何設定.)

9
Linux 討論版 / 環境變數
« 於: 2002-06-03 17:23 »
#!/bin/bash
# --- test.sh ---

kk="1234"

export kk
 
# ----------------

寫了一隻 Shell Script, 但程式執行完後, 無法將 kk 丟入環境變數裡,
若直接下 command , 等到 user logout 後, kk 也會跟著一起不見.

請問, 如何使 Script 程式裡的變數,在程式執行完後, 能夠成為系統環境變數之一.

10
C/C++程式設計討論區 / C++ Environment
« 於: 2002-05-16 22:47 »
我想在 MS Winodws 下寫 純 C++ 物件程式 , (不牽涉到任何系統底層呼叫)

, 是否能推薦好用又免費的開發軟體.

ex: DEV-C++ (不過它的 Debug 介面, 做的很差)

ref: http://www.bloodshed.net/

11
Computer 討論版 / 如何取消 IE 預設瀏灠器
« 於: 2002-05-16 15:16 »
灌了其它的 borwser 軟體, 想把系統預設值(IE)取消,

改用其它的 browser.

12
Network 討論版 / Q: Samba
« 於: 2002-05-13 16:24 »
使用 Samba 分享一個 folder (/data)
使用 微軟 DC 來驗證帳號與密碼. (Linux 本機的帳號密碼與權限皆己建好)

新增一個 user  (useradd -g g_data -d /dev/null -s /bin/false aaa).

開啟網芳, 可以看見與存取 所分享的資料夾 ( data ),

但是 user aaa , 小弟沒有建立它的 home, 為啥 samba 所 share 之 folder , 卻又看見 aaa 這個 folder 呢??

PS: 此 folder 開不起來. 本來以為 將 user home , 設為 /dev/null , 就看不到
       那令人討厭的 user folder.

13
Network 討論版 / iptables & Portscan
« 於: 2002-05-09 18:02 »
上次在討論區, 看到有人使用下列的敍述來擋 Portscan.

 iptables -A INPUT -i eth0 -p tcp --tcp-flags ALL FIN,URG,PSH -j DROP
 iptables -A INPUT -i eth0 -p tcp --tcp-flags SYN,FIN SYN,FIN -j DROP

實測後, Portscan 一樣可以掃, 是敍述錯誤, 還是小弟的擺放順序不對?

14
Linux 討論版 / sed 字串處理問題
« 於: 2002-05-06 16:09 »
欲在一堆文字檔中, 搜尋並替換字串, 發現兩個問題:

1. 單一檔案, 輸出結果不太正確:
    ex:
舊字串: '<net'
新字串: '</usr/src/linux-2.4.7-10/drivers/net'
指    令:  sed 's/\<net/\<\/usr\/src\/linux-2.4.7-10\/drivers\/net/g' qos.h | more
          替換後的字串: '<</usr/src/linux-2.4.7-10/drivers/net'

          多了一個 '<', 不知為什麼會這樣, 原先舊字串一整行的內容如下:
          #include <net/irda/parameters.h>
          理論上替換後, 該行字串應該如下:
          #include </usr/src/linux-2.4.7-10/drivers/net/irda/parameters.h>

2. 不知是否有辦法, 利用一行指令, 搜尋並替換字串
     理論上指令應該如下:
    grep '<net/' -r -l ./ -exec sed 's/\<net/\<\/usr\/src\/linux-2.4.7-10\/drivers\/net/g'  {} \;
    但如何將sed 輸出的結果, 存回原檔案呢??

15
Study-Area 公開討論版 / 討論區 & 亂碼
« 於: 2002-04-25 11:07 »
有時候在看討論區文章時, 會發現文章中, 會夾雜一些亂碼在裡頭,

這是我的 IE 問題, 還是原本就有這個問題存在?

16
Network 討論版 / iptables & PortRedirection
« 於: 2002-04-19 19:11 »
想使用 Port Redirect 功能, 但試了半天, 防火牆上卻一直找不到 Port 80,

應該是此功能沒有起來, 是否有人知道下列的敍述哪個環節出錯了.




#!/bin/bash

# ---------  Flushing ---------
/etc/rc.d/init.d/iptables stop
/etc/rc.d/init.d/iptables start
   
   # ---< Policies >---
   iptables -P INPUT   ACCEPT
   iptables -P OUTPUT  ACCEPT
   iptables -P FORWARD ACCEPT
   iptables -t nat -P PREROUTING   ACCEPT
   iptables -t nat -P POSTROUTING  ACCEPT
   iptables -t nat -P OUTPUT   ACCEPT

   echo '1' > /proc/sys/net/ipv4/ip_forward
   iptables -t nat -A POSTROUTING -o eth0 -j MASQUERADE



Gateway3="61.219.235.222"
Apache_Proxy_Server="10.0.0.250"

        Anywhere="0.0.0.0/0"
        DMZ="10.0.0.0/24"
       
# ---------  Ports Redirection  -------------------------

#   iptables -t nat -A PREROUTING  -p tcp -d $Gateway3 --dport 80 -j DNAT --to $Apache_Proxy_Server
#   iptables -t nat -A PREROUTING  -p udp -d $Gateway3 --dport 80 -j DNAT --to $Apache_Proxy_Server

   iptables -t nat -A PREROUTING  -p tcp -i eth0  --dport 80 -j DNAT --to $Apache_Proxy_Server
   iptables -t nat -A PREROUTING  -p udp -i eth0  --dport 80 -j DNAT --to $Apache_Proxy_Server
   
   iptables -t nat -A POSTROUTING -d $Apache_Proxy_Server -s $DMZ -p tcp --dport 80 -j SNAT --to $Gateway3
   iptables -t nat -A POSTROUTING -d $Apache_Proxy_Server -s $DMZ -p udp --dport 80 -j SNAT --to $Gateway3
      
   
iptables -L

17
Linux 討論版 / Redhat v7.2 & Ghost
« 於: 2002-04-15 14:37 »
有一位朋友, 因為想節省安裝 Redhat 時間(只灌系統, 不做任何設定),

只灌完一台機器, 便用另一顆硬碟, 存放此機器整顆硬碟的 Ghost 檔案,

然後再利用此檔, 再去其它機器做還原, 這樣他就可以省下灌系統的時間.

(其他的機器, 主機板, CPU , 網卡 ... 等都不太一樣)

小弟的潛意識裡, 覺得這不是一個很好的安裝系統方式,

但他卻跟我說 "沒關係, 反正 Redhat 有 PnP 的弁

請問這種安裝法, 會不會產生什麼問題?



18
Linux 討論版 / Group
« 於: 2002-04-03 17:37 »
基本常識小問題:
Linux 下, 是否能 群組 包著 群組?

例如:
g_rd, g_sales, g_finance, g_adm  四個群組,

而 g_everyone, 底下則可擁有 上述四個群組 ?! 這樣是否可行?

還是 /etc/group 此檔內所定義的 群組下, 只能加入使用者, 而不能加入群組.




19
Linux 討論版 / ext2 & ext3
« 於: 2002-03-21 16:06 »
是否有人知道 ext3 的 file system 比 ext2 多出什麼弁

在 NTFS v5.0 的檔案系統, 本身就直接支援 unicode.
不知道 ext3  是否有此弁



20
Network 討論版 / Q: 網路卡 接通
« 於: 2002-03-18 17:33 »
目前電腦裡有三片網路卡, 實驗性質使用,

常常需要換不同區段網路線,

是否有指令來查看哪一張網路卡目前處理被接通的狀態...

PS: 類似微軟2000 作業系統下, 在右下角的網路卡ICON ,可以得知哪張
    網卡, 網路線被拔掉.

21
Linux 討論版 / Q: 燒錄軟體
« 於: 2002-03-16 17:19 »

是否可以推薦一下, 在 Linux 下好用的燒錄軟體?

22
Linux 討論版 / Q: Script
« 於: 2002-03-14 18:46 »
|| 與 && 的差異為何?



 test -r $CHK_FILE && echo "You can read it!"

 test -r $CHK_FILE || echo "You can read it!"
差別為何?

&& 是前面條件成立, 才執行後面的敘述嗎?
那 || 又是什麼意思呢??

23
Linux 討論版 / Q: HardLink
« 於: 2002-03-05 11:05 »
如何得知某個檔案的其它HardLink?

(因為要將所有此檔相關的Hardlink 也一併刪除)

24
Network 討論版 / FTP 連線模式的差異
« 於: 2002-02-22 19:02 »

active mode & passive mode 的最主要差異是否為:

   active mode 的 FTP Server 固定以 port 20 與 Client 端來
   傳送data; 而passive mode 則是以隨機一個 > 1024 的port
   來與client 傳送 data.

 


25
BSD 討論版 / 問題: 系統管理
« 於: 2002-02-21 14:54 »
1. 最近灌 FreeBSD v4.4 & v4.5 結果安裝了 n 次,
   前後使用了三種mouse (COM, PS/2, USB) , 滑鼠都沒有在
   安裝過程中抓到. (BIOS 皆設定正確)

   是否有人的滑鼠安裝, 有跟我一樣的問題及解決辦法.

2. 灌完 FreeBSD 後, 想去修改系統組態..等相關設定, 發現下列的指令,
   完全無法使用 (setup , linuxconf , netconf, Xconfigurator ...)
 
   請問一下, 上述指令, 在 FreeBSD 的相對指令為何?
   ( 尤其是 X-window , 與mouse 設定那部份)

                                                       謝謝.
 

26
Computer 討論版 / 問題:磁帶的基本常識
« 於: 2002-02-20 10:58 »
前一陣子,第一次使用磁帶(HP 24G Tape)備份File-Server,

一塊標榜著 24G 的數位磁帶,根據多次的儲存結論, 一塊24G Tape大概

可以存 16 ~ 17GByte 的資料.(這與小弟心中所想的, 實在有一段很大的落差)

問題: 是否有人瞭解磁帶的儲存原理及計算方式(ex: 記錄間隙..)



27
Network 討論版 / iptables 小問題
« 於: 2002-02-20 10:47 »
最近在 看 netman 的 iptable 文章.

看到 "不考慮網路安全性" 時, 直接使用 IP Masquerading 的範例,

跟在實作, 結果出現下列錯誤訊息:

#iptables -t -A POSTROUTING -o eth0 -s 10.0.0.0/24 -j MASQUERADE

Bad argument `POSTROUTING'
Try `iptables -h' or 'iptables --help' for more information.

------------------

錯誤的參數?!  看了好幾次, 可以確認都沒有打錯字, 是否有人跟我遇到
同樣的問題?


頁: [1]