顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


主題 - takumy

頁: [1] 2
1
各位學長晚安:

小弟查了很多文章都沒有相關的說明, 還有phpbb2 plus 官方論壇好像也在整修,
真的是殘念了= =, 所以上來請教一下各位學長, 幫忙看一下大約的問題是出在那

m(_ _)m

[問題點]
FC5 + phpbb2 plus 1.53a 連線速度(page generate)異常緩慢...

[補充說明]
1.先前有架過phpbb2 plus 1.52 連線速度都很正常
2.目前FC5內建的firewall disable

php Version
php-pear-1.4.9-1
php-pdo-5.1.4-1
php-mysql-5.1.4-1
php-5.1.4-1

httpd version
httpd-2.2.2-1.2

mysql version
php-mysql-5.1.4-1
libdbi-dbd-mysql-0.8.1a-1.2.1
mysql-devel-5.0.22-1.FC5.1
mysql-5.0.22-1.FC5.1
mysql-server-5.0.22-1.FC5.1
mysql-bench-5.0.22-1.FC5.1
mod_auth_mysql-3.0.0-3

2
Network 討論版 / 關於server的maintance問題..
« 於: 2005-06-06 20:56 »
請教各位大大,

弟有一個疑問, 就是server要定期的reboot嗎?

還是一直開著就好?

3
更新了kernel 後...出現以下的訊息...
kernel panic : VFS : Unable to mount root fs on unknow n_block(0,0)

搜尋了forum也沒遇到跟我一樣的問題,
用google去搜尋...

/boot/grub/menu.list

kernel /vmlinuz-2.6.8 ro root =LABEL=/ rhgb quiet
改成
kernel /vmlinuz-2.6.8 ro root =/dev/hd0

結果一樣=.=
請學長們幫一下.....>.<

4
各位先進~!
as title !!!
弟於最近試著在FC2上架設phpbb2 plus 1.3時
到這一個step時...
http://192.168.1.20/phpbb2/install/install.php

只出現空白~!
我有試著看php是否有on
http://192.168.1.20/test.php
是正常的~!
=test.php=
<?
phpinfo();
?>
=======

5
各位先進~
系統:Fedora core 2
小弟在今日安裝openwebmail2.32時發生下面的error msg=.=

[root@mail log]# /var/www/cgi-bin/openwebmail/openwebmail-tool.pl --init
Can't do setuid

suidperl 有安裝了~
官網也上去查囉...但都沒相關資料~
所以才上來求救一下=.=

6
hi~
各位先進~
弟在昨天安裝完FC2後,語系選中文繁體~
但安裝完後,在console mode的setup
畫面都是亂碼>.<
不知該怎麼讓他正常顯示呢???

查了很多FC2的資料,及相關討論,但還是找不到解答~

7
以rpm + apt-get install安裝ntop-2.2.0於 RedHat 8.0

小弟今天用最偷懶的方式來安裝ntop..想不到居然成功了…XD
以下是安裝的步驟…..
跟各位先進分享一下….
------------
1.取得套件
------------
wget http://keihanna.dl.sourceforge.net/sourceforge/ntop/ntop-2.2-0.i386.rpm
rpm –ivh ntop-2.2-0.i386.rpm
apt-get install libpcap
apt-get install librrd.so.0

--------------------
2修改ntop.conf
--------------------

#cp //etc/ntop.conf.sample /etc/ntop.conf
把下列參數enable (去掉mark )
--user ntop
--db-file-path /usr/share/ntop
--interface eth0             =>設成監聽的設備名稱
--no-mac                       
--use-syslog
--track-local-hosts
--http-server 3000            =>預設的http埠
#--https-server 3001         =>次要的http埠,可改成你要的port
--local-subnets 192.168.0.0/24   =>修改成與你的網段一致
--domain www.your.domain.name   =>修改成你的domain name
--reuse-rrd-graphics
--daemon

-----------------------
3.設定admin密碼
-----------------------

/usr/bin/ntop -P /usr/share/ntop -u ntop -A
輸入後,會出現以下的訊息…
[root@tigger root]# /usr/bin/ntop -P /usr/share/ntop -u ntop -A
Wait please: ntop is coming up...
DD/MMM/YYYY HH:MM:SS Initializing IP services...
SSL is present but https is disabled: use -W <https port> for enabling it
DD/MMM/YYYY HH:MM:SS Initializing GDBM...
DD/MMM/YYYY HH:MM:SS Initializing network devices...
DD/MMM/YYYY HH:MM:SS ntop v.2.0.99 ntop-02-04-12.tgz MT (SSL) [i686-pc-linux-gnu] (04/12/02 10:02:15 AM build)
DD/MMM/YYYY HH:MM:SS Listening on [eth0]
DD/MMM/YYYY HH:MM:SS Copyright 1998-2002 by Luca Deri <deri@ntop.org>
DD/MMM/YYYY HH:MM:SS Get the freshest ntop from http://www.ntop.org/
DD/MMM/YYYY HH:MM:SS Initializing......
DD/MMM/YYYY HH:MM:SS Welcome to sFlow: listening on UDP port 6343...
Please enter the password for the admin user:      =>輸入第一次密碼
*****enter the admin password ("admin" is NOT a good idea) and press enter!
Please enter the password again:               =>輸入第二次密碼
*****enter the admin password again and press enter!
*****ntop will store the password and stop.
You should now be able to run ntop as usual.         =>成功囉…

-----------------------
4.啟動ntop
-----------------------
/usr/bin/ntop -P /usr/share/ntop -u ntop

-----------------------
5.觀看成果囉…
-----------------------
http://your.domain.name:3000

參考文章: (內建的FAQ + First run….)
/usr/share/doc/ntop-2.2/1STRUN.txt
/usr/share/doc/ntop-2.2/FAQ

題外話…架設好及寫sop已經凌晨兩點多囉……https的設定方式,小弟還沒時間來的及研究…還望先進指點一下…XD
SSL is present but https is disabled: use -W <https port> for enabling it
~明天加班回來在繼續爬文囉….^^~
參考圖片….



8
Mrtg安裝心得與須注意的地方
小弟我昨天凌晨1點多,心血來潮的想安裝mrtg結果…架設失敗…>.<
今天氣到…請假一天在家裡繼續努力…XD~~~結果成功了~
不自量力的寫這篇sop~希望對大家有所幫助才是~

結論是:Mrtg結果失敗,最大的原因是snmpd.conf這個檔沒設好~

-------------------------------
環境:RedHat 8.0 + Mrtg
-------------------------------
----------------------------------------------
設定snmp.conf /etc/snmp/snmpd.conf
-----------------------------------------------

----///先把以下的mark起來-把預設disable//----
#       sec.name  source          community
#com2sec notConfigUser  default       public
#om2sec mynetwork 192.168.0.0/24 public

# Second, map the security name into a group name:
#       groupName      securityModel securityName
#group   notConfigGroup v1           notConfigUser
#group   notConfigGroup v2c           notConfigUser

#       name           incl/excl     subtree         mask(optional)
#view    systemview    included   .1.3.6.1.2.1.1
#view    systemview    included   .1.3.6.1.2.1.25.1.1

#       group          context sec.model sec.level prefix read   write  noti   f
#access  notConfigGroup ""      any       noauth    exact  systemview none none

----///修改下列-把設定enable起來///----
##       sec.name  source          community
com2sec local     localhost       public
com2sec lan      192.168.0.0/24  public

##     group.name sec.model  sec.name
group MyRWGroup  v1        local
group MyROGroup  v1        lan

##           incl/excl subtree    mask
view all    included  .1          80

##                context sec.model sec.level prefix read   write  notif
access MyROGroup ""      any       noauth    prefix      all    none   none
access MyRWGroup ""      any       noauth    prefix      all    all    all
-----------------------------------------------------------------------------------------------------------------------------------------------
***************!切記!一定要把預設的設定mark起來,不然會出現以下的訊息…*************************
-----------------------------------------------------------------------------------------------------------------------------------------------
[root@pure bin]# ./cfgmaker --output=/var/www/html/mrtg/mrtg.cfg \
> public@127.0.0.1
--base: Get Device Info on public@127.0.0.1:
--base: Vendor Id:
--base: Populating confcache
--snpo: Skipping ifName scanning because public@127.0.0.1: does not seem to support it
--base: Get Interface Info
--base: Walking ifIndex
--base: Walking ifType
--base: Walking ifAdminStatus
--base: Walking ifOperStatus
--base: Walking ifSpeed
--base: Writing /var/www/html/mrtg/mrtg.cfg

*********就是下面這一行….snmp好像會先執行預設的conf檔內容,而skip在後面的設定….*********
--snpo: Skipping ifName scanning because public@127.0.0.1: does not seem to support it

------------------
2.啟動snmp
-------------
service snmpd restart

-----------------------
3.執行Cfgmaker
-----------------------
[root@mail root]# cfgmaker --global 'WorkDir: /var/www/html/mrtg' \
> --global 'Options[_]: bits,growright' \
> --global 'Language: big5' \
> --output /etc/mrtg/mrtg.cfg \
> public@192.168.0.20:
正常的話會出現以下的訊息
--base: Get Device Info on public@192.168.0.20:
--base: Vendor Id:
--base: Populating confcache
--snpo: confcache public@192.168.0.20: Descr lo --> 1
--snpo: confcache public@192.168.0.20: Descr eth0 --> 2
--snpo: confcache public@192.168.0.20: Ip 127.0.0.1 --> 1
--snpo: confcache public@192.168.0.20: Ip 192.168.0.20 --> 2
--snpo: confcache public@192.168.0.20: Type 24 --> 1
--snpo: confcache public@192.168.0.20: Type 6 --> 2
--snpo: confcache public@192.168.0.20: Eth  --> 1
--snpo: confcache public@192.168.0.20: Eth 00-03-6d-30-2a-53 --> 2
--base: Get Interface Info
--base: Walking ifIndex
--base: Walking ifType

---------------
4.執行mrtg
----------------
連續三次直到沒有warnning的訊息出現….
mrtg /etc/mrtg/mrtg.cfg

-------------------------------------------
5.產生流量分析網頁index.html
----------------------------
indexmaker --columns=1 \
--output=/var/www/html/mrtg/index.html \
--title='Traffic Info' \
/etc/mrtg/mrtg.cfg

-------------------------------------
6.觀看mrtg 流量分析表囉…
-------------------------------------
http://your.domain.name/mrtg/index.html

心得….
1.請不要照抄sop的每一個字元….
2.多利用搜尋的功能….

參考文章:
http://www.study-area.org/tips/mrtg.htm netman大大的文章
http://aerosol.ev.ncku.edu.tw/~vbird/safe/04mrtg.html 鳥大的文章

9
Linux 討論版 / [求助]mysql的root密碼遭篡改..
« 於: 2003-11-08 10:05 »
:cry:
向各位大大求助...
小弟的phpBB2 plus 1.3 的forum,
昨天晚上自己要上去檢查看有沒有新
的...結果出現...
======================
phpBB : Critical Error

Could not connect to the database

後來我用mysql -u root -p
進去檢查database...結果用本來的密碼...進不去了!!!!

檢查message沒有異常....
會不會是被駭了......

請各位大大幫小弟解答一下... :oops:

10
請教一下各位大大...
vim可以輸入中文字嗎?
我找了很多文有說~
用 bash 的話加個環境參數就能用了..
export LC_CTYPE=en_US.ISO_8859-1
但小弟在
shell#export LC_CTYPE=en_US.ISO_8859-1
shell#vim test

測試==>..輸入測試二字最後還是出現兩個點?
除了用像jmcce這樣的套件,拿vim沒法子了嗎?

11
以下是我的執行步驟...
[root@localhost mysql]# rpm -e mysql
error: Failed dependencies:
        libmysqlclient.so.10 is needed by (installed) perl-DBD-MySQL-2.1017-3
[root@localhost mysql]# rpm -e perl-DBD-MySQL-2.1017-3
error: Failed dependencies:
        perl-DBD-MySQL is needed by (installed) mysql-3.23.52-3
[root@localhost mysql]# rpm -e mysql-3.23.52-3
error: Failed dependencies:
        libmysqlclient.so.10 is needed by (installed) perl-DBD-MySQL-2.1017-3
 :cry:

我是想架phpbb來玩的,但我照鳥大的文章去做,第一個步驟
建mysql的帳號就出現問題,所以我想把mysql先移掉在安裝
新的版本..但卻移不掉...只好邊找文邊請教各位大大了.....

12
請各位大大幫忙一下....
以下是小弟我用ftpwho來查看連線的使用者...
但我在這16個小時裡,已經reboot N次了
為何這些使用者還是會顯示?
(這些使用者是我測試用的...)

剛去查看了鳥大的文章,但沒看到
可以強迫把使用者ban掉的指令....

[root@localhost root]# ftpwho
inetd FTP daemon:
 1407 test        [16h46m] (  0%) LIST
 1408 takumy  [16h45m] (  0%) LIST
 1411 takumy  [16h43m] (  0%) LIST
  887 takumy   [ 0m36s]  0m36s idle
  888 guest      [ 0m34s]  0m33s idle
  889 guest      [ 0m32s]  0m31s idle
Service class                      -   6 users

13
好感動...這一次FTP Server架設的時間比上次架Sendmail
的時間短很多....
主要還是歸功於"搜尋"
看了很多的文章....最後終於架設好了
其中不免跟之前一樣,把整個os重做....
今天剛架設好時...

第一階段測試
========
區網是OK~

第二階段測試
========
WAN卻失敗了!!!!

請朋友一起來測,卻出現認証失敗....
找了很久...
1.才發現是D-Link DI-704P未支援PASV Mode(Passive Mode)
   要把ftp的軟體裡的該功能關掉
2.而且要在其它的工具裡把ftp port在定義.....(我的port改掉了...)
   重新指定其port並保險一點在virtual server把port指向指好...

心得
===
Linux真的是一個複雜的os....
版本多,安裝方法也多........
不過,還是要堅守住信心!!!!!!!!!
多找文章!
多看文章!
最後的成功一定是你的!!!

 :oops:

14
請教各位大大~
我們公司的mail想要讓發送與收信都自動轉寄到一 個內部特定的
一個mail account,但我找遍了webmin的裡的sendmail設定都找
不到相關可設定自動轉寄的功能耶..

ex:我的想法是這樣的...
===============
~甲公司有三個account~
a@abc.com
b@abc.com
c@abc.com
讓這三個account的信件,收發都自動轉寄到
backup@abc.com,這樣可行嘛?

我是有想過用cron來做備份,但我們公司主要是備份mail而已...

15
as title..
因為我怕user自己不懂然後把檔案給搞亂...

而論壇好像沒有相關的文章說明?

16
環境:
RH8.0+sendmail+sasl+openwebmail 1.90+PLAIN
1.outlook express 收發正常
2.openwebmail 收信正常,發送錯誤...
==========================
相關設定:
#sendmail.cf
sendmail.cf的設定為加入
#Trusted user#
Tapache
Tnobody

#openwebmail.conf
mailspooldir      /var/spool/mail
ow_htmldir      /var/www/html/openwebmail
ow_cgidir      /var/www/cgi-bin/openwebmail
spellcheck      /usr/bin/ispell
default_language   zh_TW.Big5
smtpauth      yes


相關自我測試及debug:
==========================
(1)我有裝了這個套件
ftp://ftp.rpmfind.net/linux/PLD/cur...02-1.noarch.rpm

但執行
/var/www/cgi-bin/openwebmail/openwebmail-tool.pl --init

卻出現
Send the site report?(Y/n) y
sending report...
auth(username, password) at /usr/lib/perl5/5.8.0/Net/SMTP.pm line 113, <STDIN> line 2.

(2)我telnet localhost 25 (從外部及內部去try 25,110 均正常)

Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 mail.mana.com.tw ESMTP Sendmail 8.12.5/8.12.5; Thu, 5 Jun 2003 17:39:00 +0800
ehlo localhost
250-mail.xxxx.com.tw Hello localhost.localdomain [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH GSSAPI LOGIN PLAIN
250-DELIVERBY
250 HELP

(3)我有把openwebmail.conf的
smtpauth 改為no
就可以寄信~

(4)openwebmail 寄信時出現的訊息:
網路伺服器錯誤!
(127.0.0.1 - 5.7.0 authentication failed

================================

所以我想是openwebmail的認証有問題~
但不知要從何去debug...
=.=
我己經有照著這兩篇文章去除bug了..
http://redhat.ecenter.idv.tw/bbs/showthread.php?s=eea61a3091dbcab22c651f86ba98c679&threadid=43094
http://phorum.study-area.org/viewtopic.php?t=15359&highlight=auth
=.=但還是不行耶...
其實除了這兩篇文章,我也翻遍了這個論壇的相關文章了...
求各位大大幫幫忙唄!

17
內部去telnet 110是OK的...
[root@mail root]# telnet 192.168.1.4 110
Trying 192.168.1.4...
Connected to 192.168.1.4.
Escape character is '^]'.
+OK POP3 mail.mana.com.tw v2001.78rh server ready
quit
+OK Sayonara
Connection closed by foreign host.
===================================
用外部的IP去telnet卻失敗...
[root@mail root]# telnet 61.66.x.x 110
Trying 61.66.x.x...
===================================
[root@mail root]# postconf -n
alias_database = hash:/etc/postfix/aliases
alias_maps = hash:/etc/postfix/aliases
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/libexec/postfix
debug_peer_level = 2
inet_interfaces = all
mail_owner = postfix
mail_spool_directory = /var/spool/mail
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man
mydestination = $myhostname, localhost.$mydomain, $mydomain,    mail.$mydomain, www.$mydomain, ftp.$mydomain
mydomain = xxx.com.tw
myhostname = mail.xxx.com.tw
mynetworks = 192.168.1.0/24
myorigin = $mydomain
newaliases_path = /usr/bin/newaliases.postfix
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/postfix-1.1.11/README_FILES
relay_domains = $mydestination
relayhost = $mydomain
sample_directory = /usr/share/doc/postfix-1.1.11/samples
sendmail_path = /usr/sbin/sendmail.postfix
setgid_group = postdrop
smtpd_client_restrictions = permit_sasl_authenticated
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated,      reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_sasl_security_options = noanonymous

18
我sasl認証有起來了~
遠端telnet hostname 25 (與110)
都ok但~outlook express就是不能收發信件~!

 :cry: 以下是我maillog的訊息~
==============================================
May 19 23:42:00 mail postfix/smtpd[1435]: connect from swtp217-244.adsl.seed.net.tw[211.74.217.244]
May 19 23:43:25 mail postfix/smtpd[1435]: disconnect from swtp217-244.adsl.seed.net.tw[211.74.217.244]
May 19 23:45:13 mail postfix/postfix-script: warning: /var/spool/postfix/etc/resolv.conf and /etc/resolv.conf differ
May 19 23:46:11 mail ipop3d[1624]: pop3 service init from 61.222.126.211
May 19 23:46:12 mail ipop3d[1624]: Login user=hptest host=61-222-126-211.HINET-IP.hinet.net [61.222.126.211] nmsgs=0/0
May 19 23:46:12 mail ipop3d[1624]: Logout user=hptest host=61-222-126-211.HINET-IP.hinet.net [61.222.126.211] nmsgs=0 ndele=0
May 19 23:54:37 mail postfix/nqmgr[1288]: 3E70B4A4F1: from=<root@mail.mana.com.tw>, size=1347, nrcpt=1 (queue active)
May 19 23:54:37 mail postfix/nqmgr[1288]: 1703E4A4F2: from=<root@mail.mana.com.tw>, size=1338, nrcpt=1 (queue active)
May 19 23:54:37 mail postfix/local[1745]: fatal: open database /etc/aliases.db: Permission denied
May 19 23:54:37 mail postfix/local[1746]: fatal: open database /etc/aliases.db: Permission denied
May 19 23:54:38 mail postfix/nqmgr[1288]: warning: premature end-of-input from private/local socket while reading input attribute name
May 19 23:54:38 mail postfix/nqmgr[1288]: warning: private/local socket: malformed response
May 19 23:54:38 mail postfix/nqmgr[1288]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
May 19 23:54:38 mail postfix/master[920]: warning: process /usr/libexec/postfix/local pid 1745 exit status 1
May 19 23:54:38 mail postfix/master[920]: warning: /usr/libexec/postfix/local: bad command startup -- throttling
May 19 23:54:38 mail postfix/nqmgr[1288]: warning: premature end-of-input from private/local socket while reading input attribute name
May 19 23:54:38 mail postfix/nqmgr[1288]: warning: private/local socket: malformed response
May 19 23:54:38 mail postfix/nqmgr[1288]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
May 19 23:54:38 mail postfix/master[920]: warning: process /usr/libexec/postfix/local pid 1746 exit status 1


May 20 00:26:11 mail postfix/nqmgr[1838]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
May 20 00:26:11 mail postfix/master[920]: warning: process /usr/libexec/postfix/local pid 1895 exit status 1
May 20 00:26:11 mail postfix/master[920]: warning: /usr/libexec/postfix/local: bad command startup -- throttling
May 20 00:26:11 mail postfix/master[920]: warning: process /usr/libexec/postfix/local pid 1896 exit status 1
May 20 00:26:11 mail postfix/master[920]: warning: process /usr/libexec/postfix/local pid 1897 exit status 1
May 20 00:26:11 mail postfix/nqmgr[1838]: AFFD84A4EF: to=<hptest@mail.mana.com.tw>, relay=none, delay=5840, status=deferred (unknown mail transport error)
May 20 00:26:11 mail postfix/nqmgr[1838]: warning: premature end-of-input from private/local socket while reading input attribute name
May 20 00:26:11 mail postfix/nqmgr[1838]: warning: private/local socket: malformed response
May 20 00:26:11 mail postfix/nqmgr[1838]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description
May 20 00:26:11 mail postfix/nqmgr[1838]: warning: premature end-of-input from private/local socket while reading input attribute name
May 20 00:26:11 mail postfix/nqmgr[1838]: warning: private/local socket: malformed response
May 20 00:26:11 mail postfix/nqmgr[1838]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description

19
hi~各位學長大大.
我的環境是RH8.0 + sasl+openwebmail 2.01但裝好後
啟動openwebmail卻出現以下的訊息...

=================================================================================
sending report...
Can't locate Authen/SASL.pm in @INC (@INC contains: /usr/lib/perl5/5.8.0/i386-li
nux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/5.8.0/i386-linux-
thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl /usr/lib/pe
rl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.0 /
usr/lib/perl5/vendor_perl /var/www/cgi-bin/openwebmail) at /usr/lib/perl5/5.8.0/
Net/SMTP.pm line 101, <STDIN> line 2.
[root@mail root]# cd /backup/openwebmail/

===================================================================================
我有去小紅帽找文章,有位大大說少
ftp://ftp.rpmfind.net/linux/PLD/cur...02-1.noarch.rpm ===>少了這個套件,但這個套件不是MDK的嗎?
mdk跟rh可以共用?

唔..但我 還是先去下載了,結果..出現了以下相依的問題...相關的套件,,我怎麼找都找不到....>.<|||~~~

[root@mail vice]# rpm -ivh perl-Authen-SASL-2.02-1.noarch.rpm
warning: perl-Authen-SASL-2.02-1.noarch.rpm: V3 DSA signature: NOKEY, key ID f96
51d5a
error: Failed dependencies:
        perl(Digest::HMAC_MD5) is needed by perl-Authen-SASL-2.02-1
        perl-Digest-HMAC is needed by perl-Authen-SASL-2.02-1





 :(

20
Linux 討論版 / pam_mysql-0.5.tar.gz裝不起來...
« 於: 2003-05-12 17:28 »
這個安裝是參考王興宇大大的文章的(http://www.cngnu.org/technology/Postfix_I.tw.html#a.6)
但是我照著以下的步驟做..
卻沒有出現 pam_mysql.so 這個檔!!!

===///步驟///===
[root@mail src]# tar -zxf pam_mysql-0.5.tar.gz

[root@mail src]# cd pam_mysql

修改pam_mysql.c的源代碼,去掉調試消息:

[root@mail pam_mysql]# vi +54 pam_mysql.c

將如下一行:
#define DEBUG

修改為:
/* #define DEBUG */

然後編譯:

[root@mail pam_mysql]# make

[root@mail pam_mysql]# cp pam_mysql.so /lib/security

===///相關訊息///===
mkdir -p ./dynamic
gcc -O2 -Dlinux -DLINUX_PAM -ansi -D_POSIX_SOURCE -Wall -Wwrite-strings -Wpointer-arith -Wcast-qual -Wcast-align -Wtraditional -Wstrict-prototypes -Wmissing-prototypes -Wnested-externs -Winline -Wshadow -pedantic -fPIC -DPAM_DYNAMIC  -c pam_mysql.c -o dynamic/pam_mysql.o
pam_mysql.c:35:25: mysql/mysql.h: 沒有此一檔案或目錄
pam_mysql.c:80: parse error before '*' token
pam_mysql.c:80: warning: type defaults to `int' in declaration of `mysql_auth'
pam_mysql.c:80: ISO C forbids data definition with no type or storage class
pam_mysql.c:140: parse error before '*' token
pam_mysql.c:140: warning: function declaration isn't a prototype
pam_mysql.c:142: parse error before '*' token
pam_mysql.c:143: warning: function declaration isn't a prototype
pam_mysql.c:838: parse error before '*' token
pam_mysql.c:838: warning: function declaration isn't a prototype
pam_mysql.c: In function `sqlLog':
pam_mysql.c:885: `user' undeclared (first use in this function)
pam_mysql.c:892: `msg' undeclared (first use in this function)
pam_mysql.c:905: warning: function `mysql_escape_string' was previously declared within a block
pam_mysql.c:951: warning: implicit declaration of function `mysql_real_query'
pam_mysql.c:951: `auth_sql_server' undeclared (first use in this function)
pam_mysql.c:962: warning: function `mysql_error' was previously declared within a block
pam_mysql.c:962: warning: format argument is not a pointer (arg 3)
pam_mysql.c: In function `pam_sm_authenticate':
pam_mysql.c:988: `MYSQL' undeclared (first use in this function)
pam_mysql.c:988: parse error before "auth_sql_server"
pam_mysql.c:1018: `auth_sql_server' undeclared (first use in this function)
pam_mysql.c: In function `pam_sm_chauthtok':
pam_mysql.c:1076: `MYSQL' undeclared (first use in this function)
pam_mysql.c:1076: parse error before "auth_sql_server"
pam_mysql.c:1099: `auth_sql_server' undeclared (first use in this function)

21
Linux 討論版 / 求救!saslauthd認証起不來!
« 於: 2003-05-09 17:15 »
請教各位學長~!!!

我的環境是RH8.0+Postfix+saslauthd+openwebmail
但我做測試的時候(下面)
!!!沒出現===>250-AUTH PLAIN LOGIN !!!
寄的信也不見了!!!

///telnet localhost 25///    test
--------------------------
[root@mail root]# telnet localhost 25
ehlo localhost Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 mail.mana.com.tw ESMTP Sendmail 8.12.5/8.12.5; Fri, 9 May 2003 16:56:40 +0800

501 5.0.0 Invalid domain name
ehlo localhost
250-mail.mana.com.tw Hello mail.mana.com.tw [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN    
250-DELIVERBY
250 HELP
quit
221 2.0.0 mail.mana.com.tw closing connection
Connection closed by foreign host.

!!!沒出現===>250-AUTH PLAIN LOGIN !!!


===相關設定及service的檢查工作...===

///postfix/main.cf///
----------------------
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated,
     reject_unauth_destination
smtpd_client_restrictions = permit_sasl_authenticated
smtpd_sasl_security_options = noanonymous


///etc/postfix/master.cf///
-----------------------------
smtp    inet    n       -       n       -       -       smtpd


///smtpd.conf///
------------------
pwcheck_method: saslauthd
mech_list:plain login

///service檢查///
------------------
[root@mail sasl]# ps -aux | grep pwcheck
root      2185  0.0  0.2  4408  636 pts/0    S    17:11   0:00 grep pwcheck
[root@mail sasl]# ps -aux | grep sasl
root      1387  0.0  0.2  2156  636 ?        S    15:15   0:00 saslauthd -a shad
root      2187  0.0  0.2  4408  636 pts/0    S    17:11   0:00 grep sasl
[root@mail sasl]# ps -aux | grep saslauth
root      1387  0.0  0.2  2156  636 ?        S    15:15   0:00 saslauthd -a shad
root      2189  0.0  0.2  4408  636 pts/0    S    17:11   0:00 grep saslauth

請各位大大幫幫我!
我也有找過相關的文章,但不知從何debug起...>.<||||

22
情形:我從mail server本機用一般user登入=>正常
但用winxp或w2k去http://192.168.1.4/cgi-bin/openwebmail/openwebmail.pl
時出現:無法顥示網頁 =_=
以下是我系統的狀況~

///相關的service都有起來///
xinetd =>ok
httpd =>ok
saslauthd => ok
./openwebmail.pl --init => ok

===///httpd.conf的設定///
--------------------------------------------
<Directory /var/www/cgi-bin>
AllowOverride All
Options ExecCGI
Order allow,deny
Allow from all
</Directory>

///openwebmail.conf的設定///
---------------------------------------------
mailspooldir /var/spool/mail
dbm_ext .db
dbmopen_ext %dbm_ext%
dbmopen_haslock no
ow_cgidir /var/www/cgi-bin/openwebmail
ow_cgiurl /cgi-bin/openwebmail
ow_htmldir /var/www/html/openwebmail
ow_htmlurl /openwebmail
logfile /var/log/mail/openwebmail.log
spellcheck /usr/bin/ispell
default_language zh_TW.Big5
<default_signature>

===///main.cf的設定///
-------------------------------------------
#===///sasl///===
smtpd_sasl_auth_enable = yes
smptd_sasl_local_domain =
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated,
reject_unauth_destination
smtpd_client_restrictions = permit_sasl_authenticated
smtpd_sasl_security_options = noanonymous

#===///postfix///===
inet_interfaces = all
mynetworks = 192.168.1.0/24, 127.0.0.0/8,
hash:/etc/postfix/access
myhostname = mail.mana.com.tw

====================================================
但是咧...其它的pc是ping的到mail server卻無法開啟網頁~
我httpd.conf有在查過了1,是ok的~
想請各位先進幫忙一下看要從那方面去debgu....

23
請各位前輩看一下幫忙我一下.....我今天試了一整天了!!!
===============================
安裝libiconv-1.8.tar.gz時,以下是我的step:
tar -zxvf libiconv-1.8.tar.gz=>ok
cd libiconv-1.8
./configure
卻出現
checking for gcc ... no
check for cc... no
check for cc... no
check for c1... no
configure:error:no acceptable cc found in $PATH


===============================
安裝MIME-Base64-2.12.tar.gz
tar -zxvf MIME-Base64-2.12.tar.gz =>ok
cd MIME-Base64-2.12
perl Makefile.PL =>ok
make
cp QuotedPrint.pm blib/lib/MIME/QuotedPrint.pm
cp Base64.pm blib/lib/MIMEBase.64.pm
/usr/bin/perl /usr/lib/per15/5.8.0/ExtUtils/xsubpp  -typemap /usr/lib/per15/5.8.0/ExtUtils/typemap Base64.xs > Base64.xsc && mv Base64.xsc Base64.c gcc -c -D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -march=i386 -mcpu=i686   -DVERSION=\.....
........
/bin/sh: line 1: gcc:command not found
make:*** [Base64.o] Error 127

=======================================
安裝cyrus-sasl-2.1.12.tar.gz時的問題...
[root @mail root]# cd /usr/local/src
[root @mail src]# tar -zxvf /root/cyrus-sasl-2.1.12.tar.gz
[root @mail src]# cd cyrus-sasl-2.1.12
[root @mail cyrus-sasl-2.1.12]# ./configure   \
> --prefix=/usr/local/cyrus-sasl2 --enable-login --enable-plain \
> --enable-pwcheck --with-saslauthd=/var/run \
按下enter後...
creating cache ./config.cache
checking host system type... i586-pclinux-gnuoldld
checking for a BSD compatible install ... /usr/bin/install -c
checking whether build environment is sane... yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking for gcc... no
checking for cc... no
configure:error: no aceptable cc found in $PATH

============================================
 :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:  :cry:

24
我查過了study area, 鳥哥..
但就是沒有移除的指令..
=_=
我昨天架了openwebmail2.01後,他說perl不穩,要我重新compile..
所以我想重架...

(附帶一提)
我用一般user 登入openwebmail,卻出現
Open WebMail ERROR  
====================================
無法建立使用者目錄! /home/vice/mail (Permission denied)
=.=||| :cry:

25
Linux 討論版 / postfix check出現 time differ
« 於: 2003-05-05 14:23 »
=.=|||我執行了postfix check後出現
 postfix/postfix-script: warning /var/spool/postfix/etc/localtime
and /etc/localtime differ...
這是怎麼一回事...
我有試著去改localtime但出現的是一堆亂碼不知從何改起耶..

26
Linux 討論版 / RH9.0開機後卻沒畫面?!
« 於: 2003-05-05 09:32 »
請教一下各位大大..
我前几天安裝了RH9.0之後一開機~
就沒畫面(是跑完所有的開機程序後,要進入X-win時,monitor
卻好像自己shutdown)
連console也切換不進去..
但電源一直都開著耶
ping也ping的到耶...真怪..

如果我去改runlevel改成3的話~
不知道要怎麼在開機畫面去下指令修改?
我有試過打C(command line)
但沒法子修改...

27
:o 安裝時,按下install 之後....出現以下的訊息...
我有在燒一片了...可是還是不行耶!
請各位大大幫幫我解答一下!
=================================
crc error<6>Freeing initrd memory ?2640k freed
VFS: Cannot Open root device '' or 48:05
Please append a correct "root=" boot option
Kernel panic : VFS Unable to mount root fs on 48:05

28
以下是我規劃的第二版~
但有個問題想請教大家一下...
就是mail server用的到scsi的hd嗎??
以下是情況描述~~~~~~~~~
 :-? ====================================
預估clients 50~100
Mail Server Spec
====Hardware====
CPU    Pentium 4 2.4GHz
HD   IBM 18GB SCSI
RAM     Transcend 128~256 DDR 266 RAM
NIC    Intel Pro 10/100M
Power   300W
CD -Rom Sony 52X
Fan     8x8 2
*SCSI Card ADAPTEC

====OS====
RedHat Linux 9.0
Webmin
OpenWebMail
Postfix+procmail

29
近日公司要架mail server,我是有預設一些spec..
Clients 預估50
====PC Server====
1.Version= RedHat 7.3
2.CPU=P4 2.4 GHz
3.HD= WD 40GB ,8mb buffer
4.RAM =512 DDR 266 RAM
5.NIC=Intel server nic

請教各位大大這樣的Spec夠力嗎??
還有Webmin,sendmail的版本那一版較穩?
(Srry!!!沒做功課就上來po文,因為公司臨時發佈命令.....>.<|||)

30
怪了....
我的RedHat 8.0安裝完後...
有些指令會莫名其妙的消失.....
=.=
還是這些指令不內建在RH8.0 內?.?
連...
cron都不見了....
=.=|||
請各位大大為我解答....
ps 我是用putty ssh進去linux 然後su成root的權限,
而我在本機用時也找不到這些指令.....

頁: [1] 2