顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


主題 - 淺倉中

頁: [1] 2
1
Linux 討論版 / 掃描器只能掃一次?
« 於: 2003-02-23 01:07 »
我的 Microtek 3600在 sane or kooka裡面都可以抓到並掃描

但是有個問題~~進入程式後只要預掃或是掃描過一次之後,

再來就會沒有任何反應,必須要再重新進入程式後才能再動

作,但也是只能操作一次,請問這是怎樣的問題呢?

對了~~他是usb的~~

2
Linux 討論版 / vmware中的ms網芳看不到?
« 於: 2003-02-21 16:43 »
我現在有兩台 RHL7.3,都安裝有 VMware + win2000

透過 samba,linux和win2000之間都分享正常沒問題~~

linux之間也正常!但是很奇怪,反而是兩個 VMware當中的

win2000之間的網路芳鄰會互相看不到!在win2000的檔案總

管裡面,可以互相看到另一台的win2000,但是當要進入時

卻會顯示說 "找不到網路路徑"~~~我已經確定關掉了ms中的

防火牆,在win2000中去 ping 另一台win2000,會出現

request time out....請問這是怎樣一回事呢???

3
我有去下載最新的 sane-backends-1.0.10.tar.gz 回來編譯,說可以支援我這款

的掃描器,

也安裝了 XSane-0.90.tar.gz,也去看了 sm3600.sourceforge.net~~

但是執行 Xsane or sane-find-scanner 卻跟我說找不到掃描器,

但是如果用 microtek3600 的 tarball安裝時,測試的時候可以讓scanner有動作呀~~

請問有人有安裝usb的經驗ㄇ?

4
本文參考螢火飛學姐在酷!學園中的文章寫成,只是加入詳細的安裝步驟。

原文請參考 http://phorum.study-area.org/viewtopic.php?t=14895
---------------------------------------------------------------------------------

先說一下,我的系統是 RedHat Linux7.3 (kernel-2.4.18-19.7.x)

http://www.kde.org 已經釋出 KDE3.1 release,安裝後的桌面可以參考

http://promo.kde.org/3.1/screenshots.php

這邊先介紹第一種下載 tarball 回來編譯安裝的方法

---------------------------------------------------------------------------------

1. 安裝 KDE3.1,必須使用到 Qt-3.1.0 (含以上)的版本,所以必須要先安裝 Qt-3.1.1

您可以到 ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS 去下載,

我是使用 qt-3.1.1-0.4.2.i386.rpm,qt-devel-3.1.1-0.4.2.i386.rpm 和

qt-designer-3.1.1-0.4.2.i386.rpm,您可以下載 3.1.1-6 版回來安裝!

下載回來後,安裝如下:

rpm -Uvh qt-3.1.1-6.i386.rpm --nodeps
rpm -Uvh qt-devel-3.1.1-6.i386.rpm --nodeps
rpm -Uvh qt-designer-3.1.1-6.i386.rpm --nodeps

建議裝好了 qt-3 以後重新啟動一次,讓系統自己把 QTDIR 的位置改成新的

目錄,您可以用 echo $QTDIR 來查看一下,例如:

echo $QTDIR 如果出現

/usr/lib/qt-3.1 , 這樣等下編譯KDE3.1時才會去使用 qt-3.1!

PS:或是去 http://kde-redhat.sourceforge.net,找一下在 KDE3.1 test 或是在

download 當中都有 qt-3.1.1版,但是我的經驗裡面,KDE3.1的 rpm沒辦法

正常安裝,如果您試過可以的話,以rpm來安裝是比較方便又快速的!

2. 在編譯之前,有些程式您要先抓回來安裝,不然等下您在 ./configure 的時候,

會出現錯誤的訊息,跟您說有些檔案沒安裝。

http://mesa3d.sf.net

下載安裝 MesaDemos-5.0.tar.gz

tar -zxvf MesaDemos-5.0.tar.gz
cd MesaDemos-5.0
./configure ; make ; make install

下載安裝 MesaLib-5.0.tar.gz

tar -zxvf MesaLib-5.0.tar.gz
cd MesaLib-5.0
./configure ; make ; make install

http://svg.kde.org/download.html 當中,

下載 libart_lgpl-2.3.11.tar.gz (http://ftp.gnome.org/pub/GNOME/sources/libart_lgpl/2.3/)

tar libart_lgpl-2.3.11.tar.gz
cd libart_lgpl-2.3.11
./configure ; make ; make install

下載 lcms-1.09.tar.gz (http://www.littlecms.com/downloads.htm)

tar -zxvf lcms-1.09.tar.gz
cd lcms-1.09
./configure ; make ; make install

下載 fcpackage.2_1.tar.gz (http://fontconfig.org/)

tar -zxvf fcpackage.2_1.tar.gz
cd fcpackage.2_1
./configure ; make ; make install

下載 freetype-2.1.3.tar.gz (http://sourceforge.net/project/showfiles.php?group_id=3157)

tar -zxvf freetype-2.1.3.tar.gz
cd freetype-2.1.3
./configure ; make ; make install

3. 下載並安裝 KDE3.1

ftp://ftp.uni-kl.de/pub/linux/kde/stable/3.1/src/ 下載下面的 *.tar.bz2

arts-1.1.tar.bz2
kdelibs-3.1.tar.bz2
kdebase-3.1.tar.bz2
kdenetwork-3.1.tar.bz2
kdegraphics-3.1.tar.bz2
kdeadmin-3.1.tar.bz2
kdemultimedia-3.1.tar.bz2
kdegames-3.1.tar.bz2
kdeaddons-3.1.tar.bz2
kdeartwork-3.1.tar.bz2

注意: 編譯安裝的時候,要按照上面的順序,下面以第一個檔案為範例。

bunzip2 arts-1.1.tar.bz2
tar -xvf arts-1.1.tar
cd arts-1.1
./configure ; make ; make install

其他檔案如上方法依序進行編譯安裝。

再來下載中文化檔案,

ftp://ftp.uni-kl.de/pub/linux/kde/stable/3.1/src/kde-i18n/kde-i18n-zh_TW-3.1.tar.bz2

編譯安裝方法同上。

4. 修改使進入 X window 能進入到 KDE3.1

vi .bashrc

在其中加入一行 PATH=/usr/local/kde/bin:$PATH

5. 重開機再進入到 X window,您就可以看到中文化的 KDE3.1 環境囉!

6. 如果您還想要編譯安裝其他的 KDE3.1 程式,請自行抓回,不拘順序!

上面只是基本的安裝法!

5
本文參考多篇文章寫成,原文章如下:

http://phorum.study-area.org/viewtopic.php?t=14715&highlight=gaim


在使用 Gaim 中的 yahoo messanger,其中對方會看不到您所打的中文字,

就算是使用了 Gaim 0.59.8 版的也會有同樣的問題,必須要下載 tarball 回來

修改後再重新編譯才能修正這個問題。步驟如下:

1.去 http://gaim.sourceforge.net/downloads.php 下載最新的 tarball 版本

我是抓回 gaim-0.59.8.tar.gz

2. tar -zxvf gaim-0.59.8.tar.gz

cd gaim-0.59.8/src/protocols/yahoo

vi yahoo.c (修改程式碼),在大約1199行加入下面三行!

1196 yahoo_packet_hash(pkt, 1, gc->displayname);
1197 yahoo_packet_hash(pkt, 5, who);
1198 yahoo_packet_hash(pkt, 14, utf8);
+ yahoo_packet_hash(pkt, 63, ";0");
+ yahoo_packet_hash(pkt, 64, "0");
+ yahoo_packet_hash(pkt, 97, "1");

好了之後存檔,重新編譯!

./configure
make
make install

這樣就可以了!

3.美化 Gaim 字型顯示:

修改 .gtkrc

style "gtk-default-zh-tw" {
fontset = "-adobe-helvetica-medium-r-normal--11-*-*-*-*-*-iso8859-1,\
-Arphic-AR PL KaitiM Big5-medium-r-normal--13-130-0-0-c-13-big5-0,\
-*-*-medium-r-normal--13-*-*-*-*-*-big5-0,*-r-*"
}
class "GtkWidget" style "gtk-default-zh-tw"

您可以把上面13改成16,以增加中文字的大小,11改成14以增加英文字的大小!

修改 /etc/X11/XF86Config-4

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "/usr/X11R6/lib/X11/fonts/TrueType/"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/local/"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/Speedo/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
EndSection

並在Gaim程式中,工具 -> 偏好設定 -> 交談 -> 忽略字型

這樣就可以取代多種即時訊息的軟體囉!

6
酷!學園 精華區 / 如何安裝 KDE3.1 release?
« 於: 2003-01-29 16:35 »
剛剛看到 http://www.kde.org 已經釋出 KDE3.1 版~~

樣子真是美呢!想抓回來安裝看看,但是裡面套件實在很多,

我現在是 KDE3.0.3版,每次我要安裝更新的版本,他就會跟我說那個檔案有

相依性的問題,都沒辦法繼續安裝下去,我只好用 up2date 的方式,

另外,如果我安裝了3.1版,會不會有些原來的程式會因為相依性的問題

而不能執行了???

請問大家如果這樣要升級的話,應該如何來安裝這個3.1版呢?

7
Linux 討論版 / Gaim對方看不到中文?
« 於: 2003-01-27 22:23 »
經過設定後,我的Gaim可以正常看到對方所打的中英文~~

大小和字體都正確~~但是對方(yahoo)跟我說看到的是亂碼~~

英文則可以看得懂~~~

請問這是怎樣一回事呢?

8
同樣寫在前面,先說一下我的系統及軟體環境!

我是使用RHL7.3(kernel-2.4.18-19.7.x),利用 up2date 的方式已經將

mozilla 升及到 1.0.1 版,及 ghostscript 6.52版,同時是 ghostscript-fonts.5.50-3版

mozilla在還未調整之前,就算您使用到 mozilla-1.3a 版,在列印含有中文字的網頁時,

您會發現中文字全都變成了方格,Galeon也是一樣,Netscape好像才可以正常列印,

但是比較起來,mozilla對網頁內容的呈現和支援性比較棒,調的好可以比 IE 來的更

棒,所以mozilla如果不能中文列印,是相當可惜的一件事,相信很多RHL7.3的使用

者對這一點也是牙癢癢的吧!回歸主題,另外如果您是使用RHL7.3內附安裝的

mozilla時,它是英文介面的,您也可以把它中文化,甚至是直接抓回中文版的安

裝程式回來安裝,下面我就針對兩大部份來說明我的經驗:

一: mozilla 1.0.1 中文化,將程式的字型增大(或縮小),或是使您可以使用繁

體中文的 Google 搜尋等等。這些修正您都可以在下面林弘德先生的網站裡

面找到,設定方法裡面都有說了,這一點容我略過!裡面還有相當多不錯

的內容值得參考!

http://www.csie.ntu.edu.tw/~b7506051/mozilla/index.html

二: mozilla 列印中文字網頁的修正,我的經驗大部份是取自下面這篇 Slackware8.1

中mozilla列印中文字修正的文章,只是我還沒看到有針對 Red Hat Linux 7.3的

完整修正步驟,希望對大家有所幫助。原文出自:

http://zope.slat.org/Members/Keanu/slack_cprint/slack_cprint.stx/view

在進行修正步驟之前,上面的原文是針對 Slackware8.1的環境,它是內定安

裝了 ghostscript-7.05 版,但是我的 RHL7.3 經過 up2date 升級後是 6.52 版,

所以目錄上的位置會跟原文不同,這邊要注意一下,萬一您的RHL7.3所用

的 ghostscript 版本不同的話,記得先查看一下真正的位置在那裡,可別改

錯了,另外,上面的原文中有些地方的修正步驟在RHL7.3當中是已經自動

修正過的,這些我就會跳過,不列在下面實際的步驟當中。如果萬一您整

個修改過後還是不能列印中文字的話,您可能就要參照一下前面完整的修

正步驟囉!

1.下載回來下面的兩個修正檔案,

ftp://ftp.gyve.org/pub/gs-cjk/adobe-cmaps-200204.tar.gz
ftp://ftp.gyve.org/pub/gs-cjk/acro5-cmaps-2001.tar.gz

2. 解壓縮CMap檔至/usr/share/ghostscript/Resource目錄下:

cp adobe-cmaps-200204.tar.gz acro5-cmaps-2001.tar.gz /usr/share/ghostscript/Resource
tar zxvf adobe-cmaps-200204.tar.gz
tar zxvf acro5-cmaps-2001.tar.gz
rm *.gz

3. touch /usr/share/ghostscript/6.52/lib/CIDFnmap.zh

4. vi /usr/share/ghostscript/6.52/lib/CIDFnmap

在最後的地方新增如下的敘述:

(CIDFnmap.zh) .runlibfile

5. vi /usr/share/ghostscript/6.52/lib/CIDFnmap.zh

/ZenKai-Medium (/usr/share/fonts/ttf/bkai00mp.ttf) 1 ;
/ShanHeiSun-Light (/usr/share/fonts/ttf/bsmi00lp.ttf) 1 ;
/Adobe-CNS1 /ShanHeiSun-Light ;
/MSung-Light /ShanHeiSun-Light ;
/MSung-Medium /ShanHeiSun-Light ;
/MOESung-Regular /ShanHeiSun-Light ;
/Arphic-MingB5 /ShanHeiSun-Light ;
/MKai-Medium /ZenKai-Medium ;
/MHei-Medium /ZenKai-Medium ;
/MOEKai-Regular /ZenKai-Medium ;
/Arphic-KaiB5 /ZenKai-Medium ;

存檔後就可以囉!

6. 關掉mozilla重新進入mozilla瀏覽器後,請依照下面的操作修正一次!

"檔案" --> "列印" --> "列印到印表機" --> "屬性" --> "Print Command"

把裡面的列印命令改成下面這樣!

gs -q -sDEVICE=pswrite "-sOutputFile=/tmp/out.ps" \
"-dNOPAUSE -dBATCH -dSAFER" && \
lpr ${MOZ_PRINTER_NAME:+'-P'}${MOZ_PRINTER_NAME} \
/tmp/out.ps && rm -f "/tmp/out.ps"


這樣您的mozilla就可以列印出美美的中文網頁囉!

上面的列印命令由網友 Keanu 所提供!

(ps:但是頁首的地方會有點被切掉,小缺點啦!)

9
Linux 討論版 / mozilla的中文列印問題??
« 於: 2003-01-26 03:11 »
我已經參考了下面文章~

http://linux.nctu.edu.tw/web/moto/tips/xwindow/Xapps/Mozilla/Mozilla_print_chinese_page.txt

但是還是不行耶???

我的是rhl7.3~~和這有關ㄇ?

10
前言:

  先說一下系統的環境,我的區網中一共有三台電腦,電腦a和電腦b都是

使用 RHL7.3(kernel 2.4.18-19.7.3),而且a上面是接了 HPLaserJet5L,b接的是

Epson Stylus C61,也就是印表機現在都是接在Linux的機器上。電腦c則是VMware

中所跑的虛擬系統 win2000,現在想要做到的是:這三台電腦都可以隨意的印

到兩台印表機上面去!

  以前我使用 RHL7.3 內附的 printconf,不知道為什麼,在win2000使用透過

samba分享的印表機列印是正常的,但是linux之間想要使用網路印表機的時候

卻會印不出來,沒有反應,只能使用本機印表機。所以有點不方便!看了網路

上的一些實作分享,認為使用 CUPS(Common Unix Printing System)來管理印表機

並且透過 samba 來把印表機分享給 MS 的作業系統來使用,同時也能兼顧 MS &

linux 間的檔案分享便利性,所以下面的作法是使用 CUPS + samba 來完成我們的

目的!

在安裝好 RHL7.3之後,如果您有利用 up2date 的方式去更新套件的話,您

會發現 CUPS 的版本應該是 cups-1.1.14-15.2,您可以利用 rpm -qa | grep cups 來

看一下,除了 cups 本身之外應該還有個 cups-libs-1.1.14-15.2,如果您的印表機

驅動程式抓不到,建議您可以到 http://rpmfind.net 以 cups-drivers 的關鍵字去下

載 cups-drivers 回來並安裝,一般說來使用RHL7.3內定安裝的驅動程式就很足

夠了!

另外,samba在 2.2 版以前是沒辦法支援 CUPS印表機管理程式的,所以

您也要先檢查一下您samba的版本 (rpm -qa | grep samba),同樣的,如果您有進行

up2date 更新的話,您的samba版本應該是 2.2.7-1.7.3 了!

   下面就是實際的操作了!

1.要使用 CUPS必需要先移除 RHL7.3 內定安裝好的 LPRng和printconf

rpm -e LPRng printconf printconf-gui

(最後的 printconf-gui 是 printconf 的 gui 程式)

2.修改 /etc/cups/cupsd.conf,使區網網段中可以登入設定 CUPS server

找到並修改成下面的兩段:

<Location />
Order Deny,Allow
Deny From All
Allow From 192.168.1.0/24 <--這是您區網的位置
</Location>

<Location /admin>
AuthType Basic
AuthClass System
Order Deny,Allow
Deny From All
Allow From 192.168.1.0/24 <--這是您區網的位置
</Location>

好了之後,重新啟動 CUPS server 吧!

/etc/init.d/cups restart

3.接著我們就要在 CUPS server 上新增一台本機印表機囉!

我們是使用瀏覽器的方式來管理 CUPS,有一點很重要,當您要操作的時

候,瀏覽器的 proxy 功能要先關掉,以直接讀取網路的方式來操作,不然會

根本沒法進入到管理的畫面!在您的瀏覽器輸入下面位址即可進入:

http://localhost:631/

再來聰明的您應該知道要怎樣去新增一台本機印表機吧!選擇 Printers吧!

4.以上面的方式您可以在電腦a和b上面都裝好本機印表機,並且試印正常!

 再來就是要在電腦a和b的上面,把接在另一台linux上的印表機給加成自己

的網路印表機(這邊所說和所做的都還只是在linux系統之間的喔!),所以

現在先到電腦a上,修改 /etc/cups/client.conf,這個檔案是要設定您這台電腦

所要登入的 CUPS server,因為電腦a和b我們都有安裝CUPS server並各自

裝了一台本機印表機,所以這邊請您找到檔案中的下面一行,並設定成自己

的電腦iIP位置,也就是如果電腦a是 192.168.1.2,請您設定成下面:

ServerName 192.168.1.2

等下電腦b也是要改成他自己的IP位置!好了就存檔囉!

5.加入網路印表機:

上面的步驟好了之後,到電腦a上,同樣進入 http://localhost:631/ 管理介面,

(忘了說,如果有需要管理帳號和密碼,請輸入root和root的密碼),然後

點一下 Printer,像剛剛您新增本機印表機一樣:

Name : 設定您這台網路印表機的佇列名稱(要認真打!)
Location : 簡短的說一下您這台電腦的位置,可以隨便打!
Description : 您對印表機的描述,可以隨便打!

再來是選擇印表機的 Device,請選 Internet Printing Protocol (http)

好了之後,這邊就重要了,要實際設定您那台網路印表機的位置!

舉例來說,前面您設定電腦a上面的本機印表機佇列名稱為 HPLaserJet5L

而電腦a的IP為192.168.1.2,電腦b上面的本機印表機佇列名稱為 EpsonC61

而電腦b的IP為 192.168.1.12,現在您要在電腦a上面加入 EpsonC61 這台網

路印表機,您就要輸入下面這樣的方式:

(Device URI:) http://192.168.1.12:631/printers/EpsonC61

所以如果您是在電腦b上面加入網路印表機,您就要輸入:

(Device URI:) http://192.168.1.2:631/printers/HPLaserJet5L

以此類推囉! 後面的設定就很像加入本機印表機,對您應該不難了!

上面設定完,您在各台linux之間就可以互相列印了!想要開機就啟動 CUPS

server嗎? 用 ntsysv 去勾選 cups 吧!

6.基本的samba設定這我就不說了,假設您已經有了正常運作的samba服務,這邊

您只要稍微改一下設定就可以使 samba 支援cups了,因為還沒改的時候,samba

是不認得cups的! 請您修改 /etc/samba/smb.conf

首先,先把印表機分享的區塊設定找到,如果有 "#" 把它給除去,大致的內容

如下:

[printers]
comment = All Printers
path = /var/spool/samba
create mdoe = 0700
guest = ok
printable = yes <---- 重要!
browseable = no
......(其他的不用改!)

再來在最上面的通用設定區段 global 中,您要改的只有兩行!

printcap name = cups
printing = cups

這樣就好了,簡單吧!存檔後,重新啟動samba!

service smb restart

7.經過上面的samba的修正,重新啟動後您就可以在MS的網芳中看到

linux透過 CUPS所管理的印表機,既然您看得到,就可以在MS中以新增

網路印表機的方式來使用它們囉! 這個應該就不用我說了吧!

8.最後一點,因為我的 win2000 是裝在VMware當中的,結果vmware和samba會

有衝突的情形,造成 smbd 根本不能啟動,自然samba跑不起來,如果您有

這種情形,請您修正 /etc/samba/smb.conf,加入下面三行,重新啟動samba

就一切ok了!

hosts allow = 192.168.1. <--- 設定您可以使用samba的範圍,您的區網啦!
interfaces = 192.168.1.0/255.255.255.0
bind interfaces only = yes <---- 最重要!

9.為了避免 vmware和 samba的互相干擾,且CUPS應該要在 samba 之前就先啟動,

免得samba會不認得 CUPS(這是有的網頁講的,但是我實作好像不會!)

所以應該要把起動的順序改成 cups --> samba --> vmware

我是使用 init level 5,所以請到 /etc/rc.d/rc5.d 目錄中,您可以看到原來是:

S90vmware S91smb S99cups

請您改成 S88cups S89smb S90vmware

所以命令如下:

mv S91smb S89smb
mv S99cups S88cups

這樣的話,下次重新啟動您就會有一個很完美的列印分享環境!

11
Linux 討論版 / SAMBA沒辦法啟動???
« 於: 2003-01-25 02:06 »
唉~~這是以前好久遇到的問題了~~

今天在玩 CUPS  + samba印表機分享~~

原本都可以正常運作了~~但是後來重開機後~~samba就不能正常運作了~~

service smb status 會出現

smbd : 已停止
nmbd: 正在執行~~~

不管怎樣在重新啟動~~smbd就是會出現停止的現象~~

救救我呀!!  

弄了三天才把 CUPS + samba印表機分享架起來~~

現在 CUPS 正常了~~結果samba掛了~~~嗚~~~

12
Linux 討論版 / 列印的奇怪問題?
« 於: 2003-01-23 14:30 »
區網中一共有三台電腦~~

一台是win2000~~另外兩台是Red Hat Linux7.3

我分別在兩台linux上裝有印表機~~一台是HPLaserjet5L,一台是Epson-C61

兩台linux都有安裝samba,分別也都利用 Printer Configuration設定好了印表機

試印都正常~~好用得很! 但是透過samba分享給win2000的時候~~以加入網路印

表機的方式來使用時,HPlaserjet5L很正常,但是Epson-C61就會印成亂碼,

三台電腦都是設成同一個workgroup,請問這是怎樣一回事?

另外,這兩台linux之間,不論是用 unix printer(LPD) 或是 samba printer (SMB)的方式

都沒辦法把對方的印表機給加入成網路印表機,或是加入後都沒反應,不能列印

請問這又是怎樣的問題???

拜託拜託了!!很急呢!

13
Linux 討論版 / 分享:up2date設定(X windows)
« 於: 2003-01-23 01:24 »
透過 up2date,簡單的幾個鍵就可以更新您系統上的套件~~

下面是在 X windows裡設定 up2date 的教學~~

圖檔很多,可能要等等。

http://www.shizuka.adsldns.org/modules/forum/viewtopic.php?t=87

ps:如果錯誤煩請指正~~

14
嗯~~看了螢火飛學姐和ㄚ賢學長的教學文章~~

我的系統是rhl7.3 + kde3.0.3

下載了j2sdk回來安裝~~並且以xttfm.ttfm修正過~~

也有以xtt取代了xfs來管理字型~~~

原來有些網頁(像奇魔入口網站~~)原來自會糊成一團~~現在已經很棒了

但是有的網站java的字還是有點怪怪的~~有的中文還是可以出來~~

不過方塊字的問題已經沒有了~~

另外有一點比較奇怪的是~~有些網頁進去後文字都變成亂碼~~

我的mozilla編碼是選擇big5~~請問學長們有遇過這樣的問題ㄇ?

15
Linux 討論版 / linux間的印表機分享???
« 於: 2003-01-20 11:34 »
這幾天在玩純linux的區網設定~~~

以前是用過印表機在ms and linux間透過samba來分享~~

但是還沒在同樣兩台都是linux的系統間嘗試~~試不太出來~~

現在我兩台linux都有跑samba~~請問我的印表機要設定成samba分享

還是unix種類的印表機呀??

可以請有經驗的前輩說說ㄇ?

16
Linux 討論版 / 又被燒錄搞死了~~
« 於: 2003-01-19 14:15 »
從昨天開始來玩RHL8.0來當桌面電腦使用~~~

但是很奇怪~~~在還沒把CDROM and CDRW給模擬成SCSI之前~~

來聽音樂cd或是看vcd都很正常~~但是如果模擬成SCSI之後~~

hda (cdrom) --> scd0,  ln -s /dev/scd0 /dev/cdrom

hdc (cdrw) --> scd1, ln -s /dev/scd1 /dev/cdrom1

其中的scd1(cdrom1) 可以掛載或是卸載

但是scd0(cdrom) 卻沒辦法正常的掛載~~~

Attached scsi CDROM sr0 at scsi0,channel 0, id 0, lun 0
Attached scsi CDROM sr1 at scsi0,channel 0, id 1, lun 0
sr0: scsi3-mmc drive: 40x/40x cd/rw xa/form2 cdda tray
Uniform CD-ROM driver Revision : 3.12
sr1: scsi3-mmc drive: 40x/40x write cd/rw xa/form2 cdda tray
ISO 9660 Extensions : Microsoft Joliet Level 3
ISOFS: changing to secondary root
ide-scsi: hdc: unsupported command in request queue (0)
end_request: I/O error, dev 16:00 (hdc) , sector 64
isofs_read_super: bread failed,dev=16:00,iso_blknum=16,block=32
ide-scsi: hdc: unsupported command in request queue (0)
sr1 : CDROM (ioctl) reports ILLEGAL REQUEST
sr1 : CDROM not ready. Make sure there is a disc in the drive.

我的cdrom是一般的光碟機~~執行時裡面也都有資料片在裡面~~~

請問這是怎樣的一回事呢?

17
我的主機板是 ASUS P4B533

音效晶片是 C-Media 8738.....

在linux下用 xine以 arts可以正常撥放出音效....

但是在VMware當中....系統卻會抓不到音效說....

開始時會去找 /dev/dsp 但是在 win2000中的控制台中

還是看不到有抓到任何的音效裝置.....

參考了 www.vmware.com  網站說新增安裝硬體

 Creative SoundBlaster WDM...但還是不行呢....

我要如何才能使得vmware中的音效正常呢???

18
Linux 討論版 / 我的xine不能播???
« 於: 2002-12-21 21:03 »
下面是我執行 xine 出現的錯誤訊息...

請問一下是怎麼了??


Found xine library version: 0.9.8 (0.9.8).
Display is not using Xinerama.
video_out_xv: using Xv port 55 from adaptor NV Video Overlay for hardware colorspace conversion and scaling.
video_out_xv: double buffering mode = 1
video_out_xv: port attribute XV_COLORKEY value is 66046
video_out_xv: port attribute XV_AUTOPAINT_COLORKEY value is 1
video_out_xv: port attribute XV_BRIGHTNESS value is 0
video_out_xv: port attribute XV_CONTRAST value is 4096
video_out_xv: port attribute XV_SATURATION value is 4096
video_out_xv: port attribute XV_HUE value is 0
video_out_xv: this adaptor supports the yuy2 format.
video_out_xv: this adaptor supports the yv12 format.
load_plugins: video output plugin Xv successfully loaded.
audio_oss_out: Opening audio device...
audio_oss_out: using device >/dev/dsp<
audio_oss_out: opening audio device /dev/dsp failed:
裝置或系統資源忙碌中
load_plugins: audio output plugin /usr/lib/xine/plugins/xineplug_ao_out_oss.so: init_audio_out_plugin failed.
main: the specified audio driver 'oss' failed

19
Linux 討論版 / 更新KDE到 3.0.4版 ??? how to??
« 於: 2002-12-21 19:55 »
看了一些之前版上的post....如何升級KDE...

但是有的是針對 FreeBSD...有的是連x windows都還沒裝的...

不太能針對我的需求.....

我現在是KDE 3.0.3 想要升級到 3.0.4版....

因為想要裝一個版上推薦的screensaver....

之前的安裝都有問題...看了討論是說如果升級到3.0.4版就可以安裝正常....

問題來了.....我找到KDE 3.0.4版....想用rpm方式來升級...

ftp://download.tw.kde.org/pub/kde/stable/3.0.4/RedHat/7.3/i386/

裡面那麼多檔案要怎裝呀?? 是全裝ㄇ? 又怕裝不完全x xindows又掛了...

或是有檔案相關性的問題.....

ps:今天用 up2date 的方式升級...但是只能升到3.0.3版....還是裝不起來

那個screensaver....

20
忙了好些天~~終於有點像樣了...這裡來報告一下我的心得和感想...

大家可以來看一下結合的結果...

http://www.shizuka.adsldns.org

架設步驟如下 :

1. 安裝 twxoops_rc3 v3.0.4 版...

安裝方法可以參考本站 http://www.shizuka.adsldns.org 精華區中的文件

ps: 一開始我是安裝 twxoops 最新的1.3.6繁體中文完整版...不能和phpBB

模組結合...建議不要再試了!!

2. 下載 phpbb_module_xoops rc3x.v1.07.zip (本站下載區中有)

解壓縮之後...會有5個檔案(其中一個是說明檔..)和兩個目錄....

把那5個檔 copy to /var/www/html 下..

把 class 目錄中的檔案 copy to /var/www/html/class

把 module 目錄中的檔案 copy to /var/www/html/modules

記得全部覆寫過去...!!!

3. 進入xoops的控制台中,安裝並啟動 message board (phpBB 模組在

xoops 中的名稱啦!!)

4. 進入網頁 http://您的網址/modules/forum/install.php 去安裝您的 phpBB

模組...

重點切記 :

A. xoops的管裡者帳號和email與 phpBB 模組的系統管理者不可以設

同一個人(也就是同一個名稱啦!!) 不然會整合不良....很慘!!

B. phpBB 模組安裝好之後,所設定的模組系統管理員會把之前xoops

的系統管理帳號給消掉並取而代之!!! 也就是現在 xoops 和 phpBB

的系統管理員只有一個...就是最後那個phpBB的管理員帳號...

C. 這時的phpBB因為沒有中文化..所以現在這個管理員就算是以後

phpBB有中文化了....它也不會顯示出中文化的結果....這一點我都

沒辦法克服!!

4. 中文化 phpBB 模組

下載 lang_chinese_traditional_taiwan_rc3.zip 和

subSilver_chinese_traditional_taiwan.zip (本站下載區中有)

解開來後...

lang_chinese_traditional_taiwan 目錄是放到

/var/www/html/modules/forum/language 之下...

而 subSilver 解開來的那個 lang_chinese_traditional_taiwan 目錄是放到

/var/www/html/modules/forum/templates/subSilver/images 之下...


5. 中文化後...以之前那個管理員帳號登入..(您還是會看到是英文版的...)

進入 phpBB 的系統管理...選擇系統的預設語系為繁體中文...

ps:別忘了以後就算是中文化完成..您的這個管理帳號看到的還是英文...

6. 在 xoops 的登入區去註冊一個新的帳號...它會主動連結到phpBB模組

的註冊系統...您會看到中文化完整的畫面...(您滿13歲了沒.....)

這樣註冊回來的帳號...以後您只要在 xoops or phpBB模組登入一次...

兩邊都是通用的...而且是完整的中文化.....

7. 如果您有在 xoops 中開放 "線上人數" 的區塊...那邊也可以申請帳號...

但請千萬注意!! 這裡的註冊是對xoops來申請...不是對phpBB模組.....

雖然這個帳號也可以通用...但是您會發現這種帳號登入後..phpBB模組

是沒有中文化的.....千萬不要在這裡註冊!!!

21
Linux 討論版 / 奇怪的問題 : rxvt不能複製???
« 於: 2002-12-04 00:21 »
嗯....以前灌rhl7.3....裡面的rxvt都可以操作copy and paste...

結果現在卻不行了....可以請學長們幫個忙ㄇ??

這是怎樣的一回事呀?

22
經過一個禮拜的努力~~這台P4-2.4G所算是被我搞定95%...

現在我這一台是跑RHL7.3(kernel-2.4.18-18.7.x)架server...

外加 VMware (win2000)...好用順手的很....

不過在裝的時候會有點問題~~來跟大家分享一下免得搞很久....

------------------------------------------------------------------

我有兩顆40gb的硬碟...如果只是用RHL7.3(kernel-2.4.18-3)

會沒辦法開DMA功能....(bios中有開...hdparm -d1 /dev/hdx

會出現 operation not permitted) ....整體速度會被拖很慢.....

常會delay.....而原來下載的VMware-workstation-3.2.0-2230

卻只能在 kernel-2.4.18-3中安裝.....如果更新過kernel...

VMware是沒法裝的......

另外當kernel更新到 2.4.18-18.7.x時...開機即可啟動硬碟的

DMA功能...不過卻沒法安裝VMware....

解決方案 :

1.更新kernel到 2.4.18-18.7.x (up2date即可)

2.去 http://rpmfind.net 下載 kernel-source-2.4.18-18.7.x.i386.rpm

回來安裝....(在 /usr/src/linux-2.4.18-18.7.x)
3.安裝VMware-workstation-3.2.0-2230

在安裝時它會去找新kernel的原始檔來compile....這樣就可以裝囉....

按照上面的方式,就可以又支援hd DMA,又可以安裝VMware....

安裝vmware可以參考 :

http://www.shizuka.adsldns.org/vmware.htm
(2007/11/9 slime 備註: adsldns.org 網址已失效)

23
Linux 討論版 / 無法打開DMA模式??
« 於: 2002-11-30 23:46 »
在BIOS中已經設定了開啟UDMA5...

但是在RHL7.3(2.4.18-3)中以
   hdparm -d1 /dev/hda 會出現
 HDIO_SET_DMA failed: Operation not permitted

可是升級後的 RHL7.3(2.4.18-18.7.x)

卻可以設定 hdparm -d1 /dev/hda
配合其他的設定可以有十倍的效能增加....

請問現在我該如何在2.4.18-3中打開UDMA??

24
有好幾個有關VMware的問題想請先進們指正一下....

拜脫了....

----------------------------------------------

1.原本我安裝好RHL7.3 (kernel 2.4.18-3)...也安裝好了

  Vmware,在其中安裝了win2000。但是後來因為去跑了

  windows update,使得我的win2000掛掉了,要重灌VMware..

  慘的是 : 我的RHL7.3因為去RHN進行up2date更新...使得

  kernel 更新為2.4.18-18.7.x 。後來想要再安裝VMware

  的時候就跟我說 :

  What is the location of the directory of C headers

  files that match your running kernel ? /usr/include <<--輸入

  結果出現...

  The directory of kernel headers (Version 2.4.9-9) does

  not match your running kernel(Version 2.4.18-18.7.x).

  Even if the module were to compile successfully, it

  would not load into the running kernel.

  我想問的是,是不是找到或是能夠下載解開來針對新的kernel

  的 C headers files,就可以安裝了...但是怎樣我都找不到

  這些 *.c 的檔案耶....可以請高手指正一下ㄇ?? 還是VMware

  現在就是沒辦法支援到這樣新的kernel版本???

2.我的RHL7.3 server上有兩張網卡...一張是對外(ADSL,eth0)

  一張是對內(NAT,eth1)..這樣的話~~當我在安裝VMware時...

  它會問我說要使用哪張網卡???? (如果我是用 bridge的方式

  不是說 host端和 guest端是共用一張實體網卡ㄇ??) 是eth0

  還是 eth1呢????

25
救命呀!!

剛剛去看了一下鳥哥私房菜的安裝 phpBB2 的教學文件...

提到 :

cd /var/lib
tar -zcvf mysql.tar.gz mysql

以上面的方式來備份資料庫....

但是我是用phpBB2本身的控制台內中的 '備份資料庫'

並選擇以不壓縮的方式來完整備份整個資料庫....

有存成一個檔案 phpbb_db_backup.sql

問題是現在我裝好了新系統...要把之前的討論版給還原回去....

用phpBB2系統控制台中的 '還原資料庫' 功能....

有看到硬碟或是軟碟在讀取..但是讀完之後...系統還是沒有還原耶...

這是怎樣的一回事呀???? 救命呀....

26
我在RHL7.3中安裝了 vmware 3.2.0 版....要安裝win2000

結果跟我說 /tmp 滿了...所以想重開機~~再灌在其它指定的partition..

重開後...卻進不了 x-window....一點畫面都沒...一閃一閃...

已參考了 netman站長 有關 xwin對安裝 vmware後的修正....

去抓回 vmware_drv.o --> /usr/X11R6/lib/modules/drivers

並修改了 xf86Config-4 .....還是一樣耶!!

可以請哪位大大指正一下ㄇ???  :oops:

27
雜七雜八 / 台達UPS優惠!
« 於: 2002-11-06 14:27 »
購買台達UPS的優惠已經和他們的板主談好了```

1. 台達 S650 (650VA 380W) : 1850元 (不含運費100)

    可接一台電腦...單port... RS232

2. 台達年底預定要出的 1000VA : 3400元(不含運費) + 送UPS寶寶一個

    可接兩台電腦...雙port...  RS232 + USB

    可參考台達UPS網站  http://www.delta.com.tw

訂購說明:

   1.請直接和台達ups版主訂購....   simon.chen@delta.com.tw

   2.請在信中說明訂購人姓名聯絡方式地址等基本資料....

     最重要的是  要說明您是哪個網站的會員...如酷!學園等等...

28
近來想把我在MS上裝的winfax pro...改成linux上的 hylafax...

fax modem是用 internal modem card(PCI)...

新增硬體時有抓到....好像是在 ttyS0 還是 ttyS1 的....

但是當用 faxaddmodem時...好像會抓不到耶....

在x windows中看系統資訊....也找不到modem card是裝在哪個 com port...

可以請高手指正一下ㄇ?

29
Linux 討論版 / PXE停止執行?
« 於: 2002-10-19 07:43 »
在ntsysv中設定開機啟動PXE...

但是一開機進入之後...

service pxe status --> pxe停止執行但subsys已鎖定...

這是什麼意思呢????

煩請指正.... :cry:

30
Linux 討論版 / 有關 tftp server ~~
« 於: 2002-10-17 22:07 »
這幾天想來弄個 PXE server....

看了心得技巧那邊的文章....

說是要先安裝 tftp server...

所以有抓回 rpm 回來安裝....(我的系統是RHL7.3)

進入 ntsysv 中勾選了 tftp 開機時啟動.....

重開之後....好像沒耶~~ service tftp (or tftpd) status

都跟我說 unrecognized service....

請問是哪裡我沒裝好ㄇ???  

其它pxe server所需的服務(如dhcpd)或是檔案修改都弄好了...

也都正常....好像就是tftp server弄不起來...

煩請指正.... :oops:

頁: [1] 2