顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


主題 - endure

頁: [1]
1
請教一個問題,不知道是什麼原因所引起,若知道原因或方向麻煩告知一下
問題:Oracle不定時變慢(一個月約1~2次, 時間日期不一定), 使得對他的請求均要很久才會回覆
OS : Red Hat Enterprise Linux ES release 4
Oracle : 9.2.0.1
狀況:(1) select , update, insert等語法均要很久才會回覆, 超過10min
       (2) 使用TOP查詢, 發現IOWAIT已吃滿50~99%以上, 但CPU的耗用量低於 10%
       (3) 使用iostat查詢, 不過tps佔很高, 並未發現有大量的資料讀取
       (4) 只要把oracle service 關掉, iowait就降下來.
       (5) 目前一定要透過oracle shutdown immediate關掉,再重新啟動才會好(abort關掉,重啟iowait一樣衝高)
       (6) alter.log一直出現cannot allocate new log 與 Checkpoint not complete錯誤, 發生問題時才出現,
            redolog常幾個小時才switch一次, 問題發生時, 2~6分鐘switch一次
       (7) 當發生問題時,把AP關掉後,只留oracle單獨運行,狀況並沒變好.
       (8) Server HD並未出現警示, 有請系統工程師檢查HD,並無壞軌
       (9) 有透過dbminer去檢查redo到底在做什麼, 結果發現有百分之80以上是INTERNAL的運作,但其對應的
                    redo_sql欄位並無資料.

so...真的不知道怎麼處理了..現在維護廠商也說沒遇過這種問題..朝更新patch方式來試..
但我覺得應該不是oracle bug, 不然別人早就遇過了, 所以麻煩知道原因或知道怎麼查的人告知一下.謝謝

狀況說明:
(2)
</u2/oradb/admin/topdb/bdump> top
 16:07:24  up 90 days,  5:00,  5 users,  load average: 4.09, 3.91, 2.69
323 processes: 322 sleeping, 1 running, 0 zombie, 0 stopped
CPU states:  cpu    user    nice  system    irq  softirq  iowait    idle
           total    7.1%    0.0%    0.6%   0.0%     0.0%   69.1%   23.0%
           cpu00    9.1%    0.0%    0.0%   0.0%     0.0%   44.0%   46.7%
           cpu01    7.4%    0.0%    0.0%   0.0%     0.0%   47.2%   45.3%
           cpu02    4.5%    0.0%    0.9%   0.0%     0.0%   94.4%    0.0%
           cpu03    7.4%    0.0%    1.8%   0.0%     0.0%   90.7%    0.0%
Mem:  4091560k av, 4073536k used,   18024k free,       0k shrd,    7704k buff
                   2881744k actv,  560524k in_d,   75836k in_c
Swap: 8385920k av,   21908k used, 8364012k free                 3211592k cached

(3) 並無大量的資料讀寫, 不過tps佔很高
avg-cpu:  %user   %nice    %sys %iowait   %idle
          19.65    0.00    4.53   51.64   24.18

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0        0.00         0.00         0.00          0          0
cciss/c0d0p1      0.00         0.00         0.00          0          0
cciss/c0d0p2      0.00         0.00         0.00          0          0
cciss/c0d0p3      0.00         0.00         0.00          0          0
cciss/c0d1      130.30       274.75     11410.10        272      11296
cciss/c0d1p1    130.30       274.75     11410.10        272      11296
cciss/c0d1p2      0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys %iowait   %idle
          13.90    0.00    2.48   76.67    6.95

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
cciss/c0d0        0.00         0.00         0.00          0          0
cciss/c0d0p1      0.00         0.00         0.00          0          0
cciss/c0d0p2      0.00         0.00         0.00          0          0
cciss/c0d0p3      0.00         0.00         0.00          0          0
cciss/c0d1      130.69       166.34     12411.88        168      12536
cciss/c0d1p1    130.69       166.34     12411.88        168      12536
cciss/c0d1p2      0.00         0.00         0.00          0          0

(6) 一直出現cannot allocate new log 與 Checkpoint not complete錯誤
Thread 1 advanced to log sequence 10737
  Current log# 2 seq# 10737 mem# 0: /u2/oradb/oradata/topdb/redo02.log
Wed Aug 27 08:41:09 2008
Thread 1 cannot allocate new log, sequence 10738
Checkpoint not complete
  Current log# 2 seq# 10737 mem# 0: /u2/oradb/oradata/topdb/redo02.log
Wed Aug 27 08:51:04 2008

2
Linux 討論版 / ps -aux 顯示的問題
« 於: 2008-04-29 13:57 »
Dear all
OS: Linux 7.3 Red Hat
    請教一下,當我下ps -aux時,我發現當帳號大於8碼(不含),產生的USER那欄會變成數字,而不是他的帳號.
    1.adduser  -u a123456789 ( 共十碼)
    2.a123456789 login linux

    3.我用ps -aux 看,User 並不是以他的帳號出現,如下
USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
1479     11996  0.0  0.0  2724  608 pts/13   Ss   13:04   0:00 -ksh
1479     12018  0.0  0.0  2724  548 pts/13   S+   13:04   0:00 /bin/ksh /u1/tiptop/ds4gl2/bin/udm2

    4.但假設我單純下ps -ao '%u',又能正常出現, 但下 ps -ao '%u%a' ,則不能
a123456789
a123456789
-------------- ps -ao '%u%a'
1479     /bin/ksh /u1/tiptop/ds4gl2/bin/udm2
1479     fglrun /u1/tiptop/azz/4gi41/udm4

看樣子好像是長度問題,ps 好像會自動轉成數字...
請問有什麼方式可以解決的嗎 ? 我 man ps , 沒找到可以指定某一欄的顯示長度.
能幫忙解決我的疑惑嗎 ? 謝謝.       

3
各為大大好
        我想請教一下有關Oracle redolog file 一些的相關問題,redologfile據我現在知道是儲存已經完成TRANSACTION
的資料
        1.實際儲存的資料是什麼? 假設我下了刪了一筆資料 DELETE FROM a_table where a.name='林小明'
        在redolog file 他是不是只儲存我下的SQL語法 ?
     2.有什麼辦法可以得知redolog file中實際儲存的資料嗎?

4
各位前輩
        請問一下adduser是root用的指令,有什麼方式可以指定某一個帳號
也可以直接下此使用此指令嗎(不透過su)?
謝謝

5
Network 討論版 / 有關收到Mail後發生的狀況
« 於: 2006-11-28 10:27 »
信件內容變成下面所示,原因不明,不知道誰有遇到這種狀況,因為我找不到
800這個代號是什麼意思.這種狀況有時候會有有時候沒有,信件只有主旨正常
內容就變成這樣子
Your mail 198.1.1.5:22732->61.220.xx.xx:25 is dropped for Internal Error 800.
發信者是從馬來西亞發出來的,後面是台灣的61.220.xx.xx的Mail Server,
馬來西亞發送給大陸也會發生此狀況.

6
BSD 討論版 / 有關sendmail + sasl2 的問題
« 於: 2006-10-24 14:30 »
請教一下各位先進...
我目前架設了一台FreeBSD , 使用sendmail+sasl2
現在自己寄信收信沒有問題.
但是現在遇到一個問題就是...別人寄信到我的信箱就會被退信..
不知道發生了什麼事?我找了好多文章都是講因位認證寄信的問題..
但都沒看到我這種情況..
Relaying denied. Proper authentication required
下面是被退信的內容
The original message was received at Tue, 24 Oct 2006 13:51:26 +0800 (CST)
from m9190210@webmail.stut.edu.tw

---The following addresses had delivery errors---

mis@buffaloworld.com.cn [550 5.7.1 <mis@buffaloworld.com.cn>... Relaying denied. Proper authentication required.]

7
Network 討論版 / 網路芳鄰列印很慢的問題
« 於: 2006-08-21 18:07 »
請問各為大大,不知道有沒有遇過印表機透過網芳分享列印時
速度出現很慢的狀況?不知道要怎麼解決,還是正常的
情況說明:
1.使用者透過illutrator列印圖檔(XPP)片,印表機是再另外一台機器上(XPP)
2.檔案約5MB,我到印表機看他傳輸是32k這樣慢慢傳(兩台是在同一個LAN上)
3.網路架構很簡單
   Router --> Switch --> PC - Printer
                       ------->Switch ---> PC - Client

8
因為在別的主題聽到前輩說,怎麼一堆資訊主管都是某種調調(應該是指處理
事情的態度與方式很差)..
我想一想,我好像是屬於這種調調...當我面對一些沒經驗的事情
但主管又想聽取我的建議....我只能理論上去評估...
但實際運作狀況,卻無法實際去掌握,我常遇到這種狀況,但一直不知道要用
怎樣的態度與作法才是正確的.請教各位前輩應該用什麼的態度去面對事情
(1)以視訊會議這件事來講
我要建立的是台灣與上海的視訊會議,我有請廠商來Demo過
機器的表現滿足我的需求,但是兩岸之間資料傳輸的狀況卻不是硬體廠商
可掌握的,尤其是大陸的網路環境跟台灣差很多,對大陸的網路真的很無力
,此時就會很困擾,要怎麼去找可解決兩岸連線的問題?我目前想到的就是
請硬體廠商介紹,只能相信,但又害怕介紹的會不會有問題(這部份好像沒
辦法測試)
(2)另外跟廠商的溝通模式
因為老闆會交待一些事情,但只是評估,不一定會建構,但此時我要怎麼
面對幾個配合廠商,是一樣請他們過來Demo,借機器測嗎?假如到時候
不買,以後真的要建置,又要請他Demo其它的,會不會有問題,這是我一
直擔心的問題.我應該用怎樣的心態去面對這些廠商?

9
MIS 討論區 / 有關視訊會議的連線費用
« 於: 2006-05-04 16:22 »
各位先進好
        上次有跟大家詢問過架設視訊會議的硬體與環境的問題,但現在談到有關
網路連線的相關費用,目前我們現在是台北跟上海要連,我上網找了速博跟Hinet
的費用,一個月要繳的費用好多,而且他雖然列表是這些,但備註又寫了下面的說明
1、 凡選用專業型或經濟型,兩點之間免費無限時數連線,不計入多點連線時計算之10小時或2小時。
2、 以上費用均含台灣地區 ADSL 電路月租費及大陸地區專線( DDN )電路月租費。
3、 台灣地區端點均搭配雙向 640K on-net ADSL 電路,若需升級為 E1 專線電路,僅需加付 10,000/ 每月每端點,若為 Off-net ADSL 電路需自行繳納中華電信電路費。

問題:
1.是說若是單純我兩點做視訊會議,就不列入計算時間的意思嗎?
2.第二點寫說有包含電路費,但有沒有網路費?還是根本沒那種東西
   (因為中華電信的ADSL不是有分電路跟網路費用兩種)
3.on-net 叫網內 ? off-net 叫網外 ?

最重要的一點,有誰願意分享一下自己現在公司有用視訊會議(台灣 <>大陸)
一個月的費用要花多少錢,有哪些要花錢的項目.麻煩各位了.

10
各位先進好
        想請教有關Fortigate 60幾個問題
        (1) Fortigate 60 中的兩個WAN port 到底能不能同時作用.我問廠商廠商
               說可以,傳給我設定的方式,可是我爬文看到ZMAN說只能用來備援,所以
               有點混亂,但是最重要的我設了之後起不來,所以不知道有誰有實際的經
               驗,看能不能告訴我答案
        (2)假如可以,是否有沒有範例可以看,因為我設了之後,感覺是routing那邊
              出了問題,但是不知道確切在哪.基本上WAN1可以正常運作,但WAN2
           只能ping到小烏龜那台.而外面ping不到WAN2網段所對應的IP.沒有
               檔此服務
       謝謝各位.

11
各位好,我在上海準備要申請一條網路線,且需要有2個固定IP,但我打電話到上海電信問,目前有固定IP的只有FTTB & 專線才有,但是在下遇到了幾個問題.
1.FTTB並不是每個地區都有,且目前只有配予一個IP
2.專線太貴了
所以我想問一下
1.在上海地區是否可以申請類似台灣雙向512k固接式的線路,然後可以分配到
    固定2個左右的固定 IP?
2.假設我只有一個IP的話,若是透過IP分享器去做Port mapping的方式,對應到
    區網內的某一個機器的話,是否要考慮到什麼東西?

12
各位先進好
        不知道各位是否在大陸買過資訊系統的經驗,因為小弟我現在人在上海,昨
天跟軟體廠商(正航)見過面也看過Demo,但是整個談下來發現大陸的行銷方式
不知道是業務是亂講還是怎樣,跟台灣的都不一樣,主要比較大的差異是:
1.軟體不打折
2.維護費用從第一年就開始收費(15%),不是基本都是會有半年到一年的保固期嗎?
是大陸都這樣嗎?還是業務跟我亂講,不知道各位先進是否有談判的經驗
可以分享一下.

頁: [1]