顯示文章

這裡允許您檢視這個會員的所有文章。請注意, 您只能看見您有權限閱讀的文章。


文章 - alumi

頁: [1] 2 3
1
MIS 討論區 / MIS 的新定義
« 於: 2005-10-28 03:12 »
MIS(Mission Impossilbe Specialist)

其實不只是水電工, 當公司有任何突發狀況發生時,

就要有 一夫當關, 萬夫莫敵, 捨我其誰 的氣魄與能力.





這是個人的感觸.

2
Linux 討論版 / Q: sendmail 備援
« 於: 2002-10-21 10:22 »
IN   MX    50   aaa.do.com.
IN             MX  100    bbb.do.com.

當 aaa 主機掛掉 (當機, 斷線. ..... ), bbb 就負責接收 do.com 這個網域的信件,

直到 aaa 正常時, bbb 才會把所收到的信, 傳給 aaa.


Q:
aaa 主機上的 mail account , bbb 是否也要有一份?!

還是 bbb 主機只負責接受 do.com這個網域的信件, 而不會管這個網域是否有
該收件人帳號.

ps: 小弟 不能(也無法) 將 aaa 關機做實驗.

3
Network 討論版 / Multipath
« 於: 2002-10-11 18:46 »
不是設 iptables 就可以了嗎?



iptables -t nat -A PREROUTING  -d $REAL_IP  -j DNAT --to $DMZ_IP

4
Network 討論版 / Proftp & 續傳問題
« 於: 2002-10-09 19:00 »
奇怪?!

怎麼 "大於" "小於" "斜線" 都無法正常顯示在版面上.

5
Network 討論版 / Proftp & 續傳問題
« 於: 2002-10-09 18:59 »
User            nobody
Group            nobody

# Normally, we want files to be overwriteable.

  AllowOverwrite      on


# A basic anonymous configuration, no upload directories.

  User            ftp
  Group            ftp
     # We want clients to be able to login with "anonymous" as well as "ftp"
     UserAlias         anonymous ftp

     # Limit the maximum number of anonymous logins
     MaxClients         6

     # We want 'welcome.msg' displayed at login, and '.message' displayed
     # in each newly chdired directory.
     DisplayLogin         welcome.msg
     DisplayFirstChdir      .message

     # Limit WRITE everywhere in the anonymous chroot
     
          DenyAll
     

   
   
      
        Allowall
      


      
        Allowall
      


      
        Allowall
      

   

   
   



6
Network 討論版 / Proftp & 續傳問題
« 於: 2002-10-09 18:58 »
FTP: Proftp

使用 Anonymous Login 至 Upload , 能 READ / WRITE ,

但是為何不能續傳呢? (斷線後, 接著再傳)

是設定有錯嗎?

User            nobody
Group            nobody

# Normally, we want files to be overwriteable.

  AllowOverwrite      on


# A basic anonymous configuration, no upload directories.

  User            ftp
  Group            ftp
     # We want clients to be able to login with "anonymous" as well as "ftp"
     UserAlias         anonymous ftp

     # Limit the maximum number of anonymous logins
     MaxClients         6

     # We want 'welcome.msg' displayed at login, and '.message' displayed
     # in each newly chdired directory.
     DisplayLogin         welcome.msg
     DisplayFirstChdir      .message

     # Limit WRITE everywhere in the anonymous chroot
     
          DenyAll
     

   
   
      
        Allowall
      


      
        Allowall
      


      
        Allowall
      

   

   
   



7
Network 討論版 / Promiscuous mode enabled.
« 於: 2002-09-24 11:15 »
混亂模式, 是指 當有軟體試著從網卡, 擷取封包或監控時, 會將網卡設定成此模式嗎?!

那  網卡  是否還有其他 mode 呢?!

8
Network 討論版 / Promiscuous mode enabled.
« 於: 2002-09-24 10:50 »
最近裝了 ntop , 但系統會自動跳出下列的訊息.

這是正常的嗎??

Promiscuous(雜亂的?!) mode enabled.






------- < /var/log/messages > --------
gw1 kernel: device eth0 entered promiscuous mode
gw1 kernel: eth1: Promiscuous mode enabled.
gw1 kernel: device eth1 entered promiscuous mode

9
Network 討論版 / sendmail 啟動問題
« 於: 2002-09-18 15:29 »
謝謝, 已經解決了.

剛剛正準備放棄, 決定使用 tgz 來 compiler, 看了一下 README...

+-----------------------+
| DIRECTORY PERMISSIONS |
+-----------------------+

Sendmail often gets blamed for many problems that are actually the
result of other problems, such as overly permissive modes on directories.
For this reason, sendmail checks the modes on system directories and
files to determine if they can be trusted.  For sendmail to run without
complaining, you MUST execute the following command:

        chmod go-w / /etc /etc/mail /usr /var /var/spool /var/spool/mqueue
        chown root / /etc /etc/mail /usr /var /var/spool /var/spool/mqueue

10
Network 討論版 / sendmail 啟動問題
« 於: 2002-09-18 15:03 »
[root@cvs etc]# cp -a /etc/mail /etc/mail.bak
[root@cvs etc]# chmod -R g-w /etc/mail
[root@cvs etc]# /etc/init.d/sendmail restart
Shutting down sendmail:                                    [FAILED]
Starting sendmail: 451 4.0.0 /etc/sendmail.cf: line 88: fileclass: cannot open '/etc/mail/local-host-names': Group writable directory
451 4.0.0 /etc/sendmail.cf: line 513: fileclass: cannot open '/etc/mail/trusted-users': Group writable directory
                                                           [FAILED]

11
Network 討論版 / sendmail 啟動問題
« 於: 2002-09-18 11:57 »
[root@cvs mail]# chmod g-w /etc/mail
[root@cvs mail]# /etc/init.d/sendmail restart
Shutting down sendmail:                                    [FAILED]
Starting sendmail: 451 4.0.0 /etc/sendmail.cf: line 88: fileclass: cannot open '/etc/mail/local-host-names': Group writable directory
451 4.0.0 /etc/sendmail.cf: line 513: fileclass: cannot open '/etc/mail/trusted-users': Group writable directory
                                                           [FAILED]


是否要去 download sendmail.tgz 檔 , 回來 compiler; 而不用現成的 *.rpm 檔呢??

12
Network 討論版 / sendmail 啟動問題
« 於: 2002-09-18 11:41 »
[root@cvs mail]# mv /etc/sendmail.cf /etc/sendmail.cf.bak
[root@cvs mail]# m4 /etc/mail/sendmail.mc > /etc/sendmail.cf
[root@cvs mail]# /etc/init.d/sendmail restart
Shutting down sendmail:                                    [FAILED]
Starting sendmail: 451 4.0.0 /etc/sendmail.cf: line 88: fileclass: cannot open '/etc/mail/local-host-names': Group writable directory
451 4.0.0 /etc/sendmail.cf: line 513: fileclass: cannot open '/etc/mail/trusted-users': Group writable directory
                                                           [FAILED]

13
Network 討論版 / sendmail 啟動問題
« 於: 2002-09-18 11:22 »
[root@cvs etc]# dir | grep mail
drwxr-xr-x    2 root     root         4096 Sep 18 10:31 mail/
-rw-r--r--    1 root     root         9282 Jan 11  2002 mailcap
-rw-r--r--    1 root     root          112 Jun 25  2001 mail.rc
-rw-r--r--    1 root     root        46691 Sep 18 10:43 sendmail.cf


/etc/mail  此目錄權限, 也比對過了.

14
Network 討論版 / sendmail 啟動問題
« 於: 2002-09-18 11:19 »
drwxr-xr-x    2 root     root         4096 Sep 18 10:31 ./
drwxr-xr-x   51 root     root         4096 Sep 18 10:43 ../
-rw-r--r--    1 root     root          331 Apr  8 18:55 access
-rw-r--r--    1 root     root        12288 Sep 18 10:31 access.db
-rw-r--r--    1 root     root            0 Apr  8 18:55 domaintable
-rw-r--r--    1 root     root        12288 Sep 18 10:31 domaintable.db
-rw-r--r--    1 root     root         5573 Apr  8 18:55 helpfile
-rw-r--r--    1 root     root           64 Apr  8 18:55 local-host-names
-rw-r--r--    1 root     root            0 Apr  8 18:55 mailertable
-rw-r--r--    1 root     root        12288 Sep 18 10:31 mailertable.db
-rw-r--r--    1 root     root          595 Apr  8 18:55 Makefile
-rw-r--r--    1 root     root         2716 Apr  8 18:55 sendmail.mc
-rw-r--r--    1 root     root            0 Apr  8 18:55 statistics
-rw-r--r--    1 root     root          628 Sep 11 04:03 statistics.rpmsave
-rw-r--r--    1 root     root          127 Apr  8 18:55 trusted-users
-rw-r--r--    1 root     root            0 Apr  8 18:55 virtusertable
-rw-r--r--    1 root     root        12288 Sep 18 10:31 virtusertable.db

曾經比對這兩個檔案的屬性(與其他 sendmail server), 並試著變此二檔的權限.

還是一樣會出現這組錯誤訊息.

15
Network 討論版 / sendmail 啟動問題
« 於: 2002-09-18 11:10 »
在重新啟動 sendmail 時, 出現下列訊息
Shutting down sendmail:                                    [FAILED]
Starting sendmail: 451 4.0.0 /etc/sendmail.cf: line 88: fileclass: cannot open '/etc/mail/local-host-names': Group writable directory
451 4.0.0 /etc/sendmail.cf: line 513: fileclass: cannot open '/etc/mail/trusted-users': Group writable directory
                                                           [FAILED]

再比對一下, 這兩個檔案的權限與屬性, 皆與其他能夠正常工作 的 sendmail server, 並無兩樣.

這奇怪的問題, 是否有人遇到過..

16
Network 討論版 / Multipath
« 於: 2002-09-17 10:28 »
根據 "半套武功密技 Multipath"  的內文試了一下,

發現

1. 兩片對外的網卡, 是不是不能在同一個網段之內?!
    這樣實驗的結果, 連不出去.


ex:

GW1是 Firewall & NAT 接上  ADSL 1 (對內 IP 為 10.0.0.254 )
GW2是 Firewall & NAT 接上  ADSL 2 (對內 IP 為 10.0.0.252 )


而 Multipath 主機 的兩個 對外 Gateway 分別設為 GW1 與 GW2(eth1: 10.0.0.241,GW:10.0.0.254; eth2:10.0.0.242,GW:10.0.0.252, eth0:10.1.1.253)

ps: office  為 10.1.1.0/24

17
Network 討論版 / 教教我
« 於: 2002-09-03 11:08 »
但我每次開server時,一定要把我對內的那片網卡停用
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
1. 試著更新 Service Pack


以 就好像server開機時認不出哪一片對外 哪一片對內 好像要我告訴它
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
MS 的 NAT 一定有分對內與對外. 對內的網卡是不設 Gateway.

18
Network 討論版 / DNS & List
« 於: 2002-09-02 17:51 »
謝謝.

你這樣一講, 我就懂了. ^_^

19
Network 討論版 / DNS & List
« 於: 2002-09-02 17:40 »
剛剛再看了一下 acl (allow-query , allow-transfer),

目的是 所有人, 皆可 查詢 DNS 的資料, 只是拒絕 使用 ls , 將 dns records dump 出來.

allow-query , allow-transfer 可以這樣做嗎?

好像只是單純 限制 與 允許 某段 IP 或 server 的存取.

20
Network 討論版 / DNS & List
« 於: 2002-09-02 15:52 »
DNS Server 如何防止 Client , 使用 ls 來 list dns records.

21
Network 討論版 / CISCO 2600 Router & IP Mapping
« 於: 2002-09-02 15:45 »
如果要讓 Secondary IP Address 的 Port 80 有回應的話
可以試著將 no ip http server 拿
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
這個方法也試過了.

其實不止這些, 例如:Port 25 , 110 ..., 從公司內部去找這些實體IP 的Ports
, 都找不到. (但 Ping 卻可以).

22
Network 討論版 / CISCO 2600 Router & IP Mapping
« 於: 2002-08-28 16:37 »
Routing 的優先順序高於 NAT
而 211.23.73.0/29 存在於 NAT Router 的 Routing Table (Forwarding Table), Directly Connected
所以由 192.168.1.0/24 送往 211.23.73.0/29 的封包會直接 Forward(Route) 到 FA0/0
FA0/0 連接的網段實際上並沒有 211.23.73.2 這部主機可以回應 TCP/IP Request
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
有在 FastEthernet 0/0 上, bind secondary IP, 但是還是不行.
(理論上應該是可以)

23
Network 討論版 / CISCO 2600 Router & IP Mapping
« 於: 2002-08-19 18:21 »
環境:
CICSO 2600 OS V12
ADSL (固八, NetworkID: 211.23.73.0, ADSL IP: 211.23.73.1,
          可用IP: 211.23.73.2~6, Broadcast: 211.23.73.7,
          Netmask:255.255.255.248)

CISCO 為公司內部虛擬網路的 Gateway 又兼 NAT ,
FastEthernet 0/0 : 211.23.73.6
FastEthernet 0/1 : 192.168.1.254

公司內部虛擬網路: 192.168.1.0 / 255.255.255.0
------------------------------------------------------------------------
欲達成之功能(IP Mapping/Forward)
211.23.73.2 <--> 192.168.1.2
211.23.73.3 <--> 192.168.1.3
211.23.73.4 <--> 192.168.1.4
211.23.73.5 <--> 192.168.1.5

問題:
  公司內部連上192.168.1.2~5 伺服器所開啟的服務都沒問題,
  從Internet 連到 211.23.73.2 ~ 5 伺服器所開啟的服務也沒問題
  (其實也只是藉由CISCO Router 直接對映至虛擬IP).

  1.從公司內部卻連不上211.23.73.2 ~5 ,不過奇怪的是 Ping 卻可以
    ping 的到實體IP ?!
            (CISCO Router 上,小弟並無增設Firewall 的Rule, 而中華電信的ADSL 也無問題)

ps: 目前CISCO Router已移置他處實驗, 而211.23.73.6 是一台臨時架設的Linux.


----------------------------------------------------
測試過程:(從公司內部機器實驗)
  ping 211.23.73.2  --> 有回應.
  telnet 211.23.73.2 80 --> 無回應.
  telnet 192.168.1.2 80 --> 有回應.
  tracert 211.23.73.2 (成功)
  Tracing route to 211-23-73-2.HINET-IP.hinet.net [211.23.73.2]
  over a maximum of 30 hops:

    1   <10 ms   <10 ms   <10 ms  211-23-73-2.HINET-IP.hinet.net [211.23.73.2]

  Trace complete.
  
-------- 以下為 CISCO 2600 設定值 (show config) ----------------
interface FastEthernet0/0
ip address 211.23.73.6 255.255.255.248
no ip directed-broadcast
ip nat outside

interface FastEthernet0/1
ip address 192.168.1.254 255.255.255.0
no ip directed-broadcast
ip nat inside


ip nat pool ta 211.23.73.6 211.23.73.6 netmask 255.255.255.248
ip nat inside source list 1 pool ta overload
ip nat inside source static 192.168.1.5 211.23.73.5
ip nat inside source static 192.168.1.4 211.23.73.4
ip nat inside source static 192.168.1.3 211.23.73.3
ip nat inside source static 192.168.1.2 211.23.73.2

ip classless
ip route 0.0.0.0 0.0.0.0 211.23.73.1
no ip http server

access-list 1 permit any

24
Network 討論版 / sendmail & IP 變更
« 於: 2002-08-01 19:37 »
(題外話)
 
   這個事件(mail server 停擺),使得公司老闆被大股東駡,
 
;之後小弟就被叫進去,接受老闆關愛的眼神.

   而這幾天,找問題所花的時間與成本(含熱心的網友),真不知道該

說些什麼.
  
  

25
Network 討論版 / sendmail & IP 變更
« 於: 2002-08-01 19:10 »
問題已經解決了.

myz:

    小弟同意您的看法, 先把那篇 login password 移除.
 
twu2:
   
    您的回信, 突然點醒了我.
    昨日晚, 再臨時架了一台 mail server , 25 / 110  確定都有開,
    五個實體 IP 之間連線 (Port 25 / 110), 都沒問題.
    從外面的 Server 卻找不到 這兩個 Ports.


    1.致電給中華電信機房... 等各單位, 強烈要求查線, 並派員過來.
    2.自己也再確認ADSL 的設定值. (確認防火牆機制沒有開啟)

    後然中華電話派人來查線, 只能跟他說 "線路有通, 是通信協定不通"
    , 最後他調了一台 ALC Tel 的 ADSL 來測試, 才發現是 ADSL 的問題.
    ( 換了一台就沒事, 那原先那台 ADSL , 為何會擋 Port 25 / 110 呢 ?! )

------------------------------------------------------------------

    結論:
          真的很感謝各位幫忙, 不然還會一直以為是 Sendmail 組態出問題了.

26
Network 討論版 / sendmail & IP 變更
« 於: 2002-08-01 12:32 »
有人把 ADSL 密碼改了,

無法連進去; 改密碼的人, 能不能告訴我密碼.

27
Network 討論版 / sendmail & IP 變更
« 於: 2002-07-31 18:00 »
插個題外話:

k 大哥, 您怎會知道那台 ADSL 的帳號與密碼.

因為連我自己也不知道.

28
Network 討論版 / sendmail & IP 變更
« 於: 2002-07-31 17:41 »
型號: ct-511c

廠牌: 康全電訊

29
Network 討論版 / sendmail & IP 變更
« 於: 2002-07-31 17:31 »
[root@mail /]# ip route replace default via 211.22.77.89
[root@mail /]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
211.22.77.88    0.0.0.0         255.255.255.248 U     0      0        0 eth0
10.1.1.0        0.0.0.0         255.255.255.0   U     0      0        0 eth1
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
0.0.0.0         211.22.77.89    0.0.0.0         UG    0      0        0 eth0
--------------------------------
還是一樣, 無法從外部, 進入 Port 25 或 110
現在這台沒有防火牆.

30
Network 討論版 / sendmail & IP 變更
« 於: 2002-07-31 17:13 »
[root@mail /]# ps auxw
USER       PID %CPU %MEM   VSZ  RSS TTY      STAT START   TIME COMMAND
root         1  0.0  0.1  1412  520 ?        S    16:02   0:04 init
root         2  0.0  0.0     0    0 ?        SW   16:02   0:00 [keventd]
root         3  0.0  0.0     0    0 ?        SW   16:02   0:00 [kapm-idled]
root         4  0.0  0.0     0    0 ?        SWN  16:02   0:00 [ksoftirqd_CPU0]
root         5  0.0  0.0     0    0 ?        SW   16:02   0:00 [kswapd]
root         6  0.0  0.0     0    0 ?        SW   16:02   0:00 [kreclaimd]
root         7  0.0  0.0     0    0 ?        SW   16:02   0:00 [bdflush]
root         8  0.0  0.0     0    0 ?        SW   16:02   0:00 [kupdated]
root         9  0.0  0.0     0    0 ?        SW<  16:02   0:00 [mdrecoveryd]
root        80  0.0  0.0     0    0 ?        SW   16:02   0:00 [khubd]
root       505  0.0  0.0     0    0 ?        SW   16:03   0:00 [eth0]
root       605  0.0  0.0     0    0 ?        SW   16:03   0:00 [eth1]
root       684  0.0  0.1  1472  592 ?        S    16:03   0:00 syslogd -m 0
root       689  0.0  0.2  2108 1140 ?        S    16:03   0:00 klogd -2
rpc        709  0.0  0.1  1552  588 ?        S    16:03   0:00 portmap
rpcuser    737  0.0  0.2  1688  836 ?        S    16:03   0:00 rpc.statd
root       849  0.0  0.3  2676 1272 ?        S    16:03   0:01 /usr/sbin/sshd
root       882  0.0  0.2  2264 1012 ?        S    16:03   0:00 xinetd -stayalive -reuse -pidfile /var/run/xinetd.pid
root       909  0.0  0.5  5656 2156 ?        S    16:03   0:00 sendmail: accepting connections
root       937  0.0  0.0     0    0 ?        SW   16:03   0:00 [scsi_eh_0]
root       956  0.0  0.1  1440  484 ?        S    16:03   0:00 gpm -t ps/2 -m /dev/mouse
root       979  0.0  1.8 47912 7096 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
bin        998  0.0  0.2  2028 1040 ?        S    16:03   0:00 cannaserver -syslog -u bin -inet
root      1016  0.0  0.1  1584  660 ?        S    16:03   0:00 crond
apache    1017  0.0  1.8 47936 7128 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
apache    1018  0.0  1.8 47948 7212 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
apache    1019  0.0  1.8 47936 7188 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
apache    1020  0.0  1.8 47936 7192 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
apache    1021  0.0  1.8 47912 7084 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
apache    1022  0.0  1.8 47912 7084 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
apache    1023  0.0  1.8 47912 7084 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
apache    1024  0.0  1.8 47912 7084 ?        S    16:03   0:00 /usr/sbin/httpd -DHAVE_ACCESS -DHAVE_PROXY -DHAVE_AUTH_ANON -DHAVE_AC
xfs       1105  0.0  1.0  5444 4072 ?        S    16:03   0:00 xfs -droppriv -daemon
daemon    1141  0.0  0.1  1444  568 ?        S    16:03   0:00 /usr/sbin/atd
root      1168  0.0  0.8  4704 3352 ?        S    16:03   0:00 /usr/bin/perl /Source/webmin-0.93/miniserv.pl /etc/webmin/miniserv.co
root      1172  0.0  0.1  1384  448 tty1     S    16:03   0:00 /sbin/mingetty tty1
root      1173  0.0  0.1  1384  448 tty2     S    16:03   0:00 /sbin/mingetty tty2
root      1174  0.0  0.1  1384  448 tty3     S    16:03   0:00 /sbin/mingetty tty3
root      1175  0.0  0.1  1384  448 tty4     S    16:03   0:00 /sbin/mingetty tty4
root      1176  0.0  0.1  1384  448 tty5     S    16:03   0:00 /sbin/mingetty tty5
root      1177  0.0  0.1  1384  448 tty6     S    16:03   0:00 /sbin/mingetty tty6
root      1487  0.0  0.5  3536 2008 ?        S    17:03   0:00 /usr/sbin/sshd
root      1488  0.0  0.3  2460 1320 pts/0    S    17:03   0:00 -bash
root      1764  0.0  0.1  2652  740 pts/0    R    17:28   0:00 ps auxw

頁: [1] 2 3