酷!學園

技術討論區 => 網頁技術 => 主題作者是: edwardleung 於 2011-09-24 14:16

主題: php + mssql + Windows 2003 ( IIS 6 )
作者: edwardleung2011-09-24 14:16
各位大大您們好,

可以請教以下問題嗎 ?

1, @http://windows.php.net/download/

Which version do I choose?
If you are using PHP with Apache 1 or Apache2 from apache.org you need to use the VC6 versions of PHP

If you are using PHP with IIS you should use the VC9 versions of PHP

2, @http://www.php.net/manual/en/install.windows.manual.php

Selecting and downloading the PHP distribution package
Download the PHP zip binary distribution from » PHP for Windows: Binaries and Sources. There are several different versions of the zip package - chose the version that is suitable for the web server being used:

If PHP is used with IIS then choose PHP 5.3 VC9 Non Thread Safe or PHP 5.2 VC6 Non Thread Safe;

If PHP is used with IIS7 or greater and PHP 5.3+, then the VC9 binaries of PHP should be used.

If PHP is used with Apache 1 or Apache 2 then choose PHP 5.3 VC6 or PHP 5.2 VC6.

如需要配合 php + mssql + mysql + Windows 2003 ( IIS 6 ), 不知那個才是對的 ?

謝謝!
主題: Re: php + mssql + Windows 2003 ( IIS 6 )
作者: kerash2011-09-28 17:56
If PHP is used with IIS then choose PHP 5.3 VC9 Non Thread Safe or PHP 5.2 VC6 Non Thread Safe;

If you are using PHP with IIS you should use the VC9 versions of PHP

這兩個應該算是你的需求。

其他的 IIS7 或 APACHE 都不是你要的,刪選之後就上面那些了