酷!學園

技術討論區 => Linux 討論版 => 主題作者是: power1 於 2009-08-27 14:26

主題: samba使用網域認證方式的問題?
作者: power12009-08-27 14:26
各位我是架設一個samba server而且是使用網域認證的方法
而我也有成功加入到網域裡
可是我輸入wbinfo -u 則會出現Error looking up domain users
wbinfo -g則會出現Error looking up domain groups
是我那裡還有要做修改
主題: 回覆: samba使用網域認證方式的問題?
作者: sitediy2009-08-27 15:08
是時間不一致的關西嗎??    請注意你的ad與samba的時間

學園內很多文章  google一下,一堆資料   或是改用LDAP也行

畢竟winbind的彈性還是沒LDAP來的好!!!
主題: 回覆: samba使用網域認證方式的問題?
作者: power12009-08-27 16:06
時間我去修改好了...
可是又有一點小問題想請教大家
電腦重開機直接執行 wbinfo -g 可以成功秀出群組清單
但是執行 wbinfo -u 卻還是跑出 Error looking up domain users 這個訊息
又再次執行wbinfo -g 也再次跑出Error looking up domain groups
怎麼會這個樣子
主題: 回覆: samba使用網域認證方式的問題?
作者: sitediy2009-08-27 21:37
我想你沒找過資料吧......   

給你個參考

http://www.section6.net/wiki/index.php/Configuring_Samba3_to_be_a_Windows_Domain_Member (http://www.section6.net/wiki/index.php/Configuring_Samba3_to_be_a_Windows_Domain_Member)



     
主題: 回覆: samba使用網域認證方式的問題?
作者: power12009-08-28 18:03
因為一直沒有找出原因,因此決定把samba的相關套件升級到3.3.4-0.1.146
並且再重新操作一次,現在已成功加入到網域,但是其中winbind這個服務很奇怪
我在文字模式下重啓winbind這個服務都成正常重啓,但是在IE模式下winbind
終於都是無法啓動,而且有去/var/log/messages看log,有發現一個error
ERROR: winbindd is already running. File /var/run/samba/winbindd.pid exists and process id 4258 is running.
我有去kill -9 4258 來刪這個程序,然後再去IE模式下重啓winbind服務也是無法重啓
同時有/var/log/messages看log,看到
 initialize_winbindd_cache: clearing cache and re-creating with version number 1
這個訊息,要怎麼做才能使winbind服務起來
主題: 回覆: samba使用網域認證方式的問題?
作者: sitediy2009-09-01 13:59
在ie下啟動??   我沒試過

請其他學長幫忙吧    或善用google

please inspect
主題: 回覆: samba使用網域認證方式的問題?
作者: power12009-09-04 20:38
問題已解決,謝謝各位