作者 主題: 安裝 VMware Workstation 3.1  (閱讀 5867 次)

0 會員 與 1 訪客 正在閱讀本文。

Charlie

  • 可愛的小學生
  • *
  • 文章數: 27
    • 檢視個人資料
安裝 VMware Workstation 3.1
« 於: 2002-05-09 17:48 »
小弟用 RH 7.2 裝 VMware Workstation 3.1  時遇到一問題, 訊息如下:

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.4.7-10enterprise/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

make: Entering directory `/tmp/vmware-config1/vmmon-only'
make[1]: Entering directory `/tmp/vmware-config1/vmmon-only'
make[2]: Entering directory `/tmp/vmware-config1/vmmon-only/driver-2.4.7-10ente'
.././linux/hostif.c:114:5: #error "64GB memory configuration is not supported."
make[2]: *** [hostif.d] Error 1
make[2]: Leaving directory `/tmp/vmware-config1/vmmon-only/driver-2.4.7-10enter'
make[1]: *** [deps] Error 2
make[1]: Leaving directory `/tmp/vmware-config1/vmmon-only'
make: *** [auto-build] Error 2
make: Leaving directory `/tmp/vmware-config1/vmmon-only'
Unable to build the vmmon module.

然後就跳出來了.

這是怎麼一回事??  該從哪下手.........:roll:
 安裝過程除了畫面上有訊息外, 不知道哪裡還有更詳細的 message log ??
Thanks .....

kenny

  • 訪客
安裝 VMware Workstation 3.1
« 回覆 #1 於: 2002-05-09 18:11 »
#error "64GB memory configuration is not supported."

有那麼大的記憶體嗎﹖

Charlie

  • 可愛的小學生
  • *
  • 文章數: 27
    • 檢視個人資料
安裝 VMware Workstation 3.1
« 回覆 #2 於: 2002-05-10 09:15 »
厲害.......不愧是網中人.........:wink:
直接就點出小弟疑惑不解之處.
小弟就是一直解不出為何會出現
64GB memory configuration is not supported
這個訊息.
不知道系統在哪裡找到有這麼多的 Memory.
電腦上也只有 512MB, 用的 Intel 815的板子.




Thanks.

kenny

  • 訪客
安裝 VMware Workstation 3.1
« 回覆 #3 於: 2002-05-10 09:21 »
.././linux/hostif.c

上面這個檔的 114 行寫什麼﹖

Charlie

  • 可愛的小學生
  • *
  • 文章數: 27
    • 檢視個人資料
安裝 VMware Workstation 3.1
« 回覆 #4 於: 2002-05-10 18:27 »
謝謝 Netman 的指導. :D

原來是 RH 7.2 在 High Memory Support 這一項被設定成 64GB !!!(可能是因為用 PIII, RAM 512MB 來安裝, 所以內定 64GB)
難怪 VM 會抓到 64GB.
重新 make menuconfig 將這一項改成 off 再照正常程序做之後就可以安裝了. :P

至於 .././linux/hostif.c  這個檔案裡的內容小弟看不太懂,  114行以下內容如下:

#ifdef CONFIG_HIGHMEM64G
#   error "64GB memory configuration is not supported."
#endif


P.S 小弟只安裝過RH 7.2 Linux , 但是感覺它很 "雞婆", 常會認為你有需要就自動加一些東西 :cry: , 不知道其他公司出的會不會這樣.