作者 主題: PHP 4.1.11 有安全漏洞 如何更新??  (閱讀 5177 次)

0 會員 與 1 訪客 正在閱讀本文。

gman

  • 懷疑的國中生
  • **
  • 文章數: 84
    • 檢視個人資料
PHP 4.1.11 有安全漏洞 如何更新??
« 於: 2002-03-19 03:38 »
那天聚會梁楓兄有跟我提醒PHP 4.1.11 不要裝 要就直接莊4.1.12
但是因為原本只是抱著嘗試看看的心態試試之前一直失敗的MySQL+Apache+PHP
於是就用了之前抓的4.1.11 tarball來做
沒想到居然成奶F!?之前已經失敗了5,6次 現在也知道了失敗在哪裡了!!
但是在試php測試頁時看到了 php 4.1.11才猛然想起梁楓兄說的安全漏洞一事
所以想請問  我要如何只更新 PHP 因為我想,安裝時有釵h ./configure的事前動作 不知道移除後在安裝和 apache 會不會有衝突
所以如何做更新動作 因為我還沒開始搞CVS所以請梁楓兄說明一下更新PHP要怎麼做

另外有一個問題  之前在另一個主題討論到的移除程式的問題,現在知道了 用port和pkg安裝的程式都可以用pkg_delete移除或是 make deinstall,但是如果我們是用tarball tar開後安裝好的程式要如何移除呢??
我之前有問學長,他也愣住了,因為他說他只會裝他要用的東西因為熟練也不曾裝錯版本,所以反而沒有這類經驗,想問問梁楓兄  要怎麼移除這類程式呢 就是在pkg_info都看不到pkg name, 所以不知道要如何pkg_delete

_________________
在今日的資訊領域中  你我之所以能夠方便的取得並應用所有的資訊
是因為前人的努力  而我們只是站在巨人的肩上

[ 這篇文章被編輯過:  gman 在 2002-03-19 03:38 ]
能力決定你作多少事,態度決定你作好多少事~

梁楓

  • 俺是博士!
  • *****
  • 文章數: 6220
    • 檢視個人資料
PHP 4.1.11 有安全漏洞 如何更新??
« 回覆 #1 於: 2002-03-19 10:10 »
我個人建議,將你的apache跟php4.1.1都先移除
然後在重新make apache、php4.1.2
這樣子會比較好一點...

cvsup設定很快,我個人建議你先cvsup在說
設定到執行不用花五分鐘吧:p
這樣子你的ports才會是最新的!

至於tarball的移除
恐怕就只有手動刪除了!