作者 主題: 關於核心編譯,不好意思,請教一下  (閱讀 2509 次)

0 會員 與 1 訪客 正在閱讀本文。

enochlee

  • 可愛的小學生
  • *
  • 文章數: 22
    • 檢視個人資料
關於核心編譯,不好意思,請教一下
« 於: 2002-02-05 00:35 »
小弟很懶,當初安裝時,沒有所謂重編核心,但是現在問題來了,為了netmeeting和msn能通過nat,要載入這二個modules,確屢屢失敗,重新編譯核心也失敗,不知是否要重灌linux,或下載新的核心來編譯.請不吝告知
p.s.
1.我照著netman兄的方法重新編譯,依然有error,都是出在modules部份,但是沒編譯前,用make menuconfig看,load modules的部份己經有選了啊.
2.核心為2.2.16-22

[ 這篇文章被編輯過:  enochlee 在 2002-02-05 00:37 ]

Anonymous

  • 訪客
關於核心編譯,不好意思,請教一下
« 回覆 #1 於: 2002-02-05 12:42 »
對了﹐要留意一下﹕我在網頁介紹的 kernel 版本是 2.4.9 ﹐其設定是否適用其它版本可不敢保證。

如果您確定是這個版本﹐您可以將我的設定下載回去﹕
http://www.study-area.org/linux/src/linux-2.4.9.kenny.tgz

然後﹕

tar zxvf linux-2.4.9.kenny.tgz
cp linux-2.4.9.kenny /usr/src/linux
cd /usr/src/linux
test -f .config && mv .config .config.bak
cp linux-2.4.9 .config
make dep clean ......... (按網頁步驟繼續)

kuolung

  • 俺是博士!
  • *****
  • 文章數: 1031
    • 檢視個人資料
    • http://www.kuolung.net
關於核心編譯,不好意思,請教一下
« 回覆 #2 於: 2002-02-05 14:55 »
就我的了解,用Linux的nat, kernel 2.2.x 版以前的並不支援,
您要用 kernel 2.4.x 版以後的,並撘配iptables 1.2.4 版以後的
才可以,您不妨試試看
=========================
http://www.kuolung.net
==========================