其他討論區 > 肉腳版

sid的VirtualBox-guest-x11套件“無效”的狀況

<< < (2/2)

IanHo:

--- 引述: Yamaka ---
可以參考一下這篇的步驟:
https://unix.stackexchange.com/a/286935

安裝並重開後, 在debian內的 displays 會有 VBX 螢幕, 點這個進去就可以選解析度
或者 VBox 的功能選單 [View] -> [Virtual Screen 1] 也可以選解析度

--- 引用結尾 ---

感謝Yamaka提供網頁資訊:
以下是我個人解決這個問題的推理過程還有又產生了新的問題~~~
之前印象沒錯的話,debian 9 RC版,因為virtualbox-guest-x11套件被拿掉了,
所以要在synaptic套件管理程式再加入 sid/unstable 套件庫,裡頭還有"virtualbox-guest-x11"。
在debian 9 RC版,我“只要”勾選安裝"virtualbox-guest-x11",剩下的debian會自己去計算一拖拉庫的套件相依性,然後竟批哩啪拉的開始自動下載安裝一拖拉庫相依套件,裝完了重開系統,就全螢幕了。根本不用花什麼腦筋。
debian 9 正式版發行之後,當然也是老方法繼續,重開機之後居然“沒有”全螢幕。
然後根據Yamaka提供的網頁內容,我另外先補安裝了幾個挑選過的套件,然後再裝"virtualbox-guest-x11"。
一樣是批哩啪拉的開始自動下載安裝一拖拉庫相依套件。裝完之後,系統重開,就全螢幕了。
我是覺得這樣在終端使用者思維上很不合理,誰會知道從RC版到正式版,套件的相依關係會被斷開???
誰又會知道相依關係被斷開的套件又是哪些???這樣除錯過程真是災難~~~
雖然全螢幕了,新的問題又產生了,在debian 9正式版 加入 sid/unstable 套件庫,synaptic套件管理程式 點選更新套件庫。
然後會出現一堆錯誤訊息,把這堆錯誤訊息拿去google,乍看之下得到的資訊是 rm /etc/apt/trusted.gpg,
照做之後更新套件庫的錯誤訊息就沒再出現了,但是移除trusted.gpg似乎是不妥的事情,需要再生成回來。
google之後得到的訊息是 apt-key update 照做之後,得到的回應又是錯誤訊息,又把錯誤訊息拿去google 結果找不到我看得懂的debian環境專用trusted.gpg更新解決方案。
狀況還真多~~~之前印象中debian 9 RC版也都“沒有遇到” 加個 sid/unstable 套件庫 後更新套件還會出現錯誤訊息的狀況。

IanHo:
補充:
先行依序勾選捕安裝套件:
linux-headers-4.9.0-3-amd64
build-essential
module-assistant
再來裝:
virtualbox-guest-x11
就全螢幕

導覽

[0] 文章列表

[*] 上頁

前往完整版本