作者 主題: 懇求Exchange 2013出現Event ID 4999 和7031的解決方式  (閱讀 2061 次)

0 會員 與 1 訪客 正在閱讀本文。

arielsheen

  • 懷疑的國中生
  • **
  • 文章數: 42
    • 檢視個人資料
我的環境 Windows 2012 R2 +Exchange 2013 CU6

2014/10 幫公司建立全新的Exchange 2013主機,Exchange的安裝方式是從SP1直接升級到CU6,

Exchange 2013的功能執行上都沒有問題,可是事件檢視器會一直出現錯誤訊息(Event ID 4999 和7031)

搜尋很多網路文章,依照其操作方式,仍無法解決問題,我相信這是Exchange 2013升級CU6造成的,網路上也有

一些網友有相同的困擾,可是沒有真正的解決之道. 2015/4/16之前的windows update全做完了,也曾經用虛擬機

測試安裝CU7和CU8,問題依然存在,請問這問題要怎麼解決  謝謝大家

**************************************************

Event 4999的內容

即將傳送下列處理程序識別碼的Watson報告:9624,使用參數:E12IIS、c-RTL-AMD64、15.00.0995.029、M.E.RpcClientAccess Service、unknown、M.E.D.T.I.F.F.TextStore.AddText、System.IndexOutOfRangeException、5453、unknown。

ErrorReportingEnabled:False

***************************************************

Event 7031的內容 (每20~30秒會出現一次)

Microsoft Exchange Diagnostics服務意外中止,服務曾完成這項動作225次。 以下的修正操作將在60000毫秒

內執行:重新啟動服務。

***************************************************

參考過的文章很多,其中有一篇內容並無法解決問題

http://blogs.technet.com/b/anya/archive/2014/11/25/microsoft-exchange-diagnostics-service-crashing-post-cu6-upgrade.aspx

arielsheen

  • 懷疑的國中生
  • **
  • 文章數: 42
    • 檢視個人資料
問題已經解決
操作步驟
(1) check "Windows Scheduler Service", okay
(2)check for entrys present at regedit : "HKLM\Software\Microsoft\PLA\Templates", okay
(3)delete registry-key "HKLM\Software\Microsoft\Windows NT\Currentversion\Schedule\TaskCache\Tree\Microsoft\Windows\PLA\ExchangeDiagnosticsDailyPerformanceLog"

delete registry-key "HKLM\Software\Microsoft\Windows NT\Currentversion\Schedule\TaskCache\Tree\Microsoft\Windows\PLA\ExchangeDiagnosticsPerformanceLog"
(4)Delete Counter from below path
Perfmon ->DataCollector->User Define -> Delete ExchangeDiagnosticsDailyPerformanceLog counter
(如果ExchangeDiagnostics開頭有兩個,都一起刪除)
(5)Exchange主機重開機
(6)確認工作排程器 (工作排程器-->工作排程器程式庫-->Microsoft -->Windows-->PLA)
    ExchangeDiagnosticsDailyPerformanceLog和ExchangeDiagnosticsPerformanceLog是在執行中
(7)確認效能監視器 (資料收集器集合工具-->使用者定義)
 ExchangeDiagnosticsDailyPerformanceLog和ExchangeDiagnosticsPerformanceLog都有在運行中

本問題也有在Technet論壇討論,有人回覆我,不過論壇無法登入,一直叫我驗證,簡訊和Email都試過,還是進不去,如果回覆我的人有看到這篇,在此跟您謝謝

補充一下 : 如果您依照上面的順序跑一遍,發現(6)(7)項目都只出現一個,並沒有兩個都出現,請再重頭開始跑一遍,就一定會成功   
« 上次編輯: 2015-04-28 15:18 由 arielsheen »

jacktseng

  • 鑽研的研究生
  • *****
  • 文章數: 934
    • 檢視個人資料
感謝分享解決方式