作者 主題: 安裝postfix的驗證套件cyrus-sasl-md5、cyrus-sasl-plain、cyrus-sasl出現問題  (閱讀 2304 次)

0 會員 與 1 訪客 正在閱讀本文。

snack.shih

  • 可愛的小學生
  • *
  • 文章數: 29
    • 檢視個人資料
各位先進好:
      小弟在安裝如題的套件時,出現以下狀況,可否麻煩各位前輩幫小弟解惑一下,謝謝...
[root@dns ~]# yum -y install cyrus-sasl-md5 cyrus-sasl-plain cyrus-sasl
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Setting up Install Process
Package matching cyrus-sasl-2.1.23-13.el6.x86_64 already installed. Checking for update.
Resolving Dependencies
--> Running transaction check
---> Package cyrus-sasl-md5.x86_64 0:2.1.23-13.el6 will be installed
--> Processing Dependency: cyrus-sasl-lib = 2.1.23-13.el6 for package: cyrus-sasl-md5-2.1.23-13.el6.x86_64
---> Package cyrus-sasl-plain.x86_64 0:2.1.23-13.el6 will be installed
--> Running transaction check
---> Package cyrus-sasl-lib.i686 0:2.1.23-13.el6 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.3.4) for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.0) for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libdl.so.2(GLIBC_2.1) for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libresolv.so.2 for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libc.so.6 for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libdl.so.2 for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libdb-4.7.so for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libc.so.6(GLIBC_2.3) for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Processing Dependency: libcrypt.so.1 for package: cyrus-sasl-lib-2.1.23-13.el6.i686
--> Running transaction check
---> Package db4.i686 0:4.7.25-16.el6 will be installed
---> Package glibc.i686 0:2.12-1.47.el6_2.12 will be installed
--> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.47.el6_2.12.i686
--> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.47.el6_2.12.i686
--> Running transaction check
---> Package nss-softokn-freebl.i686 0:3.12.9-11.el6 will be installed
--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:

         1. You have an upgrade for cyrus-sasl-lib which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of cyrus-sasl-lib of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude cyrus-sasl-lib.otherarch ... this should give you an error
            message showing the root cause of the problem.

         2. You have multiple architectures of cyrus-sasl-lib installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.

         3. You have duplicate versions of cyrus-sasl-lib installed already.
            You can use "yum check" to get yum show these errors.

       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).

       Protected multilib versions: cyrus-sasl-lib-2.1.23-13.el6.i686 != cyrus-sasl-lib-2.1.23-13.el6_3.1.x86_64
Error: Protected multilib versions: db4-4.7.25-16.el6.i686 != db4-4.7.25-17.el6.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

小弟的作業系統是CentOS 6.4  2.6.32-358.el6.x86_64
« 上次編輯: 2013-07-10 16:54 由 snack.shih »

snack.shih

  • 可愛的小學生
  • *
  • 文章數: 29
    • 檢視個人資料
各位先進好:
      小弟在安裝如題的套件時,出現以下狀況,可否麻煩各位前輩幫小弟解惑一下,謝謝...
[root@dns ~]# yum -y install cyrus-sasl-md5 cyrus-sasl-plain cyrus-sasl
Loaded plugins: fastestmirr.........................................以下省略

小弟的作業系統是CentOS 6.4  2.6.32-358.el6.x86_64



已解決...。