作者 主題: rpmbuild "perl-Compress-Raw-Zlib-2.027-1.noarch" 錯誤  (閱讀 1721 次)

0 會員 與 1 訪客 正在閱讀本文。

sclin2k

  • 懷疑的國中生
  • **
  • 文章數: 73
    • 檢視個人資料
我的系統是 CentOS 6,rebuild "perl-Compress-Raw-Zlib-2.027-1.noarch"出現的錯誤訊息,看起來像是缺了套件,但不知從何查起,請大家幫幫忙,謝謝!!!

補充:rpm-lib 版本是 rpm-libs-4.8.0-27.el6.i686

Processing files: perl-Compress-Raw-Zlib-2.027-1.noarch
Provides: Zlib.so perl(Compress::Raw::Zlib) = 2.027
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 rpmlib(VersionedDependencies) <= 3.0.3-1
Requires: libc.so.6 libc.so.6(GLIBC_2.0) libc.so.6(GLIBC_2.1.3) libc.so.6(GLIBC_2.3.4) libc.so.6(GLIBC_2.4) rtld(GNU_HASH)
錯誤:Arch dependent binaries in noarch package


RPM 組建錯誤:
    Arch dependent binaries in noarch package
« 上次編輯: 2012-12-18 11:40 由 sclin2k »

hikohan

  • 俺是博士!
  • *****
  • 文章數: 1288
    • 檢視個人資料
Re: rpmbuild "perl-Compress-Raw-Zlib-2.027-1.noarch" 錯誤
« 回覆 #1 於: 2012-12-18 12:28 »
rpm 建議用官方釋出的,不然如果有善心人士幫你整組打好的。

perl 可以直接利用 cpan install ,或者手動 perl MAKEFILE.PL 打造 。
lifeIsFunWithPHP.

sclin2k

  • 懷疑的國中生
  • **
  • 文章數: 73
    • 檢視個人資料
Re: rpmbuild "perl-Compress-Raw-Zlib-2.027-1.noarch" 錯誤
« 回覆 #2 於: 2012-12-18 12:36 »
您好,
會安裝這個套件是因為安裝MailScanner時它會一併安裝
但不知為什麼這個套件裝不起來
所以想另外想辦法試著安裝它
謝謝您

補充一下:我有先在測試機安裝是可以正常安裝,結果在正常服務的主機裝不起來,還好MailScanner還是可以正常啟動及掃瞄,不然就......
« 上次編輯: 2012-12-18 12:41 由 sclin2k »

sclin2k

  • 懷疑的國中生
  • **
  • 文章數: 73
    • 檢視個人資料
Re: rpmbuild "perl-Compress-Raw-Zlib-2.027-1.noarch" 錯誤
« 回覆 #3 於: 2012-12-18 13:32 »
謝謝 hikohan,終於透過 cpan 解決了。

rpm 建議用官方釋出的,不然如果有善心人士幫你整組打好的。

perl 可以直接利用 cpan install ,或者手動 perl MAKEFILE.PL 打造 。