作者 主題: yum update报错 看样子很严重哦,rpm软件没能正常更新,请求帮助  (閱讀 2576 次)

0 會員 與 1 訪客 正在閱讀本文。

vcvok

  • 可愛的小學生
  • *
  • 文章數: 1
    • 檢視個人資料
^C[root@localhost ~]# yum update
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirror.bit.edu.cn
 * extras: mirror.bit.edu.cn
 * updates: mirror.bit.edu.cn
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package rpm.i686 0:4.8.0-19.el6 will be updated
--> Processing Dependency: rpm = 4.8.0-19.el6 for package: rpm-libs-4.8.0-19.el6.i686
---> Package rpm.i686 0:4.8.0-27.el6 will be an update
---> Package rpm-python.i686 0:4.8.0-19.el6 will be updated
---> Package rpm-python.i686 0:4.8.0-27.el6 will be an update
--> Finished Dependency Resolution
Error: Package: rpm-libs-4.8.0-19.el6.i686 (@base/$releasever)
           Requires: rpm = 4.8.0-19.el6
           Removing: rpm-4.8.0-19.el6.i686 (@base/$releasever)
               rpm = 4.8.0-19.el6
           Updated By: rpm-4.8.0-27.el6.i686 (base)
               rpm = 4.8.0-27.el6
 You could try using --skip-broken to work around the problem

fishgo65

  • 懷疑的國中生
  • **
  • 文章數: 33
    • 檢視個人資料
    • Blog
看起來是因為rpm和rpm.python有兩個版本
rpm.i686 0:4.8.0-19.el6
rpm.i686 0:4.8.0-27.el6

rpm-python.i686 0:4.8.0-19.el6
rpm-python.i686 0:4.8.0-27.el6

試著把-19版的刪掉再update看看