作者 主題: 如何在vmware workstation中將nt4的網卡啟動起來?  (閱讀 9119 次)

0 會員 與 1 訪客 正在閱讀本文。

jylin

  • 可愛的小學生
  • *
  • 文章數: 7
    • 檢視個人資料
1. 我將一部實體nt4主機轉成虛擬機, 但網卡在控制台的週邊設備中有看到該網卡,但卻無法啟動它,請問有何解決法?
2.新增一片AMD PCNET系列Ethernet介面卡,但系統卻出現找不到oemsetup.inf
3.請問該如何才能解決此vm連上網路的問題 , 謝謝!

slime

  • 區域板主
  • 俺是博士!
  • *****
  • 文章數: 1692
    • 檢視個人資料
1. 我將一部實體nt4主機轉成虛擬機, 但網卡在控制台的週邊設備中有看到該網卡,但卻無法啟動它,請問有何解決法?
2.新增一片AMD PCNET系列Ethernet介面卡,但系統卻出現找不到oemsetup.inf
3.請問該如何才能解決此vm連上網路的問題 , 謝謝!


有裝 vm-tools (如果是 VMware 系列)了嗎?

由於虛擬環境提供的網卡與原本實體網卡不同,
所以在 nt4 會以為有換過網卡, 需要安裝驅動程式(vm-tools內有包含)並檢查相關網路設定.
冷笑話: 我的 IP 是 127.0.0.1

jylin

  • 可愛的小學生
  • *
  • 文章數: 7
    • 檢視個人資料
我有裝 vm-tools

slime

  • 區域板主
  • 俺是博士!
  • *****
  • 文章數: 1692
    • 檢視個人資料
我有裝 vm-tools

1. 那 VMware 的設定為何? 是否有使用 Bridge 到實體網卡, 或透過 NAT 連線?
2. "網卡在控制台的週邊設備中有看到該網卡,但卻無法啟動它"可以再詳細描述嗎?
冷笑話: 我的 IP 是 127.0.0.1

u8526425

  • 俺是博士!
  • *****
  • 文章數: 1135
  • 性別: 男
    • 檢視個人資料
AMD PCNET系列Ethernet介面卡
手動安裝Driver
指向C:\Program Files\VMware\VMware Tools\Drivers\vmxnet
多見者博,多聞者智,拒諫者塞,專己者孤

jylin

  • 可愛的小學生
  • *
  • 文章數: 7
    • 檢視個人資料
如附件圖所示, 因系統設定該網卡為自動啟動,但它並沒有啟動成功,因此我便去按右側的啟動鈕,結果就出現如附件的錯誤訊息。再到視件檢視器中找到的error message為
32-Bit PCI Fast Ethernet Adapter Driver 服務宣告失敗,錯誤原因:
附加到系統的週邊設備無法作用。

u8526425

  • 俺是博士!
  • *****
  • 文章數: 1135
  • 性別: 男
    • 檢視個人資料
NT4有升級到SP6a嗎 ?
多見者博,多聞者智,拒諫者塞,專己者孤

jylin

  • 可愛的小學生
  • *
  • 文章數: 7
    • 檢視個人資料
系統本來就是sp6a

jylin

  • 可愛的小學生
  • *
  • 文章數: 7
    • 檢視個人資料
**AMD PCNET系列Ethernet介面卡
手動安裝Driver
指向C:\Program Files\VMware\VMware Tools\Drivers\vmxnet
***

我在檔案總管C:\Program Files\VMware\VMware Tools\Drivers下未發現vmxnet的檔案或目錄.

dark

  • 俺是博士!
  • *****
  • 文章數: 1581
    • 檢視個人資料
不吃 rar ... 剛剛打的都不見了

簡言之 ...
小弟只有 xp

若不行 , vmware 裝一次 win98 , NT , 2000 就有了

jylin

  • 可愛的小學生
  • *
  • 文章數: 7
    • 檢視個人資料
至今我還是沒能解決,不知有人可以協助?非常感謝謝!

twu2

  • 管理員
  • 俺是博士!
  • *****
  • 文章數: 5394
  • 性別: 男
    • 檢視個人資料
    • http://blog.teatime.com.tw/1
官方的解決方法, 上頭就有人寫了.
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1018546

有問題... 直接去問 VMWare 不就好了?

jylin

  • 可愛的小學生
  • *
  • 文章數: 7
    • 檢視個人資料
官方的解決方法, 上頭就有人寫了.
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1018546

有問題... 直接去問 VMWare 不就好了?

1.重點不在是否新增一片amd網卡, 而是如首篇附件中的硬體設定檔無法啟用網卡設備,所以如即使能幸運新增一片AMD網卡,在硬體設定檔也是無法啟動起來.
2.感謝您的連結文章...雖然派不不上用場.

日京三子

  • 全區板主
  • 俺是博士!
  • *****
  • 文章數: 8829
    • 檢視個人資料
    • http://www.24online.cjb.net
依我當初轉移的經驗,我不需要額外新增網卡,就可以平順的使用躲在VM裡面的NT4.0了!

你用哪一套軟體來進行轉移的?
哈克不愛的多合一輸入平台----->新香草口味
過去的時間不斷流逝,抹去的眼淚已成追憶;
乾枯的雙手無力阻止,再會了我遠去的曾經。

hikohan

  • 俺是博士!
  • *****
  • 文章數: 1288
    • 檢視個人資料
感覺很像 VM 的 bridge / NAT 沒設好,建議樓主仔細檢查一下,應該不難設。

天氣熱,喝杯冷飲,先冷靜一下吧。  ;D
lifeIsFunWithPHP.