作者 主題: [問題] 安裝套件相依性如何查該對應的套件名單?  (閱讀 2048 次)

0 會員 與 1 訪客 正在閱讀本文。

joe0120

  • 活潑的大學生
  • ***
  • 文章數: 241
    • 檢視個人資料
目標:
安裝 psad 套件

環境:
CentOS release 5.7 (Final)
Linux test113_188 2.6.18-274.7.1.el5 #1 SMP Thu Oct 20 16:21:01 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux


參考來源:https://matrix.senecac.on.ca:8443/wiki/ifs/index.php/SPR500_PSAD

yum install perl-IPTables-ChainMgr perl-Net-Ipv4Addr perl-Unix-Syslog perl-Data-Calc
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * rpmforge: ftp-stud.fht-esslingen.de
Setting up Install Process
No package perl-IPTables-ChainMgr available.
No package perl-Net-Ipv4Addr available.
  * Maybe you meant: perl-Net-IPv4Addr
Package perl-Unix-Syslog-1.1-1.el5.rf.x86_64 already installed and latest version
No package perl-Data-Calc available.

原本以為很容易的,但執行後才發現找不到套件,那就改直接下載相關套件好了,但會有相依性問題
 rpm -Uvh perl-IPTables-ChainMgr-0.9-5.noarch.rpm
warning: perl-IPTables-ChainMgr-0.9-5.noarch.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 97a1071f
error: Failed dependencies:
        perl(:MODULE_COMPAT_5.12.0) is needed by perl-IPTables-ChainMgr-0.9-5.noarch
        perl(IPTables::Parse) is needed by perl-IPTables-ChainMgr-0.9-5.noarch
        rpmlib(FileDigests) <= 4.6.0-1 is needed by perl-IPTables-ChainMgr-0.9-5.noarch
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by perl-IPTables-ChainMgr-0.9-5.noarch

問題:
請教各位如遇到安裝套件,遇到相依性,該如何找到對應的套件再安裝呢,如  perl(IPTables::Parse)  它的套件名稱是什麼呢,rpm 或 yum 有辦法查出嗎 ?

謝"


fishgo65

  • 懷疑的國中生
  • **
  • 文章數: 33
    • 檢視個人資料
    • Blog
rpm和yum就可以查套件的相依性了
有些網站也會把相依的套件列出來
例如  http://rpmfind.net//linux/RPM/fedora/updates/testing/16/i386/openldap-2.4.26-5.fc16.i686.html

perl的套件可以用CPAN的方式安裝
perl -MCPAN -e shell
>install IPTables::Parse