作者 主題: fedora 16會不會yum不能用呢  (閱讀 3886 次)

0 會員 與 1 訪客 正在閱讀本文。

jeremy168

  • 活潑的大學生
  • ***
  • 文章數: 255
    • 檢視個人資料
    • http://www.pica.idv.tw
fedora 16會不會yum不能用呢
« 於: 2012-02-01 21:07 »
大家好
請問一下有人安裝完fedora 16會不會yum不能用呢?
因我的下yum install snmp
它會說發生錯務,大略說找不到repoxm;.xml檔要我提供這一個檔案的路徑
有人有遇過嗎???

Acoju

  • 懷疑的國中生
  • **
  • 文章數: 50
    • 檢視個人資料
Re: fedora 16會不會yum不能用呢
« 回覆 #1 於: 2012-02-02 07:51 »
$ su root
密碼:
[root@localhost userxxx]# yum install audacity
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package audacity.x86_64 0:1.3.14-0.5.fc16 will be installed
.......省略.....
================================================================================
Install       6 Packages

Total download size: 7.3 M
Installed size: 18 M
Is this ok [y/N]: y
Downloading Packages:
(1/6): audacity-1.3.14-0.5.fc16.x86_64.rpm               | 3.6 MB     00:02     
(2/6): libid3tag-0.15.1b-11.fc15.x86_64.rpm              |  43 kB     00:00     
(3/6): soundtouch-1.4.0-4.fc15.x86_64.rpm                |  51 kB     00:00     
(4/6): vamp-plugin-sdk-2.2.1-1.fc16.x86_64.rpm           | 148 kB     00:00     
(5/6): wxBase-2.8.12-1.fc16.x86_64.rpm                   | 564 kB     00:00     
(6/6): wxGTK-2.8.12-1.fc16.x86_64.rpm                    | 2.9 MB     00:02     
--------------------------------------------------------------------------------
Total                                           1.2 MB/s | 7.3 MB     00:06     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : wxBase-2.8.12-1.fc16.x86_64                                  1/6
  Installing : wxGTK-2.8.12-1.fc16.x86_64                                   2/6
  Installing : libid3tag-0.15.1b-11.fc15.x86_64                             3/6
  Installing : vamp-plugin-sdk-2.2.1-1.fc16.x86_64                          4/6
  Installing : soundtouch-1.4.0-4.fc15.x86_64                               5/6
  Installing : audacity-1.3.14-0.5.fc16.x86_64                              6/6

Installed:
  audacity.x86_64 0:1.3.14-0.5.fc16                                             

Dependency Installed:
  libid3tag.x86_64 0:0.15.1b-11.fc15        soundtouch.x86_64 0:1.4.0-4.fc15   
  vamp-plugin-sdk.x86_64 0:2.2.1-1.fc16     wxBase.x86_64 0:2.8.12-1.fc16       
  wxGTK.x86_64 0:2.8.12-1.fc16             

Complete!
[root@localhost usrxxxx]#
以上證明 yum install 是正常的

yum install snmp
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
No package snmp available.
Error: Nothing to do

沒這個snmp包包可以install
如果你有gnome視窗就用視窗軟體GNOME 套件管理程式去裝你要的軟體吧
裝軟體有不少要用新的名稱

jeremy168

  • 活潑的大學生
  • ***
  • 文章數: 255
    • 檢視個人資料
    • http://www.pica.idv.tw
Re: fedora 16會不會yum不能用呢
« 回覆 #2 於: 2012-02-02 17:54 »
謝謝大大的回覆這一個問題後來就自己好囉~怪事~

fc16是乎改滿多的, 目前重起服務如service sshd restart
指令不太能用了會出現如附件圖片

TyroneYeh

  • 俺是博士!
  • *****
  • 文章數: 2396
  • 性別: 男
    • 檢視個人資料
Re: fedora 16會不會yum不能用呢
« 回覆 #3 於: 2012-02-02 20:16 »
我用 Gentoo 追版不用重裝...
目前 kernel 3.2.1
kde 4.8

應該夠新吧!!

用 fedora 16,半年後來個 17 是又要重裝啦...
--
TyroneYeh

jeremy168

  • 活潑的大學生
  • ***
  • 文章數: 255
    • 檢視個人資料
    • http://www.pica.idv.tw
Re: fedora 16會不會yum不能用呢
« 回覆 #4 於: 2012-02-02 23:25 »
圖型我少玩,都用文字居多,很多服務都消失囉,用chkconfig看沒幾個,指令有些不同囉~
難怪有些si不追新,難攪又有不穩定問題

Acoju

  • 懷疑的國中生
  • **
  • 文章數: 50
    • 檢視個人資料
Re: fedora 16會不會yum不能用呢
« 回覆 #5 於: 2012-02-03 16:38 »
Fedora16 啟動一個服務的方法據說在FC15時就已經改變,使用了不同的啟動程式,所以有些服務並沒有在啟動時常駐,常常要自己打指令,如下啟動httpd mysql
systemctl enable httpd.service
systemctl enable mysqld.service
要讓一個服務常駐或常駐在服務視窗軟體上就用指令chkconfig,如下
chkconfig httpd on
chkconfig mysqld on
這樣就可以在服務視窗軟體上按停止或啟動的管理
但是要讓服務永久停止就要下指令chkconfig httpd off 服務
資料參考:http://fedoraproject.org/wiki/Systemd
« 上次編輯: 2012-02-03 16:47 由 Acoju »

jeremy168

  • 活潑的大學生
  • ***
  • 文章數: 255
    • 檢視個人資料
    • http://www.pica.idv.tw
Re: fedora 16會不會yum不能用呢
« 回覆 #6 於: 2012-02-04 15:20 »
謝謝大大提供的說明, 不然一直覺得很奇怪,沒玩一下新版都不知道,因家裡的還在fc13
fc似乎很常改一些指令和操作方式,真傷腦筋