作者 主題: 在Cisco 3750上如何指定某個IP走另一個路由  (閱讀 16608 次)

0 會員 與 1 訪客 正在閱讀本文。

peteryang

  • 憂鬱的高中生
  • ***
  • 文章數: 105
    • 檢視個人資料
各位先進大家好,

公司所有網段全都連到Core Switch 3750
小弟目前想要指定單一IP不走Default Route上Internet
想要改變成走另一個Gateway上Internet
不知小弟要如何設定
是要在access-list上設定
還是要在ip route裡設定呢???
煩請各位先進不吝指教
謝謝

kojj

  • 懷疑的國中生
  • **
  • 文章數: 45
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #1 於: 2011-08-05 14:16 »
我這邊Cisco 3560是用access-list去做,你參考看看

ip access-list extended router
 deny   ip any 10.1.0.0 0.0.255.255
 permit ip 10.1.180.0 0.0.0.255 any
!
route-map router permit 10
 match ip address router
 set ip next-hop 10.1.0.250

peteryang

  • 憂鬱的高中生
  • ***
  • 文章數: 105
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #2 於: 2011-08-05 14:54 »
kojj大大,


小弟試過了
但是還是不行
仍然還是走原有routing出去

因此在想是不是ip access-list的問題
請問是不是要將這個access-list放在原本ip access-list 的權值之前才行
這樣才會走這個routing呢??

kojj

  • 懷疑的國中生
  • **
  • 文章數: 45
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #3 於: 2011-08-08 14:02 »
我們的3560上切了許多vlan,而每一個client ip的default gateway都是該vlan 在3560的ip
因此還需要你自個確認架構上是否一致

interface GigabitEthernet0/11
 switchport access vlan 180

interface Vlan180
 ip address 10.1.180.254 255.255.255.0
 ip helper-address 10.1.100.10

ip access-list extended router
 deny   ip any 10.1.0.0 0.0.255.255
 permit ip 10.1.180.0 0.0.0.255 any
!
route-map router permit 10
 match ip address router
 set ip next-hop 10.1.0.250

dark

  • 俺是博士!
  • *****
  • 文章數: 1581
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #4 於: 2011-08-09 11:46 »
ACL 制定 -> route-map 套用 ACL -> interface 套用 route-map


access-list 101 permit ip 1.1.1.0 0.0.0.255
...

route-map abc permit 10
match ip address 101
set ip next-hop 1.1.1.x

int vlanx
ip addr 1.1.1.y
ip policy route-map abc

peteryang

  • 憂鬱的高中生
  • ***
  • 文章數: 105
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #5 於: 2011-08-09 12:03 »
kojj大大 & dark大大,

小弟公司的架構看起來跟您的是一樣
只不過在interface上沒有用switchport access vlan 4
而是在default
如下:
代碼: [選擇]
1    default                          active    Gi1/0/26, Gi1/0/27, Gi1/0/28, Gi2/0/26
                                                Gi2/0/27, Gi2/0/28
而run部份如下
代碼: [選擇]
interface GigabitEthernet2/0/28
!
interface Vlan4
 ip address 172.24.3.249 255.255.255.0
 ip helper-address 172.24.1.7
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.24.1.254
!
access-list 100 deny   ip host 172.24.3.83 any
access-list 100 permit ip any any
所以您之前提供的設定可能不行

小弟再試試看dark大大提供的方法
有最新消息,小弟會再上來回覆的
謝謝二位大大的不吝指教

peteryang

  • 憂鬱的高中生
  • ***
  • 文章數: 105
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #6 於: 2011-08-19 16:49 »
dark 大大,
小弟按照您的設定
還是會從Default Route出去
而不會從小弟指定的Route走
小弟後來想
是不是0.0.0.0的route是從default rotue出去
而小弟指定單一IP上網也是0.0.0.0所以會從default route走
而不是從指定route走
所以小弟想是不是routing table裡沒有這個指定單一IP的next-hop route
所以都會從default route

那小弟要如何在現在的routing table裡加入指定單一IP走小弟指定的route呢???

煩請各位先進及dark大大不吝指教
謝謝

michaelwan

  • 憂鬱的高中生
  • ***
  • 文章數: 159
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #7 於: 2011-08-20 00:04 »
代碼: [選擇]
1    default                          active    Gi1/0/26, Gi1/0/27, Gi1/0/28, Gi2/0/26
                                                Gi2/0/27, Gi2/0/28
而run部份如下
代碼: [選擇]
interface GigabitEthernet2/0/28
!
interface Vlan4
 ip address 172.24.3.249 255.255.255.0
 ip helper-address 172.24.1.7
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.24.1.254
!
access-list 100 deny   ip host 172.24.3.83 any
access-list 100 permit ip any any

dark大所提供的指令是沒錯的.
所以一定是你的架構沒有符合. default vlan & vlan 4 這就差很多了.
port 不屬於vlan 4, 而在vlan 4上設定PBR 怎麼可能會生效.

路由表是來決定目的要走的路徑, 不是拿來決定來源要走的路徑. 所以才會需要PBR.

peteryang

  • 憂鬱的高中生
  • ***
  • 文章數: 105
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #8 於: 2011-08-22 16:18 »
michaelwan 大大 & dark 大大,

小弟用sh vlan如下:
代碼: [選擇]
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Gi1/0/26, Gi1/0/27, Gi1/0/28, Gi2/0/26, Gi2/0/27, Gi2/0/28
2    VLAN0002                         active    Gi1/0/3, Gi1/0/4, Gi1/0/5, Gi1/0/6, Gi1/0/7, Gi1/0/8, Gi1/0/9, Gi1/0/10, Gi1/0/11, Gi1/0/12,
                                                             Gi1/0/13, Gi1/0/14, Gi1/0/15, Gi1/0/16, Gi1/0/17, Gi1/0/18, Gi1/0/19, Gi1/0/20, Gi2/0/1,
                                                             Gi2/0/2, Gi2/0/3, Gi2/0/4, Gi2/0/5, Gi2/0/6, Gi2/0/7, Gi2/0/8, Gi2/0/9, Gi2/0/10, Gi2/0/11,
                                                             Gi2/0/12, Gi2/0/13, Gi2/0/14, Gi2/0/15, Gi2/0/16, Gi2/0/17, Gi2/0/18, Gi2/0/19, Gi2/0/20
3    VLAN0003                         active    Gi1/0/1, Gi1/0/2
4    VLAN0004                         active
102  VLAN0102                         active    Gi1/0/23, Gi1/0/24, Gi2/0/23, Gi2/0/24
103  VLAN0103                         active
104  VLAN0104                         active    Gi1/0/21, Gi1/0/22, Gi2/0/21, Gi2/0/22

而sh vlan id 4如下:
代碼: [選擇]
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
4    VLAN0004                         active    Gi1/0/25, Gi2/0/25

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
4    enet  100004     1500  -      -      -        -    -        0      0

Remote SPAN VLAN
----------------
Disabled

Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

而在sh run如下:
代碼: [選擇]
interface GigabitEthernet1/0/2
 switchport access vlan 3
 switchport mode access

interface GigabitEthernet1/0/25
 switchport trunk encapsulation dot1q
 switchport mode trunk

interface GigabitEthernet2/0/2
 switchport access vlan 2
 switchport mode access

interface GigabitEthernet2/0/25
 switchport trunk encapsulation dot1q
 switchport mode trunk

而小弟在int giga1/0/25l裡面
發現沒有ip address 或是 route-map等設定
如下:
代碼: [選擇]
STACK-3750(config-if)#ip ?
Interface IP configuration subcommands:
  access-group  Specify access control for packets
  admission     Apply Network Admission Control
  arp           Configure ARP features
  dhcp          Configure DHCP parameters for this interface
  dhcp          DHCP
  igmp          IGMP interface commands
  verify        verify
  vrf           VPN Routing/Forwarding parameters on the interface
是不是小弟3750不支援
所以無法用這個功能呢???
煩請michaelwan & dark及各位先進不吝指教
謝謝

dark

  • 俺是博士!
  • *****
  • 文章數: 1581
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #9 於: 2011-08-23 12:13 »
vlan 是 L2
gateway 是 L3

int g1/0/x
no switch
才會變 L3 介面才能設 IP

你先 google vlan
再找兩台 switch 做 lab 體驗先吧


michaelwan

  • 憂鬱的高中生
  • ***
  • 文章數: 159
    • 檢視個人資料
Re: 在Cisco 3750上如何指定某個IP走另一個路由
« 回覆 #10 於: 2011-08-23 16:46 »
dark大已經寫的很清楚了.

VLAN 是L2(用no switch才會變L3)
Cisco 稱Switch Virtual Interface(SVI) 才是L3.
Brocade稱Virtual Port(VE)才是L3.

PS.在小弟的環境裡, 設定VLAN 一定會給一個VE.