作者 主題: linux套件版本支援問題  (閱讀 9061 次)

0 會員 與 1 訪客 正在閱讀本文。

feeling006

  • 可愛的小學生
  • *
  • 文章數: 2
    • 檢視個人資料
linux套件版本支援問題
« 於: 2011-03-16 17:40 »
初學者 ???
(1)假如 CentOS5.5 發行很多年,然後出版到6.6甚至7.0版本等。結果發行商說已經不支援 CentOS5.5了,停止套件更新。這樣使用 yum update 不就沒有正面幫助嗎??還是選擇 Server 資料備份,移轉到目前最新版的主機上(新建置的OS)

(2) 使用 yum update 指令讓系統的套件全面升級,是否會造成問題?如不小心更動核心kernel,造成最新版而使得系統不太穩。

    可以麻煩各位前輩指點迷津,謝謝~~

netman

  • 管理員
  • 俺是博士!
  • *****
  • 文章數: 17465
    • 檢視個人資料
    • http://www.study-area.org
回覆: linux套件版本支援問題
« 回覆 #1 於: 2011-03-16 21:59 »
當初設計的時候,應該知道哪些軟體是獨立在 distro repostory 之外的,
先針對這部份進行升級測試,OK就其他就直接升級了。

harrier

  • 榮譽博士
  • 俺是博士!
  • *****
  • 文章數: 1856
  • 性別: 男
    • 檢視個人資料
    • 國屬武裝兵
回覆: linux套件版本支援問題
« 回覆 #2 於: 2011-03-17 18:17 »
(1)假如 CentOS5.5 發行很多年,然後出版到6.6甚至7.0版本等。結果發行商說已經不支援 CentOS5.5了,停止套件更新。這樣使用 yum update 不就沒有正面幫助嗎??還是選擇 Server 資料備份,移轉到目前最新版的主機上(新建置的OS)
(2) 使用 yum update 指令讓系統的套件全面升級,是否會造成問題?如不小心更動核心kernel,造成最新版而使得系統不太穩。

1.要視 AP 而定,現在最差的狀況可以選擇 VM 化,起碼解決硬體問題,資安問題可能可以用自己 compiler 解決;
2.有可能反而造成 AP 不穩..請多備份;RPM 算是很方便,基本上如果你有紀錄更新了什麼也知道員來的版本是什麼,可以 downgrade。
...90Net(90:1200/1203),GameNET(99:700/707),ALLNet(92:9200/3111),InfoNet(30:100/103)..MaximusCBCS(浮懷),AirNet,TenderNet,StormNet,FidoNet...
<<- www.nas.vg ->>