作者 主題: 【問題】{Fedora 14 @ Esxi 4.1} 找不到usb裝置  (閱讀 8107 次)

0 會員 與 1 訪客 正在閱讀本文。

aa31029

  • 可愛的小學生
  • *
  • 文章數: 4
    • 檢視個人資料
各位大大好…

目前有一個問題,找了google大神、vbird、study-area網站,實在是…找不出怎麼解決 >"<
所以上來這裡,想請教各位高手:

先前安裝了VMWare Esxi 4.1,因為想測media wiki,所以安裝了Fedora 14,
不過為了將media wiki檔案放在新建的虛擬伺服器上,想到用usb的方式上傳 (因為公司網路政策,伺服器不能連外網,所以不能wget)

我已先在VMware vSphere Client上加入了usb裝置 (因為預設不認usb)
方法如下:
安裝USB controller、USB device:
在虛擬伺服器上點選『右鍵』→『Edit Settings』→『Add』→分別選擇『USB Controller』和『USB Device』→『Next』→『OK』

接下來再回到Fedora 14,嘗試要mount usb,因為usb應該會被認為scsi,所以應該會是sdax (雖然我不是很肯定)
若我下達『df -h』,目前為:
檔案系統                  Size   Used  Avail    Use%      掛載點
/dev/mapper/vg_mediawiki-lv_root    39G   1.7G   35G   5%   /
tmpfs                                             186M      0      186M    0%   /dev/shm
/dev/sda1                                       485M    28M      432M        7%       /boot

其實接下來…我就不知怎麼找到usb被認成什麼
有試著在/etc/dmesg裡找,但是當我把usb插上去時,也沒有出現新訊息,重開機也是…
所以…想請問大大們,我應該要朝哪方面繼續著手呢?
謝謝

Darkhero

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 3728
  • 性別: 男
    • 檢視個人資料
    • ㄚ凱隨手紀
各位大大好…

目前有一個問題,找了google大神、vbird、study-area網站,實在是…找不出怎麼解決 >"<
所以上來這裡,想請教各位高手:

先前安裝了VMWare Esxi 4.1,因為想測media wiki,所以安裝了Fedora 14,
不過為了將media wiki檔案放在新建的虛擬伺服器上,想到用usb的方式上傳 (因為公司網路政策,伺服器不能連外網,所以不能wget)

我已先在VMware vSphere Client上加入了usb裝置 (因為預設不認usb)
方法如下:
安裝USB controller、USB device:
在虛擬伺服器上點選『右鍵』→『Edit Settings』→『Add』→分別選擇『USB Controller』和『USB Device』→『Next』→『OK』

接下來再回到Fedora 14,嘗試要mount usb,因為usb應該會被認為scsi,所以應該會是sdax (雖然我不是很肯定)
若我下達『df -h』,目前為:
檔案系統                  Size   Used  Avail    Use%      掛載點
/dev/mapper/vg_mediawiki-lv_root    39G   1.7G   35G   5%   /
tmpfs                                             186M      0      186M    0%   /dev/shm
/dev/sda1                                       485M    28M      432M        7%       /boot

其實接下來…我就不知怎麼找到usb被認成什麼
有試著在/etc/dmesg裡找,但是當我把usb插上去時,也沒有出現新訊息,重開機也是…
所以…想請問大大們,我應該要朝哪方面繼續著手呢?
謝謝

不能連外網, 那內網可以吧?...

可以 ssh 的話, 直接用 sftp 傳上去就好了...
或是你自己的電腦開分享資料夾, fedora 用 smbclient 去抓檔案也可以...

何必這麼麻煩的還要用到 usb 裝置呢?...

希望我們的討論是為了把問題解決,而不是爭論誰對誰錯.
『灌水才是重點,發文只是順便』
『我寧可讓不會釣魚的工程師餓死,也不想讓會餓死的工程師去攪沉公司....』
Blog: http://blog.darkhero.net/
秘密基地: http://www.darkhero.net/comic/
目前服務的網站: http://www.libook.com.tw/

aa31029

  • 可愛的小學生
  • *
  • 文章數: 4
    • 檢視個人資料
謝謝darkhero~~ 我來測試看看…

另一方面…我還是很想解決抓usb的問題,因為…百思不解啊~~沒遇過這種事 @@

aa31029

  • 可愛的小學生
  • *
  • 文章數: 4
    • 檢視個人資料
神奇的事發生了…
發問的那天,我不信邪的用mount -v -t auto /dev/sdb1 /mnt/usb
結果…當然是沒成功 因為fdisk就是沒看到sdx的出現(除了sda)

但是隔一天,我再用一次mount -v -t auto /dev/sdb1 /mnt/usb,
成功了!! 此時再看fdisk,也出現了sdb1

然後…本持著好奇的精神,在Esxi 4.1上,再灌一個Fedora,
結果…跟第一次一樣,fdisk、dmesg、message,完全沒有新裝置的出現,
星期一去公司,再試一次看看 @@

↑這麼怪的事,不知道有沒有人也有同樣的經驗

aa31029

  • 可愛的小學生
  • *
  • 文章數: 4
    • 檢視個人資料
向各位大大報告→

星期一,果然在fdisk -l找到了我的usb

我有問了某Linux老師,他說OS不支援
不過我不懂,如果不支援,為什麼隔一天就抓到了…

tnth

  • 懷疑的國中生
  • **
  • 文章數: 62
    • 檢視個人資料
在你安裝fedora的時候應該就已經用掉sda了
再加入usb會從sda之後的(sdb,sdc...)開始,
建議你去看看鳥哥的硬碟管理方面的會比較清楚