作者 主題: 關於使用主機板內建RAID安裝CentOS的問題  (閱讀 6845 次)

0 會員 與 1 訪客 正在閱讀本文。

Blue Jacky

  • 憂鬱的高中生
  • ***
  • 文章數: 155
  • 性別: 男
    • 檢視個人資料
最近公司一些資訊設備要重新作調配運用
我打算把其中的一部伺服器拿來安裝 Linux 系統

以下是它的設備概要
Intel 2.8GHz
Intel SE7230NH1-E
WDC 250G *2

它原先的系統是 Windows Server 2003 R2
兩顆硬碟是用主機板上內建的 RAID 1(MIRROR)
但在重新安裝 CentOS 5.4 x64 時
奇妙的事發生了

安裝過程中
系統會直接辦識到有兩顆硬碟
而不是一顆(RAID 1)
然後問我要安裝在那一顆

回到BIOS檢查
兩顆硬碟的確是以 RAID 1 設定成一顆
按理說主機板上內建的 RAID 功能算是硬體 RAID
也就是軟體(作業系統)應該只會辨識為一顆
不是嗎?

在論壇找了一下
看能否找到相關的資訊
有些類似的貼文
例如以下
http://phorum.study-area.org/index.php/topic,28336.0.html
http://phorum.study-area.org/index.php/topic,47744.0.html

但與我遇到的問題又不太一樣
由於其中有位網友在回文有提到可能是驅動程式的問題
我試著到INTEL網站去找
http://downloadcenter.intel.com/SearchResult.aspx?lang=zht&keyword=%22SE7230NH1-E%22
找到這個
http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=9303&lang=zht

但似乎是我太"肉腳"了
在安裝過程中依然沒辦法只辨識為一顆硬碟
不知各位先進能否提供指引?
劫後餘生,一切從頭...

phantom

  • SA 苦力組
  • 俺是博士!
  • *****
  • 文章數: 2185
    • 檢視個人資料
這就是所謂的Fake Hardware Raid。

你給的第二個連結裡不就有提到了嗎?
« 上次編輯: 2010-05-24 17:31 由 phantom »
Linux 非萬能, 沒 Linux 萬萬不能.
root = God
apt-get install ultimate-horsepower

日京三子

  • 全區板主
  • 俺是博士!
  • *****
  • 文章數: 8830
    • 檢視個人資料
    • http://www.24online.cjb.net
你用的RAID卡是?


----
如果是OnBoard的,就不用想太多了.....
哈克不愛的多合一輸入平台----->新香草口味
過去的時間不斷流逝,抹去的眼淚已成追憶;
乾枯的雙手無力阻止,再會了我遠去的曾經。

Blue Jacky

  • 憂鬱的高中生
  • ***
  • 文章數: 155
  • 性別: 男
    • 檢視個人資料
這就是所謂的Fake Hardware Raid。

你給的第二個連結裡不就有提到了嗎?

但 kuolung 兄在回答問題提到"如果設定為 Raid 0/1 , CentOS 5.0 的安裝光碟,可直接認到,安裝"
但我實際操作是一開始安裝就...不認得
卻不明瞭自己步驟錯在那?
劫後餘生,一切從頭...

日京三子

  • 全區板主
  • 俺是博士!
  • *****
  • 文章數: 8830
    • 檢視個人資料
    • http://www.24online.cjb.net
這就是所謂的Fake Hardware Raid。

你給的第二個連結裡不就有提到了嗎?

但 kuolung 兄在回答問題提到"如果設定為 Raid 0/1 , CentOS 5.0 的安裝光碟,可直接認到,安裝"
但我實際操作是一開始安裝就...不認得
卻不明瞭自己步驟錯在那?
單純就只是系統不認得而已.....

可能的話,去Intel網站找看看有沒有給Linux的驅動程式;或者,寫信跟Intel技術部門聯繫看看。
哈克不愛的多合一輸入平台----->新香草口味
過去的時間不斷流逝,抹去的眼淚已成追憶;
乾枯的雙手無力阻止,再會了我遠去的曾經。

kenduest

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 3675
    • 檢視個人資料
    • http://kenduest.sayya.org

centos 還沒整合 dmraid 功能,所以 fake raid 安裝過程無法識別到,但是 fedora 目前版本應該沒問題了.

centos 可能還有得等,比方等 rhel6 出來。
I am kenduest - 小州

my website: http://kenduest.sayya.org/

Blue Jacky

  • 憂鬱的高中生
  • ***
  • 文章數: 155
  • 性別: 男
    • 檢視個人資料
問題解決了
上來回饋一下
首先報告解決方式 -- 換主機板

在看過許多貼文後
覺得問題應該出在作業系統對這所謂的偽裝磁碟陣列(Fake RAID)的支援
於是在同仁都下班後
找了一部工作機拆下 -- 主機板 ASUS M4A785D-M Pro
再弄一組320GB的磁碟陣列(RAID 1)來交叉測試
經過這一天一夜的上網搜尋與實機測試
確定是平台的不相容
而這幾乎是INTEL平台的毛病 <-- 無意挑起藍(Intel)綠(AMD)之爭
決定把原先的主機板換掉
也許有人會對這方法不以為然
但基於小弟的立場而言 -- 快速解決資訊問題,以利公司正常運作
而且解決問題所需總成本(包括時間與金錢)亦符合經濟效益

另外補充一下
三月初
部門局部換裝作業系統 Windows 7 x64 企業版
因怕有些軟體"水土不服"
打算用 Windows 7 企業版的 XP Mode 頂著先

幾部採用AMD平台的逾三、四年"老"電腦
(Athlon 64 3000+, GA-M51GM-S2G)
除了加記憶體
幾乎不用改什麼就可直接升級
相較之下
那幾部兩年不到的"新"電腦
(E5300, P5KPL-AM)
幾乎動彈不得
除了記憶體只能換不能加之外
處理器也完全不支援 Windows 7 企業版的 XP Mode
這點提供給在公司當MIS的人員參考
劫後餘生,一切從頭...

eose

  • 活潑的大學生
  • ***
  • 文章數: 499
  • 性別: 男
    • 檢視個人資料
看過這篇嗎?http://blogs.technet.com/b/windows_vpc/archive/2010/03/19/windows-virtual-pc-and-windows-xp-mode-no-longer-require-hav-processors.aspx

Blue Jacky

  • 憂鬱的高中生
  • ***
  • 文章數: 155
  • 性別: 男
    • 檢視個人資料
看過這篇嗎?http://blogs.technet.com/b/windows_vpc/archive/2010/03/19/windows-virtual-pc-and-windows-xp-mode-no-longer-require-hav-processors.aspx

關於 Windows Virtual PC 的部份
在去年三月至五月
微軟的一連串研習課程中已瞭解

個人對I/A並無特別偏好
只是最近幾次公司資訊資產的"活化整理"
發現公司老"MIS"過去一向"不屑"使用AMD平台
在這一連串升級計劃中反而佔上風
特別是幫公司省了不少錢
這結果也是老闆最關心的部份
而這點就是小弟上篇回文補充中所要表達的

謝謝指教
劫後餘生,一切從頭...