作者 主題: CentOS 5.4 安裝Driver的問題  (閱讀 7823 次)

0 會員 與 1 訪客 正在閱讀本文。

AlbertHsu

  • 可愛的小學生
  • *
  • 文章數: 11
    • 檢視個人資料
CentOS 5.4 安裝Driver的問題
« 於: 2010-02-17 04:53 »
小弟用一台舊PC安裝CentOS 5.4來測試, 結果小弟安裝顯示卡驅動程式(Intel 845GE內建顯示卡, 驅動程式為http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-2.10.0.tar.bz2 xf86-video-intel 2.10.0 release)一直無法安裝~

顯示的錯誤訊息是
Requested 'xorg-server >= 1.6' but version of xorg-server is 1.1.1

小弟有點傻眼了, 這是要叫小弟去找xorg-x11-server-sdk-1.6這個套件嗎? 那跟小弟現在的X Window相容嗎?

好像~~~不小心按錯, 發錯版了, 真是抱歉~還刪不掉~還煩請版主幫忙處理一下~
« 上次編輯: 2010-02-17 06:29 由 AlbertHsu »

rainday

  • 鑽研的研究生
  • *****
  • 文章數: 738
  • 性別: 男
  • enhancing and optimizing
    • 檢視個人資料
回覆: CentOS 5.4 安裝Driver的問題
« 回覆 #1 於: 2010-02-18 09:08 »
相依性問題而己
訊息己經說到要你先升級xorg-server(x window)
<0  =_=  Don't learn to hack , hack to learn.

kenduest

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 3675
    • 檢視個人資料
    • http://kenduest.sayya.org
回覆: CentOS 5.4 安裝Driver的問題
« 回覆 #2 於: 2010-02-18 09:21 »

您的 X Window 可以正常進入嗎?

若可以正常進入的話,其實該版本的內建 driver 就已經可以使用了,不需要另外再行安裝。
I am kenduest - 小州

my website: http://kenduest.sayya.org/

AlbertHsu

  • 可愛的小學生
  • *
  • 文章數: 11
    • 檢視個人資料
回覆: CentOS 5.4 安裝Driver的問題
« 回覆 #3 於: 2010-02-19 19:34 »
相依性問題而己
訊息己經說到要你先升級xorg-server(x window)
但是CentOS的yum裡好像只有1.1.1,看來這個版本的驅動程式是沒辦法用的~

AlbertHsu

  • 可愛的小學生
  • *
  • 文章數: 11
    • 檢視個人資料
回覆: CentOS 5.4 安裝Driver的問題
« 回覆 #4 於: 2010-02-19 19:36 »

您的 X Window 可以正常進入嗎?

若可以正常進入的話,其實該版本的內建 driver 就已經可以使用了,不需要另外再行安裝。
是沒錯啦~內建的Driver是可以用~
這個問題是由另外一個問題所引發的,就是顯示只能800x600,不過已經解決了~
那時候就找了Intel官網的Driver,結果就是裝不上去~
不過看起來,CentOS內建的X Window就是不能用Intel官網的Driver了~
除非自己升級X Window

kenduest

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 3675
    • 檢視個人資料
    • http://kenduest.sayya.org
回覆: CentOS 5.4 安裝Driver的問題
« 回覆 #5 於: 2010-02-19 20:30 »

安裝舊一點的版本

http://intellinuxgraphics.org/

裡面可以找到舊版本 tarball
I am kenduest - 小州

my website: http://kenduest.sayya.org/

AlbertHsu

  • 可愛的小學生
  • *
  • 文章數: 11
    • 檢視個人資料
回覆: CentOS 5.4 安裝Driver的問題
« 回覆 #6 於: 2010-02-19 23:38 »

安裝舊一點的版本

http://intellinuxgraphics.org/

裡面可以找到舊版本 tarball
謝謝啦~

HOWY

  • 可愛的小學生
  • *
  • 文章數: 19
    • 檢視個人資料
回覆: CentOS 5.4 安裝Driver的問題
« 回覆 #7 於: 2011-02-17 09:25 »

安裝舊一點的版本

http://intellinuxgraphics.org/

裡面可以找到舊版本 tarball
謝謝啦~
能否請教您用哪個版本的可以解掉這個問題呢? 謝