作者 主題: 求救 !!!~不知道是哪邊出了問題(以解答)  (閱讀 22432 次)

0 會員 與 1 訪客 正在閱讀本文。

fillano

  • 鑽研的研究生
  • *****
  • 文章數: 526
    • 檢視個人資料
回覆: 求救 !!!~不知道是哪邊出了問題
« 回覆 #30 於: 2009-09-15 22:20 »
問一下:

你的 opengoo/config/config.php 裡面的 define('ROOT_URL', 'http://對外ip/opengoo'); 設定對嗎?
 
Sapere aude! Habe Mut, dich deines eigenen Verstandes zu bedienen! ist also der Wahlspruch der Aufklärung.

silenthaha

  • 憂鬱的高中生
  • ***
  • 文章數: 111
    • 檢視個人資料
回覆: 求救 !!!~不知道是哪邊出了問題
« 回覆 #31 於: 2009-09-16 08:52 »
回YA大:
已經照您的測試過了 opengoo裡面有index.php 也照打了 一樣顯示無法顯示網頁


回HO大:
這麼簡單的環境下 我只是單純測試這套件可用性 這樣而已 別想得太難
環境也是那麼簡單 我也想不通 為什麼會這樣 所以上網求救!

micmic3

  • 俺是博士!
  • *****
  • 文章數: 1692
    • 檢視個人資料
回覆: 求救 !!!~不知道是哪邊出了問題
« 回覆 #32 於: 2009-09-16 09:04 »
錯誤畫面是什麼?!

silenthaha

  • 憂鬱的高中生
  • ***
  • 文章數: 111
    • 檢視個人資料
回覆: 求救 !!!~不知道是哪邊出了問題
« 回覆 #33 於: 2009-09-16 09:07 »
找不到網頁"192.168.200.91"
發生DNS錯誤.找不到伺服器.連結已中斷.




以上是發生錯誤的網頁"
感謝各位大大

silenthaha

  • 憂鬱的高中生
  • ***
  • 文章數: 111
    • 檢視個人資料
回覆: 求救 !!!~不知道是哪邊出了問題
« 回覆 #34 於: 2009-09-16 09:14 »
回fillano大

已經照您的方法測試了!!感謝你 成功了=0=.....


以上 感謝各位大大分析!!!!讓小弟 多認識了 這部分~~^_^

micmic3

  • 俺是博士!
  • *****
  • 文章數: 1692
    • 檢視個人資料
回覆: 求救 !!!~不知道是哪邊出了問題
« 回覆 #35 於: 2009-09-16 09:15 »
問一下:

你的 opengoo/config/config.php 裡面的 define('ROOT_URL', 'http://對外ip/opengoo'); 設定對嗎?
 
如果是localhost 裝的應該會錯才是....個人推測

silenthaha

  • 憂鬱的高中生
  • ***
  • 文章數: 111
    • 檢視個人資料
回覆各位
我的opengoo/config/config.php
原本define('ROOT_URL', 'http://localhost/opengoo');  是這樣

今天看了FILLANO改了
define('ROOT_URL', 'http://192.168.200.91/opengoo'); 

我今天就從另外一台(192.168.200.90)連 就連進來了!!!!

兩台主機 不是VM  區網內測試!!!!
感謝各位 問題已經解決 謝謝!!!!

fillano

  • 鑽研的研究生
  • *****
  • 文章數: 526
    • 檢視個人資料
回覆: 求救 !!!~不知道是哪邊出了問題
« 回覆 #37 於: 2009-09-16 09:20 »
我測試了一下,ROOT_URL會用這樣的規則:

1. 如果是完整網址(前面有http://),他會用這個網址來取代你輸入的網址,後面再加上index.php等等
2. 如果是相對網址,他會用你輸入的hostname+ROOT_URL來取代網址,後面再加上index.php等等

所以依照你的環境,你正確的設定應該是 define('ROOT_URL', '/opengoo');
Sapere aude! Habe Mut, dich deines eigenen Verstandes zu bedienen! ist also der Wahlspruch der Aufklärung.

micmic3

  • 俺是博士!
  • *****
  • 文章數: 1692
    • 檢視個人資料
因為安裝時是打 localhost/opengoo 的關係吧
如果安裝時是'http://192.168.200.91/opengoo' 就不會有問題了

silenthaha

  • 憂鬱的高中生
  • ***
  • 文章數: 111
    • 檢視個人資料
回MICMIC3
安裝 opengoo
他沒有那方面可以打
安裝過程我已經安裝不下10次
他沒有可以選擇或改的設定

fillano

  • 鑽研的研究生
  • *****
  • 文章數: 526
    • 檢視個人資料
嗯嗯...其實有,我也是看到這個所以才問你的。

http://wiki.opengoo.org/doku.php/installer

請看step 3裡面的other settings有一個東西叫做Absolute script URL... 他會自動帶出,但是你用localhost安裝時,自動帶出的應該不是你要的。
Sapere aude! Habe Mut, dich deines eigenen Verstandes zu bedienen! ist also der Wahlspruch der Aufklärung.

silenthaha

  • 憂鬱的高中生
  • ***
  • 文章數: 111
    • 檢視個人資料
對   有    =.=我以為那邊設定按照原設定就可以了ˊˋ 抱歉了

Yamaka

  • 俺是博士!
  • *****
  • 文章數: 4913
    • 檢視個人資料
    • http://www.ecmagic.com
回覆: 求救 !!!~不知道是哪邊出了問題
« 回覆 #42 於: 2009-09-16 09:54 »
本機192.168.200.93

我打192.168.200.90/opengoo 無法進入我的opengo

你主機 IP 到底是什麼?

應該是IP打錯的關係吧, 之前我還在想會不會是管理介面那邊有設定只能本機登入  :D :D

我一開始就是這樣懷疑啊~
只是我沒安裝過 opengoo
不知道它有哪些設定的資料  :D

silenthaha

  • 憂鬱的高中生
  • ***
  • 文章數: 111
    • 檢視個人資料
ˊˋ抱歉    以後我會多注意的>_<