作者 主題: 3524的1個port亮orange燈,有辦法修嗎?  (閱讀 7667 次)

0 會員 與 1 訪客 正在閱讀本文。

treble

  • 活潑的大學生
  • ***
  • 文章數: 215
    • 檢視個人資料
    • 牛的大腦
3524的1個port亮orange燈,有辦法修嗎?
« 於: 2009-05-04 16:37 »
各位大大好
這台cisco 3524的23port插線會亮orange燈,但其他port都是綠燈
另外,只要是經過此port的設備都ping不到,但換一個port就OK
以下是關於此port的狀態
show interfaces fa0/23 status
Port    Name               Status       Vlan     Duplex Speed   Type
------- ------------------ ------------ -------- ------ ------- ----
Fa0/23                     connected    200      A-Full   A-100 100BaseTX/FX

show interfaces fa0/23
FastEthernet0/23 is up, line protocol is up
  Hardware is Fast Ethernet, address is 0007.502f.78d7 (bia 0007.502f.78d7)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive not set
  Auto-duplex (Full), Auto Speed (100), 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     6345650 packets input, 3556343081 bytes
     Received 1209553 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 834770 multicast
     0 input packets with dribble condition detected
     16590356 packets output, 3091068047 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

其中比較令我不解的是這一行
  Last input never, output 00:00:01, output hang never
其他port都不會never,想請問各位高手這要如何解決
感謝
[牛的大腦  http://systw.net ] 用來放一些筆記資料
[單字我朋友  http://systw.net/word ] 練英文用的
2分鐘檢測你的單字能力 http://systw.net/word/q.php

sitediy

  • 活潑的大學生
  • ***
  • 文章數: 426
    • 檢視個人資料
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #1 於: 2009-05-04 17:02 »
有開STP嗎??  是否發生loop??

anderson1127

  • 訪客
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #2 於: 2009-05-04 17:09 »
把設定檔show 出來看看裡面的config , 會跑橘燈記得大多是跑一些L2 protocol或者速率的問題(被強制跑10M之類的)

所以,把show run 的設定拿出來看看吧!!

treble

  • 活潑的大學生
  • ***
  • 文章數: 215
    • 檢視個人資料
    • 牛的大腦
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #3 於: 2009-05-05 14:16 »
感謝大大幫忙,show run的資訊如下

Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname A_Build_1F_3524_32
!
enable password 7 xxxxxxxxxxxx
!
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
 switchport access vlan 131
!
interface FastEthernet0/2
 switchport access vlan 131
!
interface FastEthernet0/3
 switchport access vlan 131
!
interface FastEthernet0/4
 switchport access vlan 131
!
interface FastEthernet0/5
 switchport access vlan 131
!
interface FastEthernet0/6
 switchport access vlan 132
!
interface FastEthernet0/7
 switchport access vlan 132
!
interface FastEthernet0/8
 switchport access vlan 200
!
interface FastEthernet0/9
 switchport access vlan 131
!
interface FastEthernet0/10
 switchport access vlan 200
!
interface FastEthernet0/11
 switchport access vlan 132
!
interface FastEthernet0/12
 switchport access vlan 200
!
interface FastEthernet0/13
 switchport access vlan 200
!
interface FastEthernet0/14
 switchport access vlan 200
!
interface FastEthernet0/15
 switchport access vlan 200
!
interface FastEthernet0/16
 switchport access vlan 200
!
interface FastEthernet0/17
 switchport access vlan 200
!
interface FastEthernet0/18
 switchport access vlan 200
!
interface FastEthernet0/19
 switchport access vlan 200
!
interface FastEthernet0/20
 switchport access vlan 200
!
interface FastEthernet0/21
 switchport access vlan 200
!
interface FastEthernet0/22
 switchport access vlan 200
!
interface FastEthernet0/23
 switchport access vlan 200
!
interface FastEthernet0/24
 switchport access vlan 200
!
interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/2
!
interface VLAN1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN200
 no ip directed-broadcast
 no ip route-cache
 shutdown
!
interface VLAN254
 ip address 10.254.254.32 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.254.254.254
no ip http server
snmp-server engineID local xxxxxxxxxxxx
snmp-server community xxxxxxxxxxxx RO
!
line con 0
 password 7 xxxxxxxxxxxx
 transport input none
 stopbits 1
line vty 0 4
 password 7 xxxxxxxxxxxx
 login
line vty 5 15
 password 7 xxxxxxxxxxxx
 login
!
end
[牛的大腦  http://systw.net ] 用來放一些筆記資料
[單字我朋友  http://systw.net/word ] 練英文用的
2分鐘檢測你的單字能力 http://systw.net/word/q.php

sitediy

  • 活潑的大學生
  • ***
  • 文章數: 426
    • 檢視個人資料
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #4 於: 2009-05-05 15:38 »

interface VLAN200
 no ip directed-broadcast
 no ip route-cache
 shutdown

把你的fa0/23 shut之後再no shut試試

treble

  • 活潑的大學生
  • ***
  • 文章數: 215
    • 檢視個人資料
    • 牛的大腦
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #5 於: 2009-05-05 16:12 »
有shutdown在no shutdown,但還是一樣不行@@
感謝
[牛的大腦  http://systw.net ] 用來放一些筆記資料
[單字我朋友  http://systw.net/word ] 練英文用的
2分鐘檢測你的單字能力 http://systw.net/word/q.php

treble

  • 活潑的大學生
  • ***
  • 文章數: 215
    • 檢視個人資料
    • 牛的大腦
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #6 於: 2009-05-05 16:22 »
有開STP嗎??  是否發生loop??

這個port只有連接到一台ap,因此不會發生loop

......................

關於stp部份,以下是stp的相關結果

#show spanning-tree summary
UplinkFast is disabled
PortFast BPDU Guard is disabled
Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                1        0         0        1          2
VLAN31               0        0         0        1          1
VLAN32               0        0         0        1          1
VLAN33               0        0         0        1          1
VLAN34               0        0         0        1          1
VLAN35               0        0         0        1          1
VLAN131              0        0         0        7          7
VLAN132              0        0         0        4          4
VLAN200              2        0         0        14         16
VLAN254              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
            10 VLANs 3        0         0        32         35

......................

show spanning-tree brief的vlan200部份(因為此port是在vlan200)
VLAN200
  Spanning tree enabled protocol IEEE
  ROOT ID    Priority 32768
             Address 0006.53e0.e383
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
  Bridge ID  Priority    32768
             Address     0007.502f.78c8
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
Port                           Designated
Name    Port ID Prio Cost Sts  Cost  Bridge ID      Port ID
------- ------- ---- ---- ---  ----  -------------- -------
Fa0/8   128.20  128  19   FWD  8     0007.502f.78c8 128.20
Fa0/10  128.23  128  19   BLK  8     0007.502f.78c8 128.23
Fa0/12  128.25  128  19   FWD  8     0007.502f.78c8 128.25
Fa0/13  128.26  128  19   FWD  8     0007.502f.78c8 128.26
Fa0/14  128.27  128  19   FWD  8     0007.502f.78c8 128.27
Fa0/15  128.28  128  19   FWD  8     0007.502f.78c8 128.28
Fa0/16  128.29  128  19   FWD  8     0007.502f.78c8 128.29
Fa0/17  128.31  128  19   FWD  8     0007.502f.78c8 128.31
Fa0/18  128.32  128  19   FWD  8     0007.502f.78c8 128.32
Fa0/19  128.33  128  19   FWD  8     0007.502f.78c8 128.33
Port                           Designated
Name    Port ID Prio Cost Sts  Cost  Bridge ID      Port ID
------- ------- ---- ---- ---  ----  -------------- -------
Fa0/20  128.34  128  19   FWD  8     0007.502f.78c8 128.34
Fa0/21  128.35  128  19   FWD  8     0007.502f.78c8 128.35
Fa0/22  128.36  128  19   FWD  8     0007.502f.78c8 128.36
Fa0/23  128.37  128  19   FWD  8     0007.502f.78c8 128.37
Fa0/24  128.38  128  19   BLK  8     0007.502f.78c8 128.38
Gi0/1   128.40  128  4    FWD  4     001b.0d65.48c8 129.134

......................

#show spanning-tree interface fastEthernet 0/23
Interface Fa0/23 (port 37) in Spanning tree 200 is FORWARDING
   Port path cost 19, Port priority 128
   Designated root has priority 32768, address 0006.53e0.e383
   Designated bridge has priority 32768, address 0007.502f.78c8
   Designated port is 37, path cost 8
   Timers: message age 0, forward delay 0, hold 0
   BPDU: sent 675595, received 0

......................

show spanning-tree

Spanning tree 1 is executing the IEEE compatible Spanning Tree protocol
  Bridge Identifier has priority 32768, address 0007.502f.78c0
  Configured hello time 2, max age 20, forward delay 15
  Current root has priority 32768, address 0006.53e0.e380
  Root port is 40, cost of root path is 8
  Topology change flag not set, detected flag not set, changes 152
  Times:  hold 1, topology change 35, notification 2
          hello 2, max age 20, forward delay 15
  Timers: hello 0, topology change 0, notification 0

Interface Gi0/1 (port 40) in Spanning tree 1 is FORWARDING
   Port path cost 4, Port priority 128
   Designated root has priority 32768, address 0006.53e0.e380
   Designated bridge has priority 32768, address 001b.0d65.4801
   Designated port is 134, path cost 4
   Timers: message age 2, forward delay 0, hold 0
   BPDU: sent 546, received 17465138

Interface Gi0/2 (port 48) in Spanning tree 1 is down
   Port path cost 4, Port priority 128
   Designated root has priority 32768, address 0006.53e0.e380
   Designated bridge has priority 32768, address 0007.502f.78c0
   Designated port is 48, path cost 8
   Timers: message age 0, forward delay 0, hold 0
   BPDU: sent 1, received 0

[牛的大腦  http://systw.net ] 用來放一些筆記資料
[單字我朋友  http://systw.net/word ] 練英文用的
2分鐘檢測你的單字能力 http://systw.net/word/q.php

anderson1127

  • 訪客
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #7 於: 2009-05-06 10:58 »
請樓主準備一台NB及一條UTP 網路線...

故障port不要接AP , 把NB接上去做測試 , 也不要延用舊的UTP線
請改用自己準備的UTP線(此線必需在其它的PC是正常可用的)

然後觀察燈號來做測試!!

一般來說,Cisco switch default 是把STP給enable , 除非你下port fast command
才不會有STP Negotiation動作(亦即橘燈閃爍) , 以上這兩個方式都試看看吧!!

treble

  • 活潑的大學生
  • ***
  • 文章數: 215
    • 檢視個人資料
    • 牛的大腦
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #8 於: 2009-05-07 16:46 »
請樓主準備一台NB及一條UTP 網路線...

故障port不要接AP , 把NB接上去做測試 , 也不要延用舊的UTP線
請改用自己準備的UTP線(此線必需在其它的PC是正常可用的)

然後觀察燈號來做測試!!

一般來說,Cisco switch default 是把STP給enable , 除非你下port fast command
才不會有STP Negotiation動作(亦即橘燈閃爍) , 以上這兩個方式都試看看吧!!

感謝大大的建議
我準備好筆電及網路線以及console線,到了現場我將筆電連到fa0/23,以及console
筆電顯示連線正
switch fa0/23依然亮橘橙(不會閃爍,和之前接ap情況一樣)
接著筆電ping同網段設備,沒回應(正常情況下接其他port是有回應的)
接著透過console進入switch內看組態是否有什麼變化
但和接ap時的情況一樣,看似都正常,但確不通@@

[牛的大腦  http://systw.net ] 用來放一些筆記資料
[單字我朋友  http://systw.net/word ] 練英文用的
2分鐘檢測你的單字能力 http://systw.net/word/q.php

anderson1127

  • 訪客
回覆: 3524的1個port亮orange燈,有辦法修嗎?
« 回覆 #9 於: 2009-05-08 07:10 »
看起來有點不樂觀了...

最後試看看 port fast 指令吧...強制把STP function 給Disable
真的不行的話就真的掛點了!! 還好啦,只壞一個port ....