作者 主題: Fedora 10網卡突然不見了  (閱讀 7759 次)

0 會員 與 1 訪客 正在閱讀本文。

lions4917

  • 懷疑的國中生
  • **
  • 文章數: 33
    • 檢視個人資料
Fedora 10網卡突然不見了
« 於: 2009-02-06 01:46 »
各位大大安..
昨天小弟我正用pidgin 說到一半時.
突然就連線失敗...接者網路也不通了..
我想X window又呆住了吧..就重新開機..
發現啟動時有關網卡的都出錯..
登入後用ifup eth0 也說 "裝置eth0不存在,延遲初始化..."
我交叉測試了 (小弟用VM) Fedora 9 發現都正常..VM也重設重開了多次
有可能被駭去改了我什麼嗎...?
(小弟是初學者只懂的以下檢查)
1. lspci 有看到AMD網卡 (VMware模擬的)
2./etc/sysconfig/network-scrips/ifcfg-eth0 有此設定檔 , onboot=yes
3.用ntsysv 有啟動 network (開機時應該會啟動網卡吧)




感激不盡!   :'(

-------------------------------------------------

剛剛下指令才發現都沒有任何模組被載入
lsmod
cat /proc/modules
可是為什麼只有網路出問題...我現在連X Window 任何工具都挺正常的
另外 dmesg | grep eth0 也沒有找到任何東西 (Linux不認識該硬體?)
可是明明用了快一個月了.且lspci也看到的哩!!
« 上次編輯: 2009-02-06 15:44 由 lions4917 »

Yamaka

  • 俺是博士!
  • *****
  • 文章數: 4913
    • 檢視個人資料
    • http://www.ecmagic.com
回覆: Fedora 10網卡突然不見了
« 回覆 #1 於: 2009-02-06 12:27 »
簡單的方式..

啟動開機時硬體自動偵測, 移除舊的虛擬網卡, 設定另一個新的虛擬網卡, 讓系統幫你自動處理..

lions4917

  • 懷疑的國中生
  • **
  • 文章數: 33
    • 檢視個人資料
回覆: Fedora 10網卡突然不見了
« 回覆 #2 於: 2009-02-06 15:33 »
請問大大...
Linux開機要如何自動偵測硬體呢..
謝謝....

Yamaka

  • 俺是博士!
  • *****
  • 文章數: 4913
    • 檢視個人資料
    • http://www.ecmagic.com
回覆: Fedora 10網卡突然不見了
« 回覆 #3 於: 2009-02-06 16:43 »
在 centos 是 kudzu, Fedora 10 應該也有這東西
(fc6 之後就沒再玩 fedora  :D :D)

lions4917

  • 懷疑的國中生
  • **
  • 文章數: 33
    • 檢視個人資料
回覆: Fedora 10網卡突然不見了
« 回覆 #4 於: 2009-02-07 11:28 »
那我現在要怎麼辦呢...
如何載入模組....是可以從另外的Linux拷貝哪個設定檔來先頂一下嗎
我想那些模組應該沒被砍掉

P.S 駭客有可能改掉什麼..讓我模組都沒載入嗎 (lsmod沒有東西)
     但我現在一個模組都沒有...其它功能卻也都正常 (只有網卡掛了,CDROM和顯示和X window都好的)

sleepywei

  • 可愛的小學生
  • *
  • 文章數: 3
    • 檢視個人資料
回覆: Fedora 10網卡突然不見了
« 回覆 #5 於: 2009-02-08 21:40 »
應該不是被駭
你可以先 check - Fedora-10 network configuration (GUI Tool)
(1) DSL 部份
(2) network (eth0)

如還不行-試著手動調整, 不然就改用 Ubuntu 8.10

(個人覺得 Ubuntu 8.10 -比Fedora 10 穩定﹐又好用)

lions4917

  • 懷疑的國中生
  • **
  • 文章數: 33
    • 檢視個人資料
回覆: Fedora 10網卡突然不見了
« 回覆 #6 於: 2009-02-09 21:51 »
設定值都沒問題..
是啟動網卡時 Fedora 說無此網卡
在lspci可看到硬體..
lsmod卻沒有相關模組載入..而看不到網卡
要怎麼載入網卡模組...

towns

  • 可愛的小學生
  • *
  • 文章數: 28
    • 檢視個人資料
    • http://hc.twcic.net
回覆: Fedora 10網卡突然不見了
« 回覆 #7 於: 2009-03-05 15:01 »
你應該是有重新掛載過Fedora 10這個虛擬磁碟
看一下是否有看到這些訊息
1.看開機流程時抓到的硬體(使用dmesg)是否有出現這一段訊息
  udev: renamed network interface eth0 to eth1
2.查看/proc/net/dev,抓到的網路卡是eth*
有上面的訊息出現,表示你有換過網卡(你將Fedora 10這個虛擬磁碟掛到其他VM主機上面,也等於是換了網卡)

處理方式:
手動將/etc/udev/rules.d/70-persistent-et.rules這個檔案刪除,重新啟動Fedora 10後,他就會重抓網卡了
相關資料:
http://itgroup.blueshop.com.tw/towns/hc?n=convew&i=6000

Yamaka

  • 俺是博士!
  • *****
  • 文章數: 4913
    • 檢視個人資料
    • http://www.ecmagic.com
回覆: Fedora 10網卡突然不見了
« 回覆 #8 於: 2009-03-05 15:20 »
(個人覺得 Ubuntu 8.10 -比Fedora 10 穩定﹐又好用)

Ubuntu 8.10 這東西我裝了之後一堆問題 = =
光是我常用到的 gimp 就很怪, 視窗不能縮小 orz
然後是它的 grub 無法啟動 xp  >:(
是否還有其他問題我就沒時間測了
裝好之後就沒再去用 XDDD