作者 主題: 求助 : Fatal : kermal too old, 要如何救回來 ?  (閱讀 1967 次)

0 會員 與 1 訪客 正在閱讀本文。

feijer

  • 可愛的小學生
  • *
  • 文章數: 2
    • 檢視個人資料
小弟為了安裝 php5
但要先裝  libxml2
但是版本又太舊
要裝新版前又說我的 glibc 版本也太舊

小弟只好裝新的 glibc
但是一直卡在說 glibc , glibc-devel 和 glibc-common 互相簽制的情況

所以小弟只好下了 rpm -ivh glibc-x.xxx.rpm --nodeps --force

結果就一直出現 Fatal : kernal too old
重開機也一樣

請問這要如何救回來 ?

謝謝

pippeng

  • 活潑的大學生
  • ***
  • 文章數: 329
  • 性別: 男
    • 檢視個人資料
    • IT Ranger
現在Linux的rpm防呆都做的很好了
所以請不要亂用--nodeps --force

請愛用 yum

我上次也愈過類似情形

把所有亂安裝的rpm移除就好了
用心用心再用心

feijer

  • 可愛的小學生
  • *
  • 文章數: 2
    • 檢視個人資料

感謝你提供一個方向給我,

我目前機器 reboot 後還是一樣, 已無法做 任何 rpm 移除動作
任一命令都會出現 FATAL : kernal too old

請問這樣的情況下, 我要如何來作 rpm 移除 ?

謝謝

Yamaka

  • 俺是博士!
  • *****
  • 文章數: 4913
    • 檢視個人資料
    • http://www.ecmagic.com
小弟為了安裝 php5
但要先裝  libxml2
但是版本又太舊
要裝新版前又說我的 glibc 版本也太舊

小弟只好裝新的 glibc
但是一直卡在說 glibc , glibc-devel 和 glibc-common 互相簽制的情況

所以小弟只好下了 rpm -ivh glibc-x.xxx.rpm --nodeps --force

結果就一直出現 Fatal : kernal too old
重開機也一樣

請問這要如何救回來 ?

謝謝

套件間的關聯性越來越複雜, 如果想要在較舊的環境安裝較新的套件

建議還是抓 tarball 回來自己編吧, 以免弄到後來, 連系統都開機不了了  :D