作者 主題: TCP/IP的怪現象 (解決了)  (閱讀 8855 次)

0 會員 與 1 訪客 正在閱讀本文。

adpp

  • 可愛的小學生
  • *
  • 文章數: 17
    • 檢視個人資料
TCP/IP的怪現象 (解決了)
« 於: 2008-08-12 11:01 »
最近遇到一個怪現象,提出來跟大家討論,不知道各位大大有沒有遇過,?

在TCP/IP自訂靜態IP為192.168.1.25並關閉,但重新再開啟TCP/IP介面
發現裡面是空的(直接跳到自動取得IP位址),所以怎麼設定都是空的。
但是在ipconfig /all,看到的是有資訊的(dhcp enable 為no)

以下是我嘗試的方式依然無效~~
1、把DHCP Client service disable
2、移除原有網卡資訊並重新下載網卡driver(針對晶片原廠下載)
3、網卡停用/啟用/重新開機

不知各位有沒有另外的方式可以試試的?感謝指教
« 上次編輯: 2008-08-14 21:14 由 adpp »

蜜蜂

  • 活潑的大學生
  • ***
  • 文章數: 276
  • 性別: 男
    • 檢視個人資料
回覆: TCP/IP的怪現象
« 回覆 #1 於: 2008-08-12 14:05 »
OS 是 Windows XP SP3 嗎 ?


adpp

  • 可愛的小學生
  • *
  • 文章數: 17
    • 檢視個人資料
回覆: TCP/IP的怪現象
« 回覆 #2 於: 2008-08-12 14:11 »
回蜜蜂~~
環境是
OS:WINDOWS 2003 R2 STD

longlife

  • 活潑的大學生
  • ***
  • 文章數: 476
    • 檢視個人資料
    • Arch
回覆: TCP/IP的怪現象
« 回覆 #3 於: 2008-08-12 15:06 »
試試:
移除 tcp/ip 通訊協定 > 重開機 > 再安裝 tcp/ip 通訊協定
個人空間 - 部落格、相冊、書籤
論壇 - 商品、懸賞、活動、辯論

adpp

  • 可愛的小學生
  • *
  • 文章數: 17
    • 檢視個人資料
回覆: TCP/IP的怪現象
« 回覆 #4 於: 2008-08-12 15:17 »
試試:
移除 tcp/ip 通訊協定 > 重開機 > 再安裝 tcp/ip 通訊協定


本來我也有想到,不過~~~~
tcp/ip預設值是不能移除的,是否有特別的移除方式?

longlife

  • 活潑的大學生
  • ***
  • 文章數: 476
    • 檢視個人資料
    • Arch
回覆: TCP/IP的怪現象
« 回覆 #5 於: 2008-08-12 16:40 »
以前曾替客戶處理類似的問題,無法自定 ip,判斷是 tcp/ip 有問題了,
於是就採取跟您提過的處理方式,也成功解決了問題,但那時是 Win98 系統。
個人空間 - 部落格、相冊、書籤
論壇 - 商品、懸賞、活動、辯論

darkranger

  • 榮譽學長
  • 俺是博士!
  • *****
  • 文章數: 1370
    • 檢視個人資料
    • http://darkranger.no-ip.org
回覆: TCP/IP的怪現象
« 回覆 #6 於: 2008-08-12 20:45 »

JOJO10

  • 活潑的大學生
  • ***
  • 文章數: 337
    • 檢視個人資料
    • 打破傳統
回覆: TCP/IP的怪現象
« 回覆 #7 於: 2008-08-13 01:08 »
你那問題跟DHCP沒關係
網卡壞掉!!!!!!!!!!!!!!!!!!!

adpp

  • 可愛的小學生
  • *
  • 文章數: 17
    • 檢視個人資料
回覆: TCP/IP的怪現象
« 回覆 #8 於: 2008-08-13 09:47 »
你那問題跟DHCP沒關係
網卡壞掉!!!!!!!!!!!!!!!!!!!

是的!現在問題是跟DHCP沒關係,至於網卡有可能是壞掉,
但目前我懷疑的是DRIVER有衝到或是系統本身的問題(重灌後才出現該問題),
因為自訂IP後在IPCONFIG查看資訊都正常也都能上網,只是在TCP/IP顯示看不到(所以才說是怪現象)

另外,使用netsh指令來重置TCP/IP,輸入netsh int ip reset c:\resetlog.txt ,重新自訂IP仍然無效

aarongaw

  • 懷疑的國中生
  • **
  • 文章數: 59
    • 檢視個人資料
回覆: TCP/IP的怪現象
« 回覆 #9 於: 2008-08-13 11:20 »
TCP/ IP
是可以重新安裝的, 請看
http://support.microsoft.com/kb/325356/zh-tw


JOJO10

  • 活潑的大學生
  • ***
  • 文章數: 337
    • 檢視個人資料
    • 打破傳統
回覆: TCP/IP的怪現象
« 回覆 #10 於: 2008-08-13 20:56 »
你的網路都顯示
ip address...........................................--     --    --  ---
subnet mask........................................--     --    --  ---
default getway....................................--     --    --  ---

adpp

  • 可愛的小學生
  • *
  • 文章數: 17
    • 檢視個人資料
回覆: TCP/IP的怪現象
« 回覆 #11 於: 2008-08-14 21:06 »
感謝各位的協助!
現在問題已經決解了唷…我的做法是…
1、手動移除原有網卡driver
2、使用netsh指令來重置TCP/IP,輸入netsh int ip reset c:\resetlog.txt
3、重新再載入原廠網卡driver
4、重新啟動,自訂IP OK!!

P.S.關於移除TCP/IP,由於風儉過大(使用Virtual 測試後出現藍底白字 @@),
故還是採用比較安全的作法。

learning

  • 可愛的小學生
  • *
  • 文章數: 26
    • 檢視個人資料
回覆: TCP/IP的怪現象 (解決了)
« 回覆 #12 於: 2008-09-17 16:36 »
感覺跟這個有關係
更新了Download the 948496 package now.此KB948496,理論上該三個Key,TCP Chimney、RSS、TCPA,應該已經Disable,但是,現在感覺似乎沒有,建議比較接近網路莫名的斷線與死當問題。建議此更新重裝,或是手動進入變更三個設定值為Disable
(http://support.microsoft.com/kb/948496)
« 上次編輯: 2008-09-17 16:39 由 learning »