作者 主題: 使用SQUID的問題  (閱讀 3095 次)

0 會員 與 1 訪客 正在閱讀本文。

aven

  • 可愛的小學生
  • *
  • 文章數: 15
    • 檢視個人資料
使用SQUID的問題
« 於: 2008-06-03 16:43 »
OS: CentOS 5.1
squid: squid-2.6-STABLE6-5.el5_1.3

在CentOS 5.1上裝squid, 裝好後,USER 端上網都沒什麼問題.
但是連公開資訊觀測站時會有問題.
公開資訊觀測站網站: http://sii.tse.com.tw

USER上公開資訊觀測站時, 會顯示首頁,
但是點選右邊佈告欄裡的連結時,都連不上, 錯誤訊息如下:
查了很久,查不出是什麼問題,  請各位先進給點意見,謝謝.

The requested URL could not be retrieved
 
While trying to retrieve the URL: http://sii.tse.com.tw/qanda2.htm
The following error was encountered:
Unable to determine IP address from host name for sii.tse.com.tw
The dnsserver returned:
Timeout
This means that:
 The cache was not able to resolve the hostname presented in the URL.
 Check if the address is correct.
Your cache administrator is root.

 
Generated Tue, 03 Jun 2008 07:27:13 GMT by proxy (squid/2.6.STABLE6)



yoww

  • 活潑的大學生
  • ***
  • 文章數: 431
    • 檢視個人資料
    • 唉呦~MIS先生
回覆: 使用SQUID的問題
« 回覆 #1 於: 2008-06-03 16:46 »
是設成transparent模式嗎?
唉呦~MIS先生 http://i-yow.blogspot.com/
寶貝的天空      http://3-baby.blogspot.com/

aven

  • 可愛的小學生
  • *
  • 文章數: 15
    • 檢視個人資料
回覆: 使用SQUID的問題
« 回覆 #2 於: 2008-06-03 16:53 »
不是設成 transparent模式,
squid.conf內容如下:

http_port 3128
cache_dir ufs /cache1 2000 16 256
cache_dir ufs /cache2 2000 16 256
visible_hostname proxy

cache_access_log /var/log/squid/access.log
cache_store_log none

cache_mem 64 MB
cache_swap_low 90
cache_swap_high 95
auth_param basic casesensitive off

acl all src 0.0.0.0/0.0.0.0
acl manager proto cache_object
acl localhost src 127.0.0.1/255.255.255.255
acl to_localhost dst 127.0.0.0/8
acl SSL_ports port 443 563 2443 6818
acl Safe_ports port 80      # http
acl Safe_ports port 21      # ftp
acl Safe_ports port 443 563 2443 6818   # https, snews
acl Safe_ports port 70      # gopher
acl Safe_ports port 210      # wais
acl Safe_ports port 1025-65535   # unregistered ports
acl Safe_ports port 280      # http-mgmt
acl Safe_ports port 488      # gss-http
acl Safe_ports port 591      # filemaker
acl Safe_ports port 777      # multiling http
acl CONNECT method CONNECT

http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports

acl allowhost src "/etc/squid/squid.allow.hosts"
acl downloadhost src "/etc/squid/squid.download.hosts"

acl mmxfile urlpath_regex -i \.mp3$ \.avi$ \.wav$ \.wmv$ \.rm$ \.asf$ \.mpg$ \.mpeg$ \.cda$ \.qt$ \.ra$
acl exefile urlpath_regex -i \.exe$ \.msi$
acl dangerousfile urlpath_regex -i \.bin$ \.pif$ \.vb?$ \.scr$ \.bat$ \.cpl$ \.bat$ \.cmd$
acl zipfile urlpath_regex -i \.rar$ \.cab$ \.zip$

acl special_url url_regex "/etc/squid/squid-block.acl"

http_access deny special_url
http_access deny dangerousfile
http_access deny mmxfile
http_access allow downloadhost
http_access deny exefile
http_access deny zipfile
http_access allow localhost
http_access allow allowhost
http_access deny all

yoww

  • 活潑的大學生
  • ***
  • 文章數: 431
    • 檢視個人資料
    • 唉呦~MIS先生
回覆: 使用SQUID的問題
« 回覆 #3 於: 2008-06-03 18:37 »
試過直接用IP連嗎?
http://203.74.228.20/ 或http://219.80.48.20/

唉呦~MIS先生 http://i-yow.blogspot.com/
寶貝的天空      http://3-baby.blogspot.com/

aven

  • 可愛的小學生
  • *
  • 文章數: 15
    • 檢視個人資料
回覆: 使用SQUID的問題
« 回覆 #4 於: 2008-06-05 11:32 »
問題解決了, 是DNS的問題, 謝謝大家.