作者 主題: 請問各位大大關於adsl-start的問題  (閱讀 6534 次)

0 會員 與 1 訪客 正在閱讀本文。

cindy751218

  • 可愛的小學生
  • *
  • 文章數: 5
    • 檢視個人資料
請問各位大大關於adsl-start的問題
« 於: 2008-05-12 18:27 »
我是用ALDSL撥接上網的
我打adsl-start的時候會出現line 214: 3530  Terminated         $CONNET"$@">/dev/null 2>&1
請問要怎麼改,它才可以連上線
它現在連IP也抓不到

darkranger

  • 榮譽學長
  • 俺是博士!
  • *****
  • 文章數: 1373
    • 檢視個人資料
    • http://darkranger.no-ip.org
回覆: 請問各位大大關於adsl-start的問題
« 回覆 #1 於: 2008-05-12 18:42 »
1.
請確認 adsl-setup 設定內容正確
2.
請說明系統版本
3.
網路卡(eth)型號與設定
4.
貼一下 /var/log/messages 中的內容

cindy751218

  • 可愛的小學生
  • *
  • 文章數: 5
    • 檢視個人資料
回覆: 請問各位大大關於adsl-start的問題
« 回覆 #2 於: 2008-05-13 22:20 »
我的adsl-setup我有設定正確
可是我打ifconfig ppp0 卻找不到裝置
我的系統是Fedora 6
我的網卡是Realtek RTL8139/810x Family Fast Ethernet NIC
是有抓到我的網卡,可是卻找不到ip,也無法按啟用
« 上次編輯: 2008-05-13 22:22 由 cindy751218 »

darkranger

  • 榮譽學長
  • 俺是博士!
  • *****
  • 文章數: 1373
    • 檢視個人資料
    • http://darkranger.no-ip.org
回覆: 請問各位大大關於adsl-start的問題
« 回覆 #3 於: 2008-05-15 01:08 »
我的adsl-setup我有設定正確
可是我打ifconfig ppp0 卻找不到裝置
ADSL 沒成功連線,ppp0 是不會存在的
我的系統是Fedora 6
我的網卡是Realtek RTL8139/810x Family Fast Ethernet NIC
是有抓到我的網卡,可是卻找不到ip,也無法按啟用
這邊看不太懂你的意思
請貼一下 /etc/sysconfig/network-scripts/ifcfg-eth0 的設定內容

cindy751218

  • 可愛的小學生
  • *
  • 文章數: 5
    • 檢視個人資料
回覆: 請問各位大大關於adsl-start的問題
« 回覆 #4 於: 2008-05-15 19:17 »
我的ifcfg-eth0內容如下:
# Please read /usr/share/doc/initscripts-*/sysconfig.txt
# for the documentation of these parameters.
TYPE=Ethernet
DEVICE=eth0
HWADDR=00:11:2f:d3:3e:c9
BOOTPROTO=dhcp
ONBOOT=yes
USERCTL=no
IPV6INIT=no
PEERDNS=yes       

darkranger

  • 榮譽學長
  • 俺是博士!
  • *****
  • 文章數: 1373
    • 檢視個人資料
    • http://darkranger.no-ip.org

cindy751218

  • 可愛的小學生
  • *
  • 文章數: 5
    • 檢視個人資料
回覆: 請問各位大大關於adsl-start的問題
« 回覆 #6 於: 2008-06-02 19:09 »
大大~我將我的系統換成Fedora 8的
我有安裝rp-pppoe -3.8-1.fc7
可是我要用adsl-setup時,卻不行...
這是為什麼?

darkranger

  • 榮譽學長
  • 俺是博士!
  • *****
  • 文章數: 1373
    • 檢視個人資料
    • http://darkranger.no-ip.org
回覆: 請問各位大大關於adsl-start的問題
« 回覆 #7 於: 2008-06-02 20:42 »
大大~我將我的系統換成Fedora 8的
我有安裝rp-pppoe -3.8-1.fc7
可是我要用adsl-setup時,卻不行...
這是為什麼?
不行.....什麼???
是怎麼個不行法?

dark

  • 俺是博士!
  • *****
  • 文章數: 1581
    • 檢視個人資料
回覆: 請問各位大大關於adsl-start的問題
« 回覆 #8 於: 2008-06-03 00:28 »
可到 etc 下把 pppeo.conf 找出來
adsl-start 參數就帶他

至於編輯 pppeo.conf ...
# 開頭的不看
回想 adsl-setup 問的問題
看的懂的填,看不懂的留預設或空字串

帳號對應密碼的檔案是 ppp/pap-????

... 通常這樣就連上去了
因為以前試過不少版本 rp-pppoe
發現不能用的版本大多都是 adsl-setup 這個有問題