作者 主題: mount 新硬碟後,重開機,所有檔案都變成read-only  (閱讀 3556 次)

0 會員 與 1 訪客 正在閱讀本文。

cv86092

  • 懷疑的國中生
  • **
  • 文章數: 49
    • 檢視個人資料
    • http://mic101.idv.st
我的 Server 原本有一顆 HD
/etc/fstab 內容如下︰
LABEL=/                 /                       ext3    defaults,largefiles        1 1
LABEL=/boot             /boot               ext2    defaults        1 2
none                    /dev/pts              devpts  gid=5,mode=620  0 0
none                    /proc                   proc    defaults        0 0
none                    /dev/shm             tmpfs   defaults        0 0
/dev/sda2               swap                 swap    defaults        0 0
/dev/cdrom              /mnt/cdrom       udf,iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                /mnt/floppy         auto    noauto,owner,kudzu 0 0

後來為了要新增容量 mount  /dev/sdb1 掛載上去
不知是 忘了先umount /dev/sdb1 的關係。
重開機後不管有沒有裝/dev/sdb1 這一顆上去,即使是用root, 所有檔案都是 read -only
開機會出現  ..... label=/  have been mounted  ...
然後開機的 log ..ex:boot.log,dmesg.log 都寫不進去
到最後 monitor 無法出現login ,只能用ssh 進去。

希望各位大大能幫我解答,..我不想重灌啊..-_-



 

cv86092

  • 懷疑的國中生
  • **
  • 文章數: 49
    • 檢視個人資料
    • http://mic101.idv.st
sorry 自問自答:
Root File System Is Read-Only
Remount it. If /etc/fstab is correct, you can simply type:

mount -n -o remount /

If /etc/fstab is wrong, you must give the device name and possibly the
type, too: e.g.

mount -n -o remount -t ext2 /dev/hda2 /

To understand how you got into this state, see, ("EXT2-fs: warning:
mounting unchecked file system.")



我把 掛在  /  的 partition 重新mount 一次就好了
我想應該是我的/etc/fstab 有寫錯吧。

Reference :http://www.unixguide.net/linux/faq/04.15.shtml


wst2080

  • 憂鬱的高中生
  • ***
  • 文章數: 93
  • 阿胖資研-鴨鴨
    • 檢視個人資料
mount -o rw,remount /dev/sdd1

sorry 自問自答:
Root File System Is Read-Only
Remount it. If /etc/fstab is correct, you can simply type:

mount -n -o remount /

If /etc/fstab is wrong, you must give the device name and possibly the
type, too: e.g.

mount -n -o remount -t ext2 /dev/hda2 /

To understand how you got into this state, see, ("EXT2-fs: warning:
mounting unchecked file system.")



我把 掛在  /  的 partition 重新mount 一次就好了
我想應該是我的/etc/fstab 有寫錯吧。

Reference :http://www.unixguide.net/linux/faq/04.15.shtml