作者 主題: 安裝ddclient時,安裝依存檔perl出錯  (閱讀 3976 次)

0 會員 與 1 訪客 正在閱讀本文。

THQ

  • 懷疑的國中生
  • **
  • 文章數: 51
    • 檢視個人資料
安裝ddclient時,安裝依存檔perl出錯
« 於: 2007-07-03 19:55 »
│Add of package perl-5.8.6_2 aborted, error code 1 - │
│Please check the debug screen for more info.
應該怎麼辦呢
thx

THQ

  • 懷疑的國中生
  • **
  • 文章數: 51
    • 檢視個人資料
安裝ddclient時,安裝依存檔perl出錯
« 回覆 #1 於: 2007-07-15 09:46 »
-bash-2.05b# make install
===>  Vulnerability check disabled, database not found
===>  Extracting for ddclient-3.6.5
=> Checksum OK for ddclient-3.6.5.tar.gz.
===>   ddclient-3.6.5 depends on file: /usr/local/bin/perl5.8.6 - not found
===>    Verifying install for /usr/local/bin/perl5.8.6 in /usr/ports/lang/perl5.8
===>  Installing for perl-5.8.6_2
===>   Generating temporary packing list
===>  Checking if lang/perl5.8 already installed
===>   An older version of lang/perl5.8 is already installed (perl-5.8.8)
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of lang/perl5.8
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/lang/perl5.8.
*** Error code 1

Stop in /usr/ports/dns/ddclient.

coborla

  • 懷疑的國中生
  • **
  • 文章數: 50
    • 檢視個人資料
安裝ddclient時,安裝依存檔perl出錯
« 回覆 #2 於: 2007-07-15 17:29 »
error log說機器的perl版本不對, 提示你做deinstall or overwrite.

weithenn

  • 懷疑的國中生
  • **
  • 文章數: 88
    • 檢視個人資料
    • http://www.weithenn.idv.tw
安裝ddclient時,安裝依存檔perl出錯
« 回覆 #3 於: 2007-07-16 11:48 »
說你已經裝過這個套件了,看是要 make deinstall 後在 make install 或是使用 make
FORCE_PKG_REGISTER=yes install 覆蓋之前的安裝
~~不斷精進一直是我的目標~~~