作者 主題: php & Apache安裝  (閱讀 4747 次)

0 會員 與 1 訪客 正在閱讀本文。

sidney

  • 憂鬱的高中生
  • ***
  • 文章數: 122
    • 檢視個人資料
php & Apache安裝
« 於: 2005-08-02 18:40 »
我的os為fedora4,php4和php5裡面的函數差了很多,
因此,我的fedora4沒有安裝php5,自行下載php4來安裝,
其於的,如apache、mysql灌好之後就安裝好了,
我去下載php-4.4.0.tar.gz下來安裝,編譯好之後,
要把php的module掛載到apache,但是libphp4.so,我一直找不到,
"LoadModule php4_module libexec/libphp4.so"

我去目錄底下看也找不到,請問這一個檔案要去那邊找呀!?
謝謝!

Darkhero

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 3728
  • 性別: 男
    • 檢視個人資料
    • ㄚ凱隨手紀
php & Apache安裝
« 回覆 #1 於: 2005-08-02 19:10 »
你的編譯過程呢?...
configure 下哪些參數?..
希望我們的討論是為了把問題解決,而不是爭論誰對誰錯.
『灌水才是重點,發文只是順便』
『我寧可讓不會釣魚的工程師餓死,也不想讓會餓死的工程師去攪沉公司....』
Blog: http://blog.darkhero.net/
秘密基地: http://www.darkhero.net/comic/
目前服務的網站: http://www.libook.com.tw/

sidney

  • 憂鬱的高中生
  • ***
  • 文章數: 122
    • 檢視個人資料
php & Apache安裝
« 回覆 #2 於: 2005-08-03 11:57 »
我安裝php時,都沒有下參數!
因為在設定時,說明檔它說:

./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
make
make install

但是我的apache是rpm的,找不到apxs這一個目錄,所以我都沒有下參數耶!
所以我只有做以下的動作:
./configure
make
make install
這三個動作!

kenduest

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 3675
    • 檢視個人資料
    • http://kenduest.sayya.org
php & Apache安裝
« 回覆 #3 於: 2005-08-03 12:50 »
引述: "sidney"
我安裝php時,都沒有下參數!
因為在設定時,說明檔它說:

./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
make
make install

但是我的apache是rpm的,找不到apxs這一個目錄,所以我都沒有下參數耶!
所以我只有做以下的動作:
./configure
make
make install
這三個動作!


apxs 程式一般收錄在 apache-devel or httpd-devel  這類 apckage 內。

==
I am kenduest - 小州

my website: http://kenduest.sayya.org/

Darkhero

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 3728
  • 性別: 男
    • 檢視個人資料
    • ㄚ凱隨手紀
php & Apache安裝
« 回覆 #4 於: 2005-08-03 14:56 »
書是死的.人是活的...

當你遇到跟說明文件不一樣的東西...
應該是要找到解決的方法... 而不是直接 by pass 過去吧...

你這樣永遠不會進步的!!..
希望我們的討論是為了把問題解決,而不是爭論誰對誰錯.
『灌水才是重點,發文只是順便』
『我寧可讓不會釣魚的工程師餓死,也不想讓會餓死的工程師去攪沉公司....』
Blog: http://blog.darkhero.net/
秘密基地: http://www.darkhero.net/comic/
目前服務的網站: http://www.libook.com.tw/

hope24tw

  • 可愛的小學生
  • *
  • 文章數: 9
    • 檢視個人資料
php & Apache安裝
« 回覆 #5 於: 2005-08-08 13:39 »
此行 mysql 部份
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql

如果是 mysql v4.1 得改 --with-mysqli
記的 Fedora Core 4 是 MySQL v4.1.x

還有 php 用編譯的很多模組要啟動,在編譯能都要加上指令,

例如: --with-gd,是啟動 GD 功能,請多爬文吧!