作者 主題: 系統升級  (閱讀 8381 次)

0 會員 與 1 訪客 正在閱讀本文。

梁楓

  • 俺是博士!
  • *****
  • 文章數: 6220
    • 檢視個人資料
系統升級
« 於: 2004-12-23 02:22 »
1. 升級PHP
2. 升級 PHPBB

嗯.. 很爆力的升級法...
所以目前是用測試的方式跑...

有問題請盡速回報...

另,由於升級因素
之前裝的模組全部都不存在...
有需要的請大家提出在安裝...

chenfm

  • 活潑的大學生
  • ***
  • 文章數: 261
    • 檢視個人資料
Re: 系統升級
« 回覆 #1 於: 2004-12-23 09:15 »
引述: "梁楓"
1. 升級PHP
2. 升級 PHPBB

嗯.. 很爆力的升級法...
所以目前是用測試的方式跑...

有問題請盡速回報...

另,由於升級因素
之前裝的模組全部都不存在...
有需要的請大家提出在安裝...


之前那個人氣指數可不可以裝一下?
突然不見了,看起來很不習慣。

u8526425

  • 俺是博士!
  • *****
  • 文章數: 1135
  • 性別: 男
    • 檢視個人資料
系統升級
« 回覆 #2 於: 2004-12-23 10:19 »
快速回應區
簡單好用
多見者博,多聞者智,拒諫者塞,專己者孤

nolan

  • 懷疑的國中生
  • **
  • 文章數: 71
    • 檢視個人資料
學長 問一下子囉
« 回覆 #3 於: 2004-12-24 02:46 »
小弟 剛才 用了  phpBB-2.0.11-files 和 phpBB-2.0.11-patch

的升級方法 ,使用 a學長的 方法, 都還是看的到帳號和密碼  :cry:

後來,用鳥方法 裝個新的 phpbb 很好 沒有看到密碼和帳號

可是,我把原來的/var/db/mysql/phpbb   複製回去

就死翹翹了

可以, 麻煩您 教一下 正確的暴力升級法  :P

梁楓

  • 俺是博士!
  • *****
  • 文章數: 6220
    • 檢視個人資料
系統升級
« 回覆 #4 於: 2004-12-24 02:56 »
你從那個版本升級?

我的升級方法基本上也是建立一個全新的phpBB2
然後在把舊資料轉匯到新資料庫裡

或許你也該注意資料庫本身運行的版本是否有差異?

nolan

  • 懷疑的國中生
  • **
  • 文章數: 71
    • 檢視個人資料
了解 ~您 晚安吧!!
« 回覆 #5 於: 2004-12-24 03:07 »
:oops:

小弟 一開始裝的是 phpbb2.05, 後來 一路走來 使用都用

phpBB-2.0.11-patch 的 方法來升級 升到了phpbb2.011

mysql資料庫一開始 也是 用3.xx版, 後來 有 更新到 4.0x版

可是 一用a學長的 就....

我知道錯了 得到報應  :-?

繼續 升級 中

梁楓

  • 俺是博士!
  • *****
  • 文章數: 6220
    • 檢視個人資料
系統升級
« 回覆 #6 於: 2004-12-24 03:26 »
phpbb mysql3 跟mysql4 用法並不一樣...這個可能你要注意

我為了這個部份刻意不升級mysql3

nolan

  • 懷疑的國中生
  • **
  • 文章數: 71
    • 檢視個人資料
是這樣子的囉
« 回覆 #7 於: 2004-12-24 03:36 »
引述: "梁楓"
phpbb mysql3 跟mysql4 用法並不一樣...這個可能你要注意

我為了這個部份刻意不升級mysql3


我記得 我一開始 有跑 mysql 是用 3.xx版的開始, 後來發現 改一下4.0xx

升級成 4.xx 後

也是 把/var/db/mysql/phpbb 的  複製回去 , 跑了(忘記多久) 都一直ok

可是 現在

我重裝 phpbb2.011  install 是選  4.xx的來新裝  (ps : 是不是 這個問題嘛??)

因為 我現在的機器 是跑 4.xx版的

可是 把 /var/db/mysql/phpbb 的 複製回去

就 還是不行  :cry:

現在 晚了 ,小弟明天要早起  


不吵您 啦   8)

梁楓

  • 俺是博士!
  • *****
  • 文章數: 6220
    • 檢視個人資料
系統升級
« 回覆 #8 於: 2004-12-24 03:44 »
你認為 4.x 跟 3.x 之間的升級,用file copy的方式真的合適嗎?

nolan

  • 懷疑的國中生
  • **
  • 文章數: 71
    • 檢視個人資料
報告 !!
« 回覆 #9 於: 2004-12-24 05:19 »
其實, 小弟 真不知道 版本 不同 不能夠用 file copy ~~不懂  :oops:


我躺著 還是睡不著 因為 功課還沒做好

剛才 試過

用port 安裝 把 mysql 裝成 3.x 版的  mod_php4 重新安裝
 
一樣不成功 ,就把 3.x 版 移掉,裝回成 4.x 版 mod_php4 也重裝過

重裝新的phpbb2.011 後,  想說 先停止mysql 看看

再來 一樣 把file copy回去

成功了  可以

有再使用 a 學長的玩具,   看不到 帳號和密碼了

ps : 只是 所有裝過的mod 還要繼續做功課  :x

VBird

  • 管理員
  • 俺是博士!
  • *****
  • 文章數: 1516
    • 檢視個人資料
    • http://linux.vbird.org
系統升級
« 回覆 #10 於: 2004-12-24 09:28 »
我是不知道會怎樣啦~
不過,我都是以 patch 的方法來升級的,
這樣一來,原本裝的 mod 才不會不見~
即使出現升級問題,其實也很簡單,將無法升級的 file 複製過來,
這樣就 OK 了~

nolan

  • 懷疑的國中生
  • **
  • 文章數: 71
    • 檢視個人資料
鳥哥長官 ^^
« 回覆 #11 於: 2004-12-25 03:31 »
小弟  實驗 了 好多次

其實,

 目的 就是 要確定 a學長 的 語法 不會 把 機器 的 user & pwd 看光光

因為 只有 一句話  沒有 這個 語法 !!

感謝  A 學長    :P

PHPBB 竟然 會成箭靶   :evil: