作者 主題: [問題]請問安裝mplayer的問題  (閱讀 3592 次)

0 會員 與 1 訪客 正在閱讀本文。

littleq

  • 可愛的小學生
  • *
  • 文章數: 24
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 於: 2004-10-19 12:43 »
warning: mplayer-common-1.0pre5-1.i386.rpm: V3 DSA signature: NOKEY, key ID 75aa026a
error: Failed dependencies:
        mplayer = 2:1.0pre5 is needed by mplayer-common-1.0pre5-1


大家好,我用rh9,在mplayer官網抓了rh9的兩個rpm檔
mplayer-common-1.0pre5-1.i386.rpm
mplayer-1.0pre5-1.i386.rpm
不論裝那一個都是一樣的錯誤訊息.

我想請問各位大大這是相依性的問題嘛?

謝謝

phantom

  • SA 苦力組
  • 俺是博士!
  • *****
  • 文章數: 2185
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #1 於: 2004-10-19 12:51 »
兩個一起裝呢?

rpm -ivh mplayer-common-1.0pre5-1.i386.rpm mplayer-1.0pre5-1.i386.rpm
Linux 非萬能, 沒 Linux 萬萬不能.
root = God
apt-get install ultimate-horsepower

littleq

  • 可愛的小學生
  • *
  • 文章數: 24
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #2 於: 2004-10-19 13:01 »
耶 可以了
對不起我太嫩了...

我有注意到下載頁有這樣教
沒想到居然是失敗的關鍵
太可怕了 ...

謝謝大大指導

phantom

  • SA 苦力組
  • 俺是博士!
  • *****
  • 文章數: 2185
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #3 於: 2004-10-19 13:13 »
引述: "littleq"
耶 可以了
對不起我太嫩了...

我有注意到下載頁有這樣教
沒想到居然是失敗的關鍵
太可怕了 ...

謝謝大大指導


不客氣. 多玩幾次. 失敗為成功知母...  :lol:
Linux 非萬能, 沒 Linux 萬萬不能.
root = God
apt-get install ultimate-horsepower

littleq

  • 可愛的小學生
  • *
  • 文章數: 24
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #4 於: 2004-10-19 13:30 »
大大可以在請問一個問題嘛?
skin要丟到那裡? 我抓的是bz2的檔案
裡面的readme沒有說明

我準備看官方的說明,不過這邊網路有問題還在努力開....

littleq

  • 可愛的小學生
  • *
  • 文章數: 24
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #5 於: 2004-10-19 13:38 »
終於進去說明頁了

因为MPlayer不自带skin,所以如果你想要使用GUI,你必须自己下载它们。参见下载页。他们应该被解压到系统通用的目录($PREFIX/share/mplayer/Skin),或者解压到$HOME/.mplayer/Skin。 MPlayer在默认情况下会在这些的目录里寻找一个叫default的目录,但是你能使用-skin newskin选项或在config文件中添加skin=newskin来强制使用*/Skin/newskin目录下的skin。

phantom

  • SA 苦力組
  • 俺是博士!
  • *****
  • 文章數: 2185
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #6 於: 2004-10-19 13:40 »
引述: "littleq"
大大可以在請問一個問題嘛?
skin要丟到那裡? 我抓的是bz2的檔案
裡面的readme沒有說明

我準備看官方的說明,不過這邊網路有問題還在努力開....


不一定要上網找啊...

試試看: 裡面就有說明
man mplayer
Linux 非萬能, 沒 Linux 萬萬不能.
root = God
apt-get install ultimate-horsepower

littleq

  • 可愛的小學生
  • *
  • 文章數: 24
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #7 於: 2004-10-19 14:21 »
GUI需要GTK 1.2.x(它不是GTK的,但是面板是的)。skin被保存为PNG格式,因此你需要安装gtk,libpng(和他们的devel包,一般是gtk-dev和libpng-dev)。你必须在运行./configure时使用--enable-gui来编译它的代码。然后,你可以用下列方法之一打开GUI方式

    * 在你的config文件中添加gui=yes
    * ln -s $PREFIX/bin/mplayer $PREFIX/bin/gmplayer,然后运行gmplayer。


大大請問一下這個gtk是必備的嘛?
我裝了skin還是不能裝gui,他說我沒有skin
目前還在跟gtk搏鬥,因為相依性檔案很多...

littleq

  • 可愛的小學生
  • *
  • 文章數: 24
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #8 於: 2004-10-19 14:49 »
終於搞定了~
後來直接去搜尋ski的rpm檔
裝完後在裝gui,也不知道裝那去了,rpm查不到
我在/usr/bin 裡面執行gmplayer可以執行
不過我有裝mencoder 但目前不能波mov
我有下載另外的codec,看來已經接近完工了

搞了一整天...

HaWay

  • 大隻佬!
  • 老人組
  • 俺是博士!
  • *****
  • 文章數: 3980
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #9 於: 2004-10-19 19:23 »
查 rpm 裝到那去了
rpm -ql xxx.rpm
我做人那麼 nice, 肯定有什麼誤會.....

littleq

  • 可愛的小學生
  • *
  • 文章數: 24
    • 檢視個人資料
[問題]請問安裝mplayer的問題
« 回覆 #10 於: 2004-10-19 23:25 »
我裝好了,要裝的東西超多的...
發覺真是累啊~