作者 主題: OpenWebMail 裝好後,不能寄信..只給我一個錯誤訊息..要 如何才能寄信呢??  (閱讀 6093 次)

0 會員 與 1 訪客 正在閱讀本文。

minlibra

  • 可愛的小學生
  • *
  • 文章數: 22
    • 檢視個人資料
OpenWebMail 裝好後,不能寄信..只給我一個錯誤訊息..要 如何才能寄信呢??

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, root@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


--------------------------------------------------------------------------------

Apache/2.0.47 (Fedora) Server at www.qubasia.org Port 80

Tim

  • 活潑的大學生
  • ***
  • 文章數: 450
  • 性別: 男
    • 檢視個人資料
    • http://www.lab.mlc.edu.tw/
可能是 perl 的問題。

damon

  • 管理員
  • 俺是博士!
  • *****
  • 文章數: 4227
    • 檢視個人資料
    • http://blog.damon.tw/

minlibra

  • 可愛的小學生
  • *
  • 文章數: 22
    • 檢視個人資料
???看哪一個 Log丫
« 回覆 #3 於: 2004-09-02 15:28 »
Thu Sep  2 15:03:30 2004 - [5360] (140.131.7.111) charles - login - charles*-session-***************
Thu Sep  2 15:05:28 2004 - [5374] (140.131.7.111) charles - webdisk download - /req.pem
Thu Sep  2 15:07:17 2004 - [5390] (140.131.7.111) charles - logout - charles*-session-***************
Thu Sep  2 15:07:50 2004 - [5394] (140.131.7.111) charles - login - charles*-session-***************
Thu Sep  2 15:18:14 2004 - [5416] (140.131.7.111) charles - folder - refresh, 0errors
Thu Sep  2 15:18:16 2004 - [5417] (140.131.7.111) charles - folder - refresh, 0
errors

damon

  • 管理員
  • 俺是博士!
  • *****
  • 文章數: 4227
    • 檢視個人資料
    • http://blog.damon.tw/
要列log的話請列有用的

minlibra

  • 可愛的小學生
  • *
  • 文章數: 22
    • 檢視個人資料
這是/var/log/httpd/error_log
« 回覆 #5 於: 2004-09-04 10:40 »
這是/var/log/httpd/error_log  ^^|||

[Thu Sep 02 20:12:35 2004] [error] [client 218.175.35.173] Premature end of scri
pt headers: openwebmail-send.pl, referer: http://www.qubasia.org/cgi-bin/openweb
mail/openwebmail-main.pl?action=listmessages&sessionid=charles*-session-0.616458
062854694&sort=date&page=1&folder=INBOX
[Thu Sep 02 20:12:35 2004] [error] [client 218.175.35.173] /usr/bin/suidperl: re
location error: /usr/lib/perl5/site_perl/5.8.1/i386-linux-thread-multi/auto/Text
/Iconv/Iconv.so: undefined symbol: libiconv_open, referer: http://www.qubasia.or
g/cgi-bin/openwebmail/openwebmail-main.pl?action=listmessages&sessionid=charles*
-session-0.616458062854694&sort=date&page=1&folder=INBOX

carldai

  • 懷疑的國中生
  • **
  • 文章數: 55
    • 檢視個人資料
這個
« 回覆 #6 於: 2004-09-04 11:01 »
perl-suidperl-
perl-Compress-Zlib-
perl-CGI-
perl-Text-Iconv
這些都有裝嗎 ?

pawnjazz

  • 懷疑的國中生
  • **
  • 文章數: 61
    • 檢視個人資料
直接在終端機下可以寄信嗎?
Like     #> mail  minlibra@xxx.yyy.zzz < /etc/passwd
如果這些寄不出,則openwebmail 也寄不出

zterry26

  • 鑽研的研究生
  • *****
  • 文章數: 596
    • 檢視個人資料
各位大大:
sorry.小弟目前的狀況是有終端機模式下以mail指令可以發信給外部,
但是用openwebmail就是不行,怎樣都發不出去呢,
Tue Oct 19 11:24:25 2004 - [4308] (10.10.10.13) galaxy - login - galaxy*-session
-0.814695135996775 - active=0,0,0
Tue Oct 19 11:24:26 2004 - [4309] (10.10.10.13) galaxy - clean trash - all msg d
eleted from mail-trash
Tue Oct 19 11:24:44 2004 - [4313] (10.10.10.13) galaxy - send message - subject=
ttt - to=zterry26@yahoo.com.tw
Tue Oct 19 11:28:25 2004 - [4384] (10.10.10.13) galaxy - send message - subject=
ttt - to=zterry26@hotmail.com, cc=zterry26@yahoo.com.tw
Tue Oct 19 11:38:29 2004 - [4539] (10.10.10.13) galaxy - session error - session
 galaxy*-session-0.814695135996775 timeout access attempt
造log來看,應該是正常的啊,請
各位大大指點,
感謝

new_bsd

  • 可愛的小學生
  • *
  • 文章數: 4
    • 檢視個人資料
我有兩部openwebmail的主機,一部是FreeBSD 4.9,另一部FreeBSD5.2.1
每次作完portupgrate後,5.2.1那一部就會出現和你相同的問題
openwebmail的FAQ有提到幾個解決方法,但我試過都沒效
最後試出不裝speedCGI就能使用
不知道對你有沒有幫助 :roll: