作者 主題: [問題]openwebmail圖片出不來....有搜尋過文章  (閱讀 2429 次)

0 會員 與 1 訪客 正在閱讀本文。

sakana

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 2589
  • 性別: 男
    • 檢視個人資料
    • sakananote
小弟是用REDHAT 9.0 + OPENWEBMAIL 2.30 RPM

在/var/www/cgi-bin/openwebmail/etc/openwebmail.conf
小弟比對了一下家裡內網跟公司的設定有一些不一樣
這是公司的
releasedate                       20040103
domainnames                       auto
auth_module                       auth_unix.pl
mailspooldir                      /var/mail
# To check the correct values for dbm options:
# 1) cd /var/www/cgi-bin/openwebmail
# 2) ./openebmail-tool.pl --init'
dbm_ext                           .db
dbmopen_ext                       .db
dbmopen_haslock                   yes
ow_cgidir                         /var/www/cgi-bin/openwebmail
ow_cgiurl                         /cgi-bin/openwebmail
ow_htmldir                        /var/www/html/openwebmail
ow_htmlurl                        /openwebmail
logfile                           /var/log/openwebmail.log
spellcheck                        /usr/bin/aspell

這是家裡的
releasedate                       20040131
domainnames                       auto
auth_module                       auth_unix.pl
mailspooldir                      /var/mail
ow_cgidir                         /var/www/cgi-bin/openwebmail
ow_cgiurl                         /cgi-bin/openwebmail
ow_htmldir                        /var/www/data/openwebmail
ow_htmlurl                        /data/openwebmail
logfile                           /var/log/openwebmail.log
spellcheck                        /usr/bin/aspell

可是小弟在安裝的方法都一樣.......
為何會出現兩種conf???
小弟家裡內網的機器都粉正常
建立一個 index.html 在/var/www/html, 內容如下

<html><head>
<meta http-equiv="Refresh"
content="0;URL=http://your_server/cgi-bin/openwebmail/openwebmail.pl">
</head></html>

公司我用virtual host
<VirtualHost *>
    ServerAdmin max@pcgm.adsldns.org
    DocumentRoot /var/www/html/xoops/html
    ServerName www.pcgm.adsldns.org
</VirtualHost>

<VirtualHost *>
    ServerAdmin max@pcgm.adsldns.org
    DocumentRoot /var/www/html
    ServerName mail.pcgm.adsldns.org
</VirtualHost>

當小弟在瀏覽器打mail.pcgm.adsldns.org
可以連上openwebmail
但是所有圖示都看不見
請問各位大大小弟哪裡錯了呢
請幫幫小弟謝謝各位
感激不盡
謝謝
專心投入研究才是王道!!
http://sakananote2.blogspot.com

SkyJou

  • 憂鬱的高中生
  • ***
  • 文章數: 112
    • 檢視個人資料
[問題]openwebmail圖片出不來....有搜尋過文章
« 回覆 #1 於: 2004-02-06 19:49 »
或許是因為virtual host的關係,你可以試試看:ln -s /var/www/data /var/www/html,不過owm應該本來就會這樣做,如果預設目錄是/var/www/html的話?