作者 主題: mod_auth_mysql 問題  (閱讀 2052 次)

0 會員 與 1 訪客 正在閱讀本文。

neil_mio

  • 可愛的小學生
  • *
  • 文章數: 9
    • 檢視個人資料
mod_auth_mysql 問題
« 於: 2003-06-27 15:09 »
是不是 mod_auth_mysql 不能在  apache 2.0.X 上安裝的呢...己經用

./configure --with-apache=/usr/local/src/apache_version --with-mysql=/usr
執行不成功.出現找不到 httpd.h 的錯誤.

又試過
/usr/local/apache/bin/apxs -i -a -I/usr/include/mysql -L/usr/lib/mysql \
        -lmysqlclient -c mod_auth_mysql.c
又出現錯誤是不是不能在 apache 2.0X 上安裝 mod_auth_mysql 呢?
還是雖要找別的版本呢
己經是 mod_auth_mysql-2.20 了

..謝謝指教


..!!

abelyang

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 1097
    • 檢視個人資料
mod_auth_mysql 問題
« 回覆 #1 於: 2003-06-27 15:44 »
是的~~
打包票和你說不能在 2.x 上跑 ~~
不然本來我還想貼個 User Guide 上來呢 ...
2.x 不能跑我就不打算貼了
你 Complier 時的錯誤訊息會有寫哦 ~~

PS: 我自己用 gcc 去做, -I 都指出來了, 就是不行

如果你還是要用 DB 做 HTTP Auth, 建議你改用 PERL 的方法
你可以到 www.cpan.org 找 Apache 的模組看看

neil_mio

  • 可愛的小學生
  • *
  • 文章數: 9
    • 檢視個人資料
mod_auth_mysql 問題
« 回覆 #2 於: 2003-06-30 00:30 »
我在 compile 時只顯示沒有 httpd.h 檔案,沒有指出不能在 2.0.x 下不能安裝 mod_auth_mysql 的.

謝謝你的指教...^^

abelyang

  • 酷!學園 學長們
  • 俺是博士!
  • *****
  • 文章數: 1097
    • 檢視個人資料
mod_auth_mysql 問題
« 回覆 #3 於: 2003-06-30 00:35 »
是的,沒有錯,用 apxs 所顯示的訊息是如此
但是過於簡單, 所以我用 gcc 自己動手一步一步做這個 DSO
所以才看得到問題所在