作者 主題: 有關安裝VMware的問題...  (閱讀 5501 次)

0 會員 與 1 訪客 正在閱讀本文。

淺倉中

  • 憂鬱的高中生
  • ***
  • 文章數: 145
    • 檢視個人資料
    • http://www.shizuka.adsldns.org
有關安裝VMware的問題...
« 於: 2002-11-30 20:29 »
有好幾個有關VMware的問題想請先進們指正一下....

拜脫了....

----------------------------------------------

1.原本我安裝好RHL7.3 (kernel 2.4.18-3)...也安裝好了

  Vmware,在其中安裝了win2000。但是後來因為去跑了

  windows update,使得我的win2000掛掉了,要重灌VMware..

  慘的是 : 我的RHL7.3因為去RHN進行up2date更新...使得

  kernel 更新為2.4.18-18.7.x 。後來想要再安裝VMware

  的時候就跟我說 :

  What is the location of the directory of C headers

  files that match your running kernel ? /usr/include <<--輸入

  結果出現...

  The directory of kernel headers (Version 2.4.9-9) does

  not match your running kernel(Version 2.4.18-18.7.x).

  Even if the module were to compile successfully, it

  would not load into the running kernel.

  我想問的是,是不是找到或是能夠下載解開來針對新的kernel

  的 C headers files,就可以安裝了...但是怎樣我都找不到

  這些 *.c 的檔案耶....可以請高手指正一下ㄇ?? 還是VMware

  現在就是沒辦法支援到這樣新的kernel版本???

2.我的RHL7.3 server上有兩張網卡...一張是對外(ADSL,eth0)

  一張是對內(NAT,eth1)..這樣的話~~當我在安裝VMware時...

  它會問我說要使用哪張網卡???? (如果我是用 bridge的方式

  不是說 host端和 guest端是共用一張實體網卡ㄇ??) 是eth0

  還是 eth1呢????

4flash5

  • 可愛的小學生
  • *
  • 文章數: 1
    • 檢視個人資料
有關安裝VMware的問題...
« 回覆 #1 於: 2003-05-28 19:42 »
其實我也想問
因為我是在 Win 2000 上面試裝 RH 9.0
running kernel 是 2.4.20-8 但是 header files 都是 2.4.20
結果 vmware-tools 就一直裝不起來
不知道怎麼辦?

Tetralet

  • 活潑的大學生
  • ***
  • 文章數: 370
    • 檢視個人資料
Re: 有關安裝VMware的問題...
« 回覆 #2 於: 2003-05-28 23:35 »
引述: "淺倉中"
有好幾個有關VMware的問題想請先進們指正一下....

拜脫了....

----------------------------------------------

1.原本我安裝好RHL7.3 (kernel 2.4.18-3)...也安裝好了

  Vmware,在其中安裝了win2000。但是後來因為去跑了

  windows update,使得我的win2000掛掉了,要重灌VMware..

  慘的是 : 我的RHL7.3因為去RHN進行up2date更新...使得

  kernel 更新為2.4.18-18.7.x 。後來想要再安裝VMware

  的時候就跟我說 :

  What is the location of the directory of C headers

  files that match your running kernel ? /usr/include <<--輸入

  結果出現...

  The directory of kernel headers (Version 2.4.9-9) does

  not match your running kernel(Version 2.4.18-18.7.x).

  Even if the module were to compile successfully, it

  would not load into the running kernel.

  我想問的是,是不是找到或是能夠下載解開來針對新的kernel

  的 C headers files,就可以安裝了...但是怎樣我都找不到

  這些 *.c 的檔案耶....可以請高手指正一下ㄇ?? 還是VMware

  現在就是沒辦法支援到這樣新的kernel版本???


我現在用的是 2.4.20 版,
vmware 一樣能用,
所以不是 Kernel 的問題。

問題是出在 vmware 的 ethernet 卡必須要能符合您的系統,
最快的方法是重新把 vmware 再裝一次。


引述: "淺倉中"

2.我的RHL7.3 server上有兩張網卡...一張是對外(ADSL,eth0)

  一張是對內(NAT,eth1)..這樣的話~~當我在安裝VMware時...

  它會問我說要使用哪張網卡???? (如果我是用 bridge的方式

  不是說 host端和 guest端是共用一張實體網卡ㄇ??) 是eth0

  還是 eth1呢????


我記得好像有一個地方可以指定吧...
(也好像是舊的版本才可以)
但是我現在只有一張網卡,
找不到在哪裡...

明月舞清風

  • 憂鬱的高中生
  • ***
  • 文章數: 173
    • 檢視個人資料
有關安裝VMware的問題...
« 回覆 #3 於: 2003-05-30 17:12 »
Q1的部份是因為VMWare的安裝過程中,會用您的kernel source(就是那些c headers)來協助編譯vmware主程式,所以會有kernel的相依性。

解決方法呢?很簡單,在你更新kernel後,也請您把kernel source一起更新後,重新安裝vmware這樣就可以了。安裝時請丟給vmware installer您kernel source的位置(如/usr/src/linux-2.4.20-8。這是我的rh9,請依您的狀況修改)就OK了。

(補充:kernel source的版本必須跟kernel一樣。所以如果您是用rpm update kernel,請同時抓下新版kernel's source的rpm來安裝,以利vmware的安裝過程)

Q2...我覺得應該要看你要把vmware擺在那邊。如果要放在下層的話,那就是eth1。反之亦然。
(簡單來說,請把vmware當作一台實體的機器,看你要擺內部還是放在外部網路上了。)

Q3...VMware Tools無法在linux guest下直接安裝?請翻一下您vmware安裝的資料夾(我的是/usr/lib/vmware/isoimages。),裡面有個isoimages資料夾中有幾個特別的ISO。請把linux.iso掛到vmware的CDROM中後查看裡面內容,會有解決的辦法。^^