作者 主題: 有關升級openssl的問題  (閱讀 7275 次)

0 會員 與 1 訪客 正在閱讀本文。

hopeliao

  • 活潑的大學生
  • ***
  • 文章數: 319
    • 檢視個人資料
有關升級openssl的問題
« 於: 2002-10-16 14:12 »
各位前輩大家好,我的Linux是RedHat 7.0
Openssl的版本如下:
openssl-0.9.5a-14
openssl-devel-0.9.5a-14
因為怕中到Slapper的毒,所以想升級到最新版,
利用搜尋找到了可以到
 http://rhn.redhat.com/errata/RHSA-2002-160.html#Red%20Hat%20Linux%207.0
依REDHAT的版本下載新的Openssl..
我是7.0所以下載了
openssl-0.9.6-13.i386.rpm        openssl-python-0.9.6-13.i386.rpm
openssl-devel-0.9.6-13.i386.rpm  openssl095a-0.9.5a-18.i386.rpm
openssl-perl-0.9.6-13.i386.rpm
可是當我執行 rpm -Fvh openssl*時,卻發生了
 rpm -Fvh openssl*
error: failed dependencies:
        libcrypto.so.0 is needed by cyrus-sasl-1.5.24-11
        libcrypto.so.0 is needed by openssh-2.3.0p1-4
        libcrypto.so.0 is needed by openssh-clients-2.3.0p1-4
        libcrypto.so.0 is needed by openssh-server-2.3.0p1-4
        libcrypto.so.0 is needed by python-1.5.2-27
        libcrypto.so.0 is needed by samba-2.0.7-21ssl
        libcrypto.so.0 is needed by samba-client-2.0.7-21ssl
        libcrypto.so.0 is needed by samba-common-2.0.7-21ssl
        libcrypto.so.0 is needed by stunnel-3.10-2
        libssl.so.0 is needed by python-1.5.2-27
        libssl.so.0 is needed by samba-2.0.7-21ssl
        libssl.so.0 is needed by samba-client-2.0.7-21ssl
        libssl.so.0 is needed by samba-common-2.0.7-21ssl
        libssl.so.0 is needed by stunnel-3.10-2
請問該如何解決呢@????

zoob

  • 鑽研的研究生
  • *****
  • 文章數: 776
    • 檢視個人資料
    • http://www.myunix.idv.tw
Re: 有關升級openssl的問題
« 回覆 #1 於: 2002-10-16 14:53 »
引述: "hopeliao"
各位前輩大家好,我的Linux是RedHat 7.0
Openssl的版本如下:
openssl-0.9.5a-14
openssl-devel-0.9.5a-14
因為怕中到Slapper的毒,所以想升級到最新版,
利用搜尋找到了可以到
 http://rhn.redhat.com/errata/RHSA-2002-160.html#Red%20Hat%20Linux%207.0
依REDHAT的版本下載新的Openssl..
我是7.0所以下載了
openssl-0.9.6-13.i386.rpm        openssl-python-0.9.6-13.i386.rpm
openssl-devel-0.9.6-13.i386.rpm  openssl095a-0.9.5a-18.i386.rpm
openssl-perl-0.9.6-13.i386.rpm
可是當我執行 rpm -Fvh openssl*時,卻發生了
 rpm -Fvh openssl*


--nodeps  don't verify package dependencies

rpm -Fvh --nodeps openssl*

hopeliao

  • 活潑的大學生
  • ***
  • 文章數: 319
    • 檢視個人資料
有關升級openssl的問題
« 回覆 #2 於: 2002-10-16 15:26 »
原來加上 --nodeps就可以了@@謝謝了!!
rpm -Fvh --nodeps openssl*

對了, 公司另一台SERVER好像中了@@, 真是後知後覺!!
我目前打算如此做~不知道是否正確!
1. stop http
2. kill /tmp/.*
3. update openssl*
4. start http

請問這樣做法正確嗎?是否還少什麼步驟呢??

zoob

  • 鑽研的研究生
  • *****
  • 文章數: 776
    • 檢視個人資料
    • http://www.myunix.idv.tw
有關升級openssl的問題
« 回覆 #3 於: 2002-10-16 15:37 »
引述: "hopeliao"
原來加上 --nodeps就可以了@@謝謝了!!
rpm -Fvh --nodeps openssl*

對了, 公司另一台SERVER好像中了@@, 真是後知後覺!!
我目前打算如此做~不知道是否正確!
1. stop http
2. kill /tmp/.*
3. update openssl*
4. start http

請問這樣做法正確嗎?是否還少什麼步驟呢??


記得update mod_ssl packet

hopeliao

  • 活潑的大學生
  • ***
  • 文章數: 319
    • 檢視個人資料
有關升級openssl的問題
« 回覆 #4 於: 2002-10-16 15:46 »
引述: "zoob"
[
記得update mod_ssl packet

您的意思是??
samba-2.0.7-21ssl
samba-common-2.0.7-21ssl
openssl-devel-0.9.6-13
samba-client-2.0.7-21ssl
openssl-0.9.6-13
mod_ssl-2.0.30
上面這些有關ssl的都要升級嗎?還是只要升級mod_ssl呢??
另外再請問您一下,
RedHat 8.0預設的openSSL是openssl-0.9.6b-29版,而不是openssl-0.9.6g以後的版本..是否也會受到Slapper的毒害呢??