作者 主題: 為什麼我的 GD 函數無法使用??  (閱讀 7069 次)

0 會員 與 1 訪客 正在閱讀本文。

TyroneYeh

  • 俺是博士!
  • *****
  • 文章數: 2396
  • 性別: 男
    • 檢視個人資料
為什麼我的 GD 函數無法使用??
« 於: 2002-07-05 19:04 »
我的手動編譯的 gd-1.8.4, 在安裝 php-4.2.1 也是手動編譯,
出現的錯誤訊息如下:
Call to undefined function: imagepng()
說沒有這個 功能,
小弟設定 php-4.2.1 的時候 configure 是這樣下的
./configure --with-apache=/usr/local/apache_1.3.26 --with-mysql=/usr/local/mysql --with-gd=/usr/local --with-jpeg-dir=/usr/local --with-png-dir=/usr/local -with-freetype-dir=/usr/local --with-iodbc=/usr/local --with-xml --with-pgsql --with-zip=/usr/local --with-zlib-dir=/usr/local --with-java=/usr/local/java --with-mm --enable-trans-gid --enable-track-vars

我的 gd 只用 make ; make install
PHP 是正常的, 就是 GD 函數問題
--
TyroneYeh

TyroneYeh

  • 俺是博士!
  • *****
  • 文章數: 2396
  • 性別: 男
    • 檢視個人資料
為什麼我的 GD 函數無法使用??
« 回覆 #1 於: 2002-07-10 09:11 »
怎麼都無人回應, 最後還是小弟試了 N 遍終於可以用了,
不過弄不出來支援 Gif , 是否有先進有可以讓 GD-1.8.4 支援 gif 功能的呢?

找了一些資料是說 1.6.2 以前的版本才支援, 因為是 Gif 權利金問題, 意思就是說
要把 Gif 功能加到 GD , Gif 的設計人要向 GD 的開發者收權利金, 所以在後面的版本都不支援 Gif 了

不過看了一些資料, 有可以自行改成支援 Gif 不知道有先進有試過嗎?
--
TyroneYeh

duncanlo

  • SA 苦力組
  • 俺是博士!
  • *****
  • 文章數: 7312
    • 檢視個人資料
為什麼我的 GD 函數無法使用??
« 回覆 #2 於: 2002-07-10 09:28 »
這我也沒試過,
我還沒看我裝了那個版本的GD函數..

小穎

  • 俺是博士!
  • *****
  • 文章數: 1005
    • 檢視個人資料
為什麼我的 GD 函數無法使用??
« 回覆 #3 於: 2002-07-10 09:44 »
png不是比較好用嗎?^^
未來的主流(別人說地)

TyroneYeh

  • 俺是博士!
  • *****
  • 文章數: 2396
  • 性別: 男
    • 檢視個人資料
為什麼我的 GD 函數無法使用??
« 回覆 #4 於: 2002-07-10 12:27 »
PNG 是還不錯, 不過小弟想, Gif 的格式一般檔案大小都比其他格式小許多, 其實不支援也實在可惜,
小弟因為在試一個賀卡程式, 它有個郵票是 PNG 的圖檔, 它可以在那圖檔上, 寫上日期與網站資訊, 把 GD 與 PHP 弄到支援 PNG & Freetype1/2 等 , 小弟也裝到快抓狂, 因為是 .tar.gz 的檔案抓回來編譯, 用 rpm 的安裝, 有些函數一樣不能用(可能是我太早把 rpm 的 php 給移除掉了, 是不是真的不能直接用也不太記得),

感覺上已經算是很滿意, 下次有找到讓 GD 支援 GIF 的文章在來試試囉!
謝謝
--
TyroneYeh

TyroneYeh

  • 俺是博士!
  • *****
  • 文章數: 2396
  • 性別: 男
    • 檢視個人資料
為什麼我的 GD 函數無法使用??
« 回覆 #5 於: 2002-07-10 12:41 »
試試看 GD 的好玩之處, 小弟修改過的測試一個 GD 製作 PNG 的網頁
http://siryeh.com/tests/test.php?keyword=測試中文功能

把 keyword= 後面的字改過馬上圖形中的字就會跟著改變唷!
--
TyroneYeh